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内容提要
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前　言



经济管理是离不开数据的，对数据的处理、分析、解释就需要借助统计分析方法，“用数据说话”是科学决策的必要手段。而大量的数据分析靠手工是很难完成的，现代的数据整理与分析都需要利用软件高效准确地实现统计分析。SPSS是国际通用的专业统计分析软件，熟练运用SPSS软件的核心功能和分析方法，将会使我们的统计工作更为专业高效。

与众多SPSS软件书籍不同，本书是从研究的对象与目的或需要解决的问题出发，注重严谨的数理统计逻辑演绎，围绕研究目的的完整实现与问题的系统解决，重点介绍统计分析的方案设计与方法选用及其SPSS实现，以准确、合理地利用统计分析结果解释现象发掘规律。值得注意的是，限于篇幅，本书没有对所有的操作结果做详尽具体的分析解释，不是因为这一部分不重要，而是因为这可以作为课堂理论教学与案例讲析的延伸，也可以为学生们课后学习应用统计分析方法提供广阔的空间。

全书以给综合性问题提出系统性统计分析解决方案为导向，以实验项目形式编排内容，可以作为统计分析技能培养的综合性实验教学指导用书，可以用做统计分析理论教学与学习用书，也可以作为统计分析和决策人士技能提升书籍阅读。

实验教学是应用技能培养的必要手段之一，由茆训诚教授策划的本套大学本科经济管理类专业实验指导系列教材就是服务于经济管理类应用创新人才综合统计分析技能培养的，本书是其中一本，共安排有综合性统计实验项目11个。王周伟提出了本书的编写框架，编写了第1至第6个以及第11个统计计算与分析项目，并完成了全书的统稿工作；朱敏编写了第7个至第10个统计计算与分析项目。书中范例的数据、计算软件可以向编著者索取。联系邮箱为：wangzhouw@163.com。

该书的出版是编者们多年教学经验的总结，书中错误或不当之处恳请广大读者批评指正。

编著者

2011年9月
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实验1　样本均值的描述统计与分布拟合






1.1　实验目的



通过本次实验操作练习，掌握特定分布随机数的生成、随机抽样的操作，掌握数据的图表概括展示与描述统计，掌握利用分布特征指标、P-P图、Q-Q图等判断数据分布的方法；掌握卡方检验与K-S检验方法的基本原理与操作。




1.2　实验原理






1.2.1　数据收集



抽样是从总体中抽取一部分单位作为样本，并根据样本数量特征对总体数量特征做出具有一定可靠性的估计与推断。它是一种数据直接收集的方法。

数据收集与抽样方法可以归纳如图1.1所示。




图1.1　数据收集及抽样方法




1.2.2　描述统计



描述统计主要是为反映总体特征，利用图、表或指标对数据进行整理、分析与综合概括。数据展示用的图可以归纳为表1.1。

表1.1　数据展示用的图




（续表）




描述统计指标的类别可以归纳为图1.2、图1.3。




图1.2　描述统计指标体系




图1.3　描述统计的静态指标体系




1.2.3　数据分组



数据分组的步骤可以分为：

（1）确定数据的最大、最小值；

（2）确定组数；

（3）计算组距；

（4）确定各组的上限、下限；

（5）分组统计落入该组的数据个数。




1.2.4　P-P图与Q-Q图



检验数据是否服从某种分布的图形判断方法就是绘制P-P图、Q-Q图。两个图形制作原理、方法相似，都是用一条第一象限内45度的直线，判断两个分布值序列的一致性；不同的是，P-P图是用观测数据的实际累积概率与其所选择的先验理论分布的对应累积概率作为坐标值绘制的散点图；而Q-Q图则是根据观测值的实际分位数与其所选择的理论分布的对应分位数作为坐标值绘制的散点图。它们可以用于任何一种分布拟合检验，适用范围较为广泛。

下面以标准正态Q-Q图为例，说明绘制步骤：

（1）将样本数据x

1


 ，x

2


 ，…，x

j


 ，…，x

n


 ，从小到大排列成x

（1）


 ，x

（2）


 ，…，x

（j）


 ，…，x

（n）


 。这里的x

（1）


 是最小观测值，x

（n）


 是最大观测值。

（2）求出样本数据的标准正态分位数z

j


 。标准正态分位数z

j


 满足




（3）以z

j


 为纵轴，x

j


 为横轴，绘制出的图形即为标准正态概率图，即标准正态Q-Q图。

如果数据服从正态分布，由坐标（x

j


 ，z

j


 ）描绘的点都将紧密围绕在一条45度直线的两侧。




1.2.5　卡方检验



卡方检验法即卡方拟合优度检验法，它是由各组段的实际频数和理论频数的差异求出卡方统计量值，并和卡方临界值比较，做出分布拟合程度判断的结论。

其基本过程为：

（1）对数据进行预处理或统计分组整理，计算出数据的概括性度量指标（如众数、中位数、平均数、标准差等），画出频率分布直方图及累积概率曲线，分析损失分布的大体轮廓及特征；

（2）根据上述初步判断，从已知的理论概率分布中选择一种可以合理近似的概率分布类型，比如选择正态分布、伽马分布、韦伯分布等；

（3）运用矩估计法或最大似然法估计分布参数，确定理论概率分布函数；

（4）对分布拟合程度进行卡方（χ

2


 ）拟合优度检验。

设组数为n，组内数据频数为O

i


 ，根据所选择的概率分布计算出每一组的理论频数为E

i


 ，则有卡方检验统计量：




即近似服从自由度为n-r-1的卡方分布，其中r为所选择的概率分布中参数的个数。

卡方（χ

2


 ）拟合优度检验的步骤如下：

（1）提出检验的假设：H

0


 ：服从所选择的理论分布；H

1


 ：并非所选择的理论分布；

（2）计算总样本数即总频数、样本平均值和方差，估计理论分布参数，建立理论分布函数；

（3）数据分组，统计组内数据频数，即实际发生频数O

i


 ；

（4）利用所选择的理论分布函数，计算分组区间对应的理论概率；

（5）用分组区间对应的理论概率乘以组距，计算该区间所选择分布的理论频数E

i


 ；

（6）计算卡方检验统计量
 ，并计算拟合优度卡方（χ

2


 ）检验统计量的临界值χ

2


 （1-α，n-r-1）及其对应的显著水平；

（7）比较卡方检验统计量与检验临界值的大小，进行判断：如果
 ＜χ

2


 （1-α， n-r-1），则接受原假设；相反，则拒绝。




1.2.6　K-S检验



单样本的K-S检验（Kolmogorov-Smirnov检验）是用来检验抽取样本所依赖的总体是否服从某一理论分布。其方法也是将某一变量的累积分布函数与选定的理论分布进行比较。

设各样本观测值的实际累积概率为S（x），各样本观测值的理论分布累积概率为F（x），则检验的原假设和备择假设为

H

0


 ：S（x）=F（x）；H

1


 ：S（x）≠F（x）

原假设所表达的意思是：抽取样本所依赖的总体分布与指定的理论分布无显著差异。

实际累积概率与理论累积概率的差值为D（x）。差值序列中的最大绝对差值D为：

D=max（|S（x

i


 ）-F（x

i


 ）|）

由于实际累积概率为离散值，D通常修正为

D=max（|S（x

i


 ）-F（x

i


 ）|，|S（x

i-1


 ）-F（x

i


 ）|）

这里差值序列中的最大绝对差值就是K-S检验的统计量。

在小样本情况下，统计量服从Kolmogorov分布；在大样本情况下，则可以用正态分布近似，此时正态分布检验统计量为：




如果检验统计量对应的实际显著水平小于给定的显著水平，则拒绝原假设，表明抽样所依赖的总体分布与指定的理论分布有显著差异；反之，则接受原假设。

Excel可以根据这个原理做任何一种分布的拟合检验，SPSS菜单操作中提供的单样本的K-S检验（Kolmogorov-Smirnov检验）可以检验的理论分布有正态分布、Poisson分布、均匀分布、指数分布等。




1.3　实验数据与内容






1.3.1　实验数据



利用Excel中的“随机数发生器”产生100个服从正态分布N（5，10

2


 ）的随机数；然后，在这100个正态分布随机数总体中，利用“周期抽样”数据分析工具，以5为间隔随机抽取样本数据，这样得到的数据作为实验数据。




1.3.2　实验内容



（1）在正态分布随机数总体中，分两次可重复地随机抽取100个数据，构成n=2的随机样本组，并计算出每个样本组的样本均值序列；

（2）利用“描述统计”分析工具，计算样本均值的描述统计指标，并与总体的描述统计指标做比较；

（3）分别利用众数、中位数、平均值之间的相对大小、分布指标，判断数据分布情况；

（4）绘制样本均值数据的直方图（含频率折线图、正态分布概率折线图），判断数据分布情况；

（5）画出样本均值的P-P图、Q-Q图，判断样本均值是否服从正态分布；

（6）利用卡方经验方法，判断数据实际分布与理论分布之间的一致性；

（7）利用K-S检验方法，检验样本均值是否服从正态分布。




1.4　实验操作与结果分析






1.4.1　生成正态分布随机数



打开Excel文件工作表，利用“数据/数据分析/随机数发生器”工具，设置生成100个N（5，10）随机数。如图1.4所示。




图1.4　利用随机数发生器生成100个N（5，10）随机数




1.4.2　先周期抽样、后两次随机抽样



（1）利用“数据/数据分析/抽样”工具，在抽样方法中选择“周期抽样”，间隔为5，结果如图1.5所示。




图1.5　周期抽样

（2）利用“数据/数据分析/抽样”工具，从周期抽样中得到的数据中再随机抽取100个样本数据，抽两次，抽样数据分别放入。结果如图1.6、图1.7所示。




图1.6　第一次随机抽样




图1.7　第二次随机抽样




1.4.3　计算样本均值



样本均值为第一、二次随机抽样数据的平均值。利用Excel中【Average】函数，在单元格E3中输入“=AVERAGE（C3：D3）”，并往下复制至E4：E102，得到样本均值序列。作为后面的实验数据。




1.4.4　做样本均值与基准正态随机数的频率折线图



1）样本均值数据的描述统计

（1）Excel实现步骤如下：

利用“数据/数据分析/描述统计”工具，计算样本均值的描述统计指标。如图1.8所示。




图1.8　样本均值的描述统计

单击“确定”，执行计算，得到图1.9所示的描述统计结果。




图1.9　描述统计结果

（2）SPSS实现步骤如下：

打开SPSS数据编辑窗口，选择“Analyze”→“Descriptive Statistics”→“Descriptives”，进入描述统计主对话框，把样本均值设置为分析变量，如图1.10所示。




图1.10　SPSS描述统计

再设置输出选项，如图1.11所示，单击“Continue”，返回描述统计主对话框；再单击“OK”，进行计算。计算结果如表1.2所示。




图1.11　SPSS描述统计选项

表1.2　Descriptive Statistics




同时数据编辑窗口出现样本均值的标准化值序列，如图1.12所示。




图1.12　样本均值序列

2）基准正态随机数的生成与描述统计

（1）Excel实现步骤如下：

Ⅰ.根据样本均值的描述统计指标得到平均值为0.6，标准差为0.59，并以此作为分布参数，利用“随机数发生器”生成100个用于比较样本均值分布的基准正态随机数。如图1.13所示。




图1.13　基准正态随机数

Ⅱ.利用“数据/数据分析/描述统计”命令，计算正态随机数的描述统计指标。如图1.14所示。




图1.14　Excel描述统计

（2）SPSS实现步骤同上（略）。

3）数据分组及频率分布表

（1）Excel实现步骤如下：

Ⅰ.对数据进行分组。由于数据较多，确定组数为20。

Ⅱ.确定各组组距。根据样本均值和基准正态随机数的描述统计，得到最小值为-15.6818，最大值为24.05197。由此算出组距=（最大值-最小值）/组数=1. 98，确定组距为2。

Ⅲ.统计出各组的频数制作频数分布表。输入“序号”、“分组区间”、“分组上限”、“分组下限”，在单元格区域N5：N24中输入“=FREQUENCY（
 E
 3：
 E
 102，
 M
 5：
 M
 24）/100”，用“Ctrl+Shift+Enter”的组合键确定执行计算；在单元格区域O5：O24中输入“=FREQUENCY（
 F
 3：
 F
 102，
 M
 5：
 M
 24）/100”，用“Ctrl+ Shift+Enter”的组合键确定执行计算，得到频数分布表，如图1.15所示。




图1.15　Excel数据分组及频数分布表

（2）SPSS实现步骤如下：

Ⅰ.打开SPSS数据文件“实验1/抽样/描述统计/分布拟合”。在当前数据编辑窗口中，选择“Transform”→“Recode into Different Variables”命令，打开“Recode into Different Variables”对话框，如图1.16所示。




图1.16　SPSS数据分组编码

Ⅱ.在变量列表中选择“样本均值”变量，移入“Numeric Variable”→“Output”列表框；在“Output Variable”框中，分别把编码输出序列命名为“均值分组”，并赋予代码“AVRG-N”，如图1.16所示。

Ⅲ.选中变量“样本均值”，单击“Old and New Values”按钮，打开“Recode into Different Variables：Old and New Values”对话框。因为是组距分组，所以，在“Old Value”选项组中，点击选中“Range”，输入闭口组分组的下限、上限，同时在“New Value”中输入组别编号的序号，单击“Add”添加；对于下开口组，利用“Range， LOWEST through value”输入数值“-14”，同时在“New Value”中设置编号“1”，单击“Add”添加；对于上开口组，利用“Range，LOWEST through value”输入数值“14”，同时在“New Value”中设置编号“15”，单击“Add”添加。同理，输入其他分组上下限及序号，如图1.17所示。




图1.17　数据分组区间设置

单击“Continue”，返回。

Ⅳ.单击“OK”按钮，执行编码，就在数据编辑窗口中出现一列变量名称为“均值分组”的组别编码；

Ⅴ.打开“Analyze”→“Descriptive Statistics”→“Frequencies”，设置频数分析对话框，如图1.18所示。




图1.18　频数统计

单击“Charts”按钮，在弹出的输出图形设置中设置带有正态曲线的直方图，如图1.19所示。




图1.19　带正态曲线的直方图输出设置

单击“Continue”，返回频数分析主对话框，单击“OK”按钮，执行频数分析，就得到分组数据频数频率分布表、直方图，如表1.3、图1.20所示。

表1.3　AVRG-N







图1.20　带有正态曲线的直方图

4）制作频率折线图

（1）Excel实现步骤如下：

Ⅰ.在频数分布表中，选中“分组上限”、“样本均值频率”、“正态随机数频率”三列数据，单击利用“插入/图/柱形图/二维柱形图”命令。

Ⅱ.点击横轴“选择数据”，在“水平（分类）轴标签”一栏中点击“编辑”，在输入“轴标签区域”时选择“分组上限”的数据确定即可；左击选中“正态随机数频率”，更改图形为折线图；

Ⅲ.选择“样本均值频率”数据单元格区域，复制再粘贴，即可得到2个样本均值频率，再在图中选中其中一个的数据将其变为折线图就可以在一个图上显示出频率分布的条形图与折线图。

Ⅳ.标上坐标轴标题及图标题，调整好大小即可。得到的结果如图1.21所示。




图1.21　样本均值、正态随机数的频率分布图

（2）SPSS实现步骤如下：

选用“Analyze”→“Descriptive Statistics”→“Frequencies”，进入描述统计主对话框，把样本均值、正态随机数设置为分析变量，如图1.22所示。




图1.22　SPSS频数统计

单击“Charts”按钮，单击选中直方图，勾选带正态分布曲线SPSS。单击“Continue”返回；再单击“OK”，进行计算。结果如图1.23、图1.24所示。




图1.23　样本均值的直方图




图1.24　基准正态随机数的频数统计直方图




1.4.5　利用Excel绘制Q-Q图



（1）将样本均值排序，并利用系列填充工具在排序后数据的右侧一列依次标上1～100作为序号。在单元格D2中，输入“=NORMSINV（（C2-0.5）/100）”，确定后往下复制至D3：D101，利用Excel中的【NORMSINV】函数计算标准正态分位数。

（2）选中排序后样本均值、标准正态分位数两列数据，选择利用“插入/图/散点图”命令，即可得到标准正态分位数图。

（3）右击选中散点，添加趋势线“y=x”，即得正态概率分位数-分位数图，即Q-Q图。如图1.25所示。




图1.25　正态分布拟合的Q-Q图




1.4.6　利用SPSS绘制P-P图、Q-Q图



1）制作P-P图

（1）单击“Analyze”→“Descriptive Statistics”→“P-P Plots”；

（2）进入制作P-P图主对话框，利用右转向键，把样本均值变量导入分析变量框，选择待检验的理论分布——正态分布，如图1.26所示。




图1.26　P-P图制作对话框

（3）单击“OK”按钮，就得到制作的P-P图及统计分析结果，主要结果如表1.4、图1.27、图1.28所示。

表1.4　Estimated Distribution Parameters




The cases are unweighted.




图1.27　正态分布拟合的P-P图




图1.28　剔除趋势后的样本均值P-P图

2）制作Q-Q图

（1）单击“Analyze”→“Descriptive Statistics”→“Q-Q Plots”；

（2）进入制作Q-Q图主对话框，利用右转向键，把样本均值变量导入分析变量框，选择待检验的理论分布——正态分布，如图1.29所示。




图1.29　制作Q-Q图主对话框

（3）单击“OK”按钮，就得到制作的Q-Q图及统计分析结果，主要结果如图1.30、图1.31所示。




图1.30　样本均值的Q-Q图




图1.31　剔除趋势后的样本均值Q-Q图




1.4.7　分布拟合的Excel卡方检验



（1）设计制作分布拟合的Excel卡方检验计算表，如图1.32所示；




图1.32　Excel卡方检验统计量的计算表

（2）选取单元格区域E3：E22，输入实际频数计算公式“=FREQUENCY（频率折线图!E3：E102，D3：D22）”，用“Ctrl+Shift+Enter”的组合键确定执行计算；再利用sum函数求和；

（3）在单元格F4中，输入下限对应的正态累积概率计算公式“=NORMDIST（C4，0.6，5.9，TRUE）”，往下复制至F5：F22；在单元格G3中，输入上限对应的正态累积概率计算公式“=NORMDIST（D3，0.6，5.9，TRUE）”，往下复制至G5：G22；

（4）在单元格H3中，输入正态分布期望频数计算公式“=（G3-F3）*
 E
 23”，并往下复制至H4：H22；再利用sum函数求和；

（5）在单元格K5中，输入卡方检验统计量的显著水平计算公式“=CHITEST（E3：E22，H3：H22）”，得到实际的显著水平0.9784。它远大于显著水平0.05，接受原假设，认为样本均值服从正态分布。




1.4.8　分布拟合的SPSS卡方检验



（1）在变量编辑窗口中，定义数值型变量“组中值”和“频数”。在数据编辑窗口中，输入数据。单击“Data”菜单中的“Weight Cases”命令，如图1.33所示。




图1.33　权重变量的设置

（2）在弹出的“Weight Cases”对话框中，选中“Weight cases by”选项，并选择“频数”变量，使之添加到“Frequency Variable”框中，定义该变量为权数，如图1.33所示。

再单击“OK”按钮，返回数据编辑窗口。

（3）在“Analyze”菜单的“Nonparametric Tests”子菜单中选择“Chi-Square”命令。

（4）弹出“Chi-Square Test”对话框，如图1.34所示，在左侧的变量列表中选择“组中值”变量，单击右转向按钮，使之添加到“Test Variable List”框中。




图1.34　“Chi-Square Test”对话框

在“Expected Range”框中可以确定待检验的样本的取值范围。选项如下：

●　Get from data：表示所有观察数据都参与检验。本实验选中此项。

●　Use specified range：表示用户自定义一个取值范围，只有在这个范围内的数据才参与检验。

“Expected Values”框中给出期望分布的频数。选项如下：

●　All categories equal：表示所有分组的期望频率都相同，即期望分布均匀分布。

●　Values：要求用户输入期望分布的频率数，通过单击“Add”（增加）、“Change”（更改）、“Remove”（删除）按钮来对期望分布进行操作。

在本例中，期望分布不是均匀分布，因此选择“Values”项，并依次添加输入14个期望频数“0.9687、1.9842、3.6273、5.9174、8.6149、11.1928、12.9776、13.4284、12.4001、10.2187、7.5151、4.9323、2.8888、1.5099”。

注意：这里所输入的期望分布频率数目必须和观察数据的分组组数对应，因此需要输入14个期望频率数。如果不对应，则SPSS不会进行卡方检验，结果会显示“Chi-Square Test cannot be performed”。

（5）单击图1.34所示对话框中的“Options”按钮，弹出“Chi-Square Test：Options”对话框。选中“Descriptive”、“Quartiles”、“Exclude cases test-by-test”项，单击“Continue”按钮，返回“Chi-Square Test”对话框。如图1.35所示。




图1.35　“Chi-Square Test： Options”对话框

（6）单击“OK”按钮，SPSS自动进行检验。如表1.5、表1.6、表1.7所示。

表1.5　Descriptive Statistics




表1.6　组中值




表1.7　Test Statistics




a.5 cells（35.7%）have expected frequencies less than 5.The minimum expected cell frequency is 1.0.




1.4.9　K-S检验的Excel实现



（1）根据样本均值频率、正态随机数频率，利用交叉加法，算出样本均值累积频率、正态随机数累积频率，再计算出它们累积概率之间的差值；

（2）利用Excel中【ABS】函数，算出绝对差值1序列和绝对差值2序列；

（3）利用Excel中【max】函数，确定检验统计量的最大绝对差值及修正的最大绝对差值D，再利用公式计算正态分布检验统计量Z；

（4）输入“=NORMSDIST（N5）”，计算检验统计量Z对应的显著水平，结果如图1.36所示；




图1.36　K-S检验的Excel计算模板

（5）与显著水平α=0.05对应的分位数进行对比判断可知，接受原假设。




1.4.10　K-S检验的SPSS实现



把“样本均值”数据复制粘贴到SPSS的数据窗口；在变量窗口把数据变量命名为“样本均值”，定义为数值型、定距变量。

（1）选择“Analyze”→“Nonparametric Tests”→“1-Sample K-S”，进入K-S检验主对话框。

（2）将待检验的变量“样本均值”选入“Test Variable List”，选择检验的理论分布为“正态分布”，如图1.37所示。




图1.37　正态分布拟合检验的SPSS软件K-S检验主对话框

（3）设定检验准确程度、输出选项。点击“Exact”，并在对话框中选择“Exact”，点击“Continue”返回。点击“Options”，勾选中“Descriptive”、“Quartiles”，再返回主对话框，如图1.38所示。点击“Continue”返回K-S检验主对话框。




图1.38　单样本K-S检验的输出选项设置

（4）点击“OK”，进行检验。结果如表1.8、表1.9所示。

表1.8　Descriptive Statistics




表1.9　One-Sample Kolmogorov-Smirnov Test




a.Test distribution is Normal.







实验2　家庭信息数据的分类汇总与透视分析






2.1　实验目的



通过本次实验，熟练掌握对样本的多元信息数据进行分类汇总与透视分析，了解一些简单的数据挖掘方法。




2.2　实验原理



本次实验的原理主要是：①数据分组；②分类汇总；③透视分析。




2.3　实验数据与内容



本实验数据是SPSS自带的数据文件“实验2家庭信息数据的分类汇总与透视分析.sav”，该数据文件是由一家调查公司的问卷调查表中的数据整理得到的。问卷调查的内容是作为被访谈调查对象的个人和家庭的基本情况，以及对某些现象和问题的看法和观点。数据文件给出了3832个被调查者的数据资料。表2.1列出了数据文件的变量及其属性，共计28个变量。

表2.1　变量信息




（续表）




本次实验的主要内容是：

（1）按照就业状态、最高学历，分类汇总个人收入；

（2）按照最高学历、性别，对个人收入进行分组透视分析。




2.4　操作步骤与结果






2.4.1　分类汇总



（1）将SPSS数据文件“survey_sample.sav”打开，读入SPSS的数据编辑窗口；

（2）打开主对话框。在数据编辑窗口，选择“Data”→“Aggregate”命令，弹出“Aggregate Data”（数据汇总）对话框。如图2.1所示。




图2.1　“Aggregate Data”（数据汇总）对话框

（3）选择分类变量。在对话框左侧的变量列表框中选择一个或多个变量作为分类变量，单击上方的右向箭头按钮，将变量移动到“Break Variable（s）”（分类变量）列表框中。在本例中，选择变量“就业状态”、“最高学历”为分类变量。

（4）选择汇总变量。在对话框的左侧变量列表框中选择一个或多个变量作为汇总变量，单击下侧的右向箭头按钮，将该变量移动到“Aggregated Variable（s）”（汇总变量）中，移动到“Break Variable（s）”列表框内的汇总变量自动改名。在本例中，汇总变量为“个人总收入”。

（5）添加变量标签。在“Aggregated Variable（s）”中选择相应汇总变量后，单击“Name＆Label”按钮，出现“Aggregate Data：Variable Name and Label”（数据汇总：变量名和变量标签）对话框，重新命名汇总数据文件中的相应变量名或添加变量标签，其中包括如下两个文本框：

Name：定义汇总变量的变量名。

Label：定义汇总变量的变量标签。

重命名后，单击“Continue”按钮，返回到“Aggregate Data”对话框。

（6）汇总函数的选择和计算。在“Break Variable（s）”列表框中选择相应的变量后，单击“Function”按钮，打开“Aggregate Data：Aggregate Function”（数据汇总：汇总函数）对话框，指定对汇总变量选择计算的统计量，默认选择“Mean”（均值），即计算变量的平均值。选择完毕后，单击“Continue”按钮，返回到“Aggregate Data”对话框。

（7）选择汇总结果保存方式为“Create a new dataset containing only the aggregated variables”，在数据编辑窗口中重新创建一个新的汇总数据集。数据集中包括分类变量和所有的通过汇总函数定义的汇总变量。活动数据集不发生变化。在“Data file”栏中输入数据集名“a”。

（8）执行数据汇总操作。以上设置完毕，操作无误后，单击“OK”按钮，执行数据汇总操作。这时，会在新的数据编辑窗口中自动添加上汇总变量数据，图2.2显示了汇总结果。




图2.2　数据汇总操作后的数据编辑窗口




2.4.2　透视分析



利用自定义表格制作交叉列联表的基本步骤如下：

（1）打开数据文件“survey_sample.sav”。

（2）打开自定义表格对话框。选择“Analyze”→“Tables”→“Custom Tables”命令，打开“Custom Tables”（自定义表格）对话框。

（3）选择行变量和列变量。二维列表需要指定表格的行变量和列变量。在“Variables”变量列表中，先后选择变量“性别”、“最高学历”，利用鼠标拖动到制表框“Rows”（行）内；选择变量“个人收入”，利用鼠标将其拖动到制表框“Columns”（列）内，如图2.3所示。




图2.3　透视分析主对话框

（4）设定显示分类变量统计量，选择计算百分比。

分别单击“最高学历”、“性别”，拖住放置在列统计变量框中；把“个人收入”拖住放置在行统计变量框中。在表格预览框内，鼠标指向“年龄范围”区域，单击右键，在弹出的菜单中选择“Summary Statistics”（综述统计量）命令，出现“Summary Statistics：Categorical Variables”（汇总统计量：分类变量）对话框。

在该对话框中，左侧的“Statistics”列表框列出确定表格中各变量的统计量选择。针对不同类型的变量，给出不同属性的汇总统计量。如果希望单元格内显示在不同分组变量值下行变量值出现的次数占该变量值下总次数的百分比，选择列表框中的“Row N%”选项，单击右向箭头按钮，将此项计算添加至“Display”。这时，“Display”中出现两个选项，其中一个为“Count”，为默认选项。

设置完毕后，单击“Apply to Selection”按钮，确定并保存设置，返回至自定义表格主对话框。在制表主对话框中表格预览图的每一个分组变量值都显示了分类变量“性别”的两个类别列变量，如图2.3所示。

（5）在制表主对话框中，单击“确定”按钮，执行制表操作。制表结果如表2. 2、表2.3所示。

表2.2　Pearson Chi-Square Tests




表2.3　Custom Table










实验3　投资策略收益差异性的假设检验






3.1　实验目的



通过本次实验，系统掌握两个独立小样本的均值之差假设检验的基本原理及相关操作分析。




3.2　实验原理



本次实验原理主要包括：①总体分布的拟合检验；②两个总体方差之比的假设检验；③两个独立小样本的均值之差的假设检验。




3.3　实验数据与内容



本次实验的实验数据主要是SPSS数据文件“实验3两个投资策略收益差异性的假设检验.sav”中两个投资策略对应的收益率序列数据。

本次实验主要练习两个总体方差未知时两个总体均值之差的假设检验。具体内容如下：

（1）练习两个总体分布的Q-Q图制作、卡方检验与非参数检验；

（2）利用F分布的假设检验，分析两个总体方差是否相等；

（3）利用相应情况下的假设检验，分析两个独立小样本的均值之差。




3.4　操作步骤与结果






3.4.1　探索分析



（1）在SPSS变量编辑窗口中，定义变量投资策略和收益率。在SPSS数据编辑窗口中，在投资策略变量列中，收益率对应的投资策略1输入编码1、投资策略2输入编码2；在收益率变量列中，对应输入或复制粘贴收益率。

（2）在“Analyze”菜单的“Descriptive Statistics”子菜单中选择“Explore”命令，弹出“Explore”对话框。

（3）先要对收益率资料进行分组探索性分析，故在对话框左侧的变量列表中选择“收益率”作为分析变量，使之添加到“Dependent List”框；再选中“投资策略”作为分组变量，使之添加到“Factor List”框，如图3.1所示。




图3.1　“Explore”对话框

注意：如果有多个分组变量进入“Factor List”框中，那么会以分组变量各取值进行组合分组。如两个分组变量各有2种取值，那么就会有4种组合分组。

（4）在“Display”框中选择“Both”项。

“Display”框中共有3个选项：“Both”（默认选项）：表示输出图形和描述统计量。选择此项将激活右边的“Statistics”和“Plots”两个按钮。“Statistics”：表示输出描述统计量。“Plots”：表示输出图形。

（5）单击右上方的“Statistics”按钮，弹出“Explore：Statistics”对话框。

在此对话框中有如下选项：

●　Descriptives：输出均值、中位数、众数、5%修正均数、标准误、方差、标准差、最小值、最大值、全距、四分位全距、峰度系数、峰度系数的标准误、偏度系数、偏度系数的标准误。在“Confidence Intervals for Mean”参数框中输入均值的置信区间，默认值为95%。

●　M-estimators：作中心趋势的粗略最大似然确定，输出4个不同权重的最大似然确定数，当数据分布均匀，并且两尾巴较长，或当数据中存在极端值时， M-estimators可以提供比较合理的估计。

●　Outliers：输出5个最大值与5个最小值。

Percentiles：输出第5%，10%，25%，50%，75%，90%及95%百分位数。

本例将这几项全部选中，之后单击“Continue”按钮，返回“Explore”对话框。

（6）在“Explore”对话框中单击“Plots”按钮，弹出“Explore：Plots”对话框，如图3.2所示。




图3.2　“Explore：Plots”对话框

本例中选中“Boxplots”框中的“Dependents together”项，选中“Descriptive”框中的“Stem-and-leaf”、“Histogram”项，表示作茎叶、直方图情形描述；选中“Normality plots with tests”复选框；在“Spread vs Level with Levene Test”框中选中“None”项。单击“Continue”按钮，返回“Explore”对话框。

（7）单击右上方的“Options”按钮，弹出“Explore：Options”对话框。

选中“Exclude cases listwise”项，单击“Continue”按钮，返回“Explore”对话框。再单击“OK”按钮，SPSS即完成探索分析；得到探索分析结果，主要相关结果如表3.1至表3.3、图3.3至图3.9所示。

表3.1　Case Processing Summary




表3.2　Descriptives




表3.3　Tests of Normality




a.Lilliefors Significance Correction



*.This is a lower bound of the true significance.




图3.3　投资策略1的收益率分布直方图




图3.4　投资策略1的收益率正态分布拟合检验Q-Q图




图3.5　去除趋势后的投资策略1的收益率正态分布拟合检验Q-Q图

投资策略2的收益率分布直方图、Q-Q图如图3.6至图3.8所示。




图3.6　投资策略2的收益率分布直方图




图3.7　投资策略2的收益率正态分布拟合检验Q-Q图




图3.8　去除趋势后投资策略2的收益率正态分布拟合检验Q-Q图




图3.9　投资策略1、2的收益率箱线图

投资策略1的收益率分布直方图、Q-Q图如图3.3至图3.5所示。




3.4.2　两独立小样本均值之差的t检验



（1）在“Analyze”菜单的“Compare Means”子菜单中选择“Independent-Samples T Test”命令。

（2）在弹出如图3.10所示的“Independent-Samples T Test”对话框中，从左侧的变量列表中选择“收益率”变量，并添加到“Test Variable（s）”框中；选择“投资策略”变量，添加到“Grouping Variable”框中。




图3.10　“Independent-Samples T Test”对话框

（3）单击“Define Groups”按钮，弹出“Define Groups”对话框，如图3.11所示。在该对话框中指定标识变量的区分方法。选择“Use specified values”选项，表示根据标识变量的取值进行区分。在“Group 1”中输入1，在“Group 2”中输入2。




图3.11　“Define Groups”对话框

如果选择“Cut point”选项，则表示要选择一个分割点，高于该值的个案组成一个样本，低于该值的个案组成另外一个样本，这适合于标识变量为连续变量的情况。

（4）单击“Continue”按钮，返回“Independent-Samples T Test”对话框；再单击“OK”按钮，SPSS即完成所要求的计算，得到最后的假设检验结果。如表3.4、表3.5所示。

表3.4　Group Statistics




表3.5　Independent Samples Test










实验4　投资策略与投资风格对投资收益率影响的方差分析






4.1　实验目的



通过本次实验，能够掌握利用方差分析方法，检验判断定性因素（分类变量）对定量因素（数值变量）的影响。




4.2　实验原理



本次实验的主要原理是方差分析。具体包括假设前提的检验、基本原理以及双因素方差分析。




4.3　实验数据与内容



本次实验所使用的数据是SPSS数据文件“实验4投资策略与投资风格对投资收益率影响的方差分析”中的数据。

实验操作的内容主要是：

（1）检验方差分析的三个假设前提是否成立，即正态性、方差齐性、独立性；

（2）再利用方差分析方法，判断投资策略、投资风格以及它们之间的交互作用对投资收益率是否有影响；

（3）确定投资策略、投资风格以及它们之间的交互作用与投资收益率之间的显著关系强弱；

（4）通过均值之间的多重配对比较，检验确定哪些均值之间存在显著差异。




4.4　操作步骤与结果



（1）打开SPSS数据文件，在“Analyze”菜单的“General Linear Model”子菜单中选择“Univariate”命令。

（2）在弹出图4.1所示的“Univariate”对话框中，从左侧的变量列表中选择“收益率”变量，使之添加到“Dependent Variable”框中，选择“投资策略”、“投资风格”变量，使之添加到“Fixed Factor”框中，如图4.1所示。




图4.1　“Univariate”对话框

（3）单击图4.1所示对话框中的“Model”按钮，弹出“Univariate：Model”对话框。在该对话框中可以选择建立多因素方差分析模型的种类。SPSS默认的是建立饱和模型，也就是Full factorial。本例中选中“Full factorial”项，单击“Continue”按钮，返回“Univariate”对话框。选择该模型，则将观察变量总的变异平方和分解为多个控制变量对观察变量的独立作用部分、多个控制变量交互作用部分以及随机变量影响部分。

在实际分析中，也可以自己指定模型进行多因素方差分析。这样就可以自由地选择需要计算考虑的变异部分。

（4）单击图4.1所示对话框中的“Contrasts”按钮，弹出“Univariate：Contrasts”对话框，通过选择该对话框中的“Contrasts”项内容，可以对控制变量各个水平上的观察变量的差异性进行对比检验。其中对比的方式有以下几种：

None：SPSS默认方式，不作对比分析。

Deviation：表示以观察变量的均值为标准，比较各水平上观察变量的均值是否有显著差异。

Simple：表示以第一水平或最后一个水平（在下面的“Reference Category”选项中进行选择）的观察变量均值为标准，比较各水平上观察变量的均值是否有显著差异。

Difference：表示将各水平上的观察变量均值与前一个水平上的观察变量均值作比较。

Hermert：表示将各水平上观察变量的均值与最后一个水平上的观察变量均值进行比较。

本例中对两个变量都选择“Simple”方式，并以最后一个水平的观察变量均值为标准。选择好“Contrasts”项中的方式后，需要单击“Change”按钮进行确认。在Contrasts对话框中选择完毕后，单击“Continue”按钮，返回“Univariate”对话框，完成设置。

（5）单击图4.1所示对话框中的“Plots”按钮，弹出“Univariate：Profile plots”对话框。通过选择“Univariate：Profile plots”对话框中的内容，可以设置以图形的方式展现控制变量之间是否有交互影响。如果各个控制变量之间没有交互作用，那么各个水平对应的图形应近于平行，否则相交。本例中选择显示两个变量交互作用，然后返回“Univariate”对话框。

（6）通过上面的步骤，只能判断两个控制变量的不同水平是否对观察变量产生了显著影响。如果想进一步了解究竟是哪个组（或哪些组）和其他组有显著的均值差别，就需要在多个样本均数间两两比较。

单击图4.1所示对话框中的“Post Hoc”按钮，弹出“Univariate：Post Hoc Multiple Comparisons for Observed Means”对话框，在其中可以选择需要进行比较分析的控制变量。本例中，选择“group”变量，并将其添加到“Post Hoc Tests for”框中。然后，选择比较方法。本例中选择“LSD”和“S-N-K”显著性检验法。单击“Continue”按钮，返回“Univariate”对话框。

（7）单击“Options”按钮，弹出“Univariate：Options”对话框。

方差分析的前提是各个水平下（以这里为group变量不同取值）总体服从方差相等的正态分布。其中正态分布的要求并不是很严格，但对于方差相等的要求是比较严格的。因此必须对方差分析的前提进行检验，在该对话框中可进行相关设置。

另外，该对话框还用来指定输出一些分析的结果，以及对缺失值如何处理。

本例中，选中“Display”框中的“Homogeneity tests”选项，单击“Continue”按钮，返回上一对话框。

（8）单击“OK”按钮，SPSS完成计算，结果如表4.1至表4.6。

表4.1　Between-Subjects Factors




表4.2　Descriptive Statistics（Dependent Variable：收益率）




表4.3　Levene’s Test of Equality of Error Variances

a


 （Dependent Variable：收益率）




Tests the null hypothesis that the error variance of the dependent variable is equal across groups.



a.Design：Intercept+投资策略+投资风格+投资策略×投资风格

表4.4　Tests of Between-Subjects Effects（Dependent Variable：收益率）




a.R Squared=.125（Adjusted R Squared=.050）

表4.5　Multiple Comparisons（Dependent Variable：收益率）




Based on observed means.



The error term is Mean Square（Error）=.805.

表4.6　收益率




Means for groups in homogeneous subsets are displayed.



Based on observed means.



The error term is Mean Square（Error）=.805.



a.Uses Harmonic Mean Sample Size=13.000.







实验5　不良贷款影响因素的回归分析与预测






5.1　实验目的



通过本次实验，掌握利用回归分析及其假设检验的方法，分析连续性变量之间的因果相关关系及弹性分析，并且会利用建立的回归模型进行预测。




5.2　实验原理



本次实验的相关理论主要包括：一般线性回归模型的假设、模型结构、参数估计原理、拟合程度判断、方程结构与参数的显著性检验、模型假设是否成立的判断，以及模型的预测方法。




5.3　实验数据与内容



本次实验所使用的数据是SPSS数据文件“实验5不良贷款影响因素的多元回归分析”。

本次实验练习的要点是：

（1）用一次进入法建立回归方程，判断估计的回归方程是否很好地拟合了原始数据；

（2）对总体回归方程结构的合理性做显著性检验，显著性水平为0.01；

（3）在0.01显著性水平下，检验在回归方程中每个回归系数与解释变量是否显著；

（4）诊断回归模型中的自变量是否存在着多重共线性问题；

（5）诊断回归模型中的残差项同方差假设是否成立；

（6）诊断样本数据中是否存在异常值；

（7）用逐步筛选回归法建模，并对模型进行评价；

（8）利用估计的回归方程预测下一期的不良贷款余额。




5.4　操作步骤与结果



（1）建立数据文件，定义数值性变量“不良贷款”、“贷款余额”、“累计应收贷款”、“贷款项目个数”、“固定资产投资额”。

（2）从菜单上依次点选“Analyze”→“Regression”→“Linear”命令，打开“Linear Regression”对话框。

（3）在“Linear Regression”对话框中，将“不良贷款”变量右移到因变量（Dependent）框中，将自变量“贷款余额”、“累计应收贷款”、“贷款项目个数”、“固定资产投资额”移入“Independent（s）”框中。并在“Method”框内选择“Enter”回归分析方法设置，即自变量一次全部进入的方法。如图5.1所示。




图5.1　不良贷款回归模型的主对话框

（4）单击“Linear Regression”对话框右上方的“Statistics”按钮，打开“Statistics”对话框，如图5.2所示。在“Statistics”对话框内，勾选“Model fit”项，则在“Linear Regression”过程完成后会输出Model Summary表；勾选回归系数“Regression Coefficients”栏下的估计“Estimates”、置信区间“Confidence intervals”，以及部分相关与偏相关“Part and partial correlations”、共线性诊断“Collinearity diagnostics”，则会输出Coefficients表和Collinearity Diagnostics表；最后，还可勾选残差“Residuals”的奇异值诊断“Casewise diagnostics”项，选中“All cases”，会输出所有样本点的情况。然后，点击“Continue”按钮，回到“Linear Regression”主对话框。




图5.2　线性回归分析的统计选项设置

（5）单击“Linear Regression”对话框下方“Plots”按钮，打开“Plots”对话框，如图5.3所示。在“Plots”对话框左下角的标准化残差图栏中（Standardized Residual Plots），勾选“Normal probability plot”，可以画出P-P图。当然，还可以将左侧框中的变量分别移入右侧Y框与X框中，以绘制散点图。本例不绘制散点图。如图5.3所示。然后，单击“Continue”按钮，回到“Linear Regression”主对话框。




图5.3　图形输出设置

（6）单击“Linear Regression”对话框下方的“Save”按钮，打开“Save”对话框。在“Save”对话框内被选中的项目，都将在数据编辑窗口显示。这里选择未标准化的点预测值“Unstandardized”及其置信度为95%的置信区间“Individual”；还可选择残差“Residuals”栏下的“Unstandardized”，即未标准化的残差值。然后，单击“Continue”按钮，回到“Linear Regression”主对话框。

（7）单击“Linear Regression”对话框下方的“Options”按钮，打开“Options”对话框。该对话框只有在筛选自变量方法“Method”框选择逐步回归法“Stepwise”项目后才需打开。临界值可以使用F的概率值（“Use probability of F”），也可以选用F值（“Use F value”）。但要注意，若使用F的概率值，则进入（“Entry”）的概率值要低于剔除（“Removal”）的概率值；若使用F值，则进入（“Entry”）的值要高于剔除（“Removal”）的值。然后，单击“Continue”按钮，回到“Linear Regression”主对话框。

（8）在“Linear Regression”主对话框中，单击“OK”按钮即可完成操作，结果如表5.1至表5.7、图5.4至图5.10所示。

表5.1　Descriptive Statistics




表5.2　Correlations




表5.3　Model Summary

b







a.Predictors：（Constant），固定资产投资额，累计应收贷款，贷款项目个数，贷款余额



b.Dependent Variable：不良贷款

表5.4　ANOVA

b







a.Predictors：（Constant），固定资产投资额，累计应收贷款，贷款项目个数，贷款余额



b.Dependent Variable：不良贷款

表5.5　Coefficients

a







a.Dependent Variable：不良贷款

表5.6　Coefficient Correlations

a







a.Dependent Variable：不良贷款

表5.7　Collinearity Diagnostics

a







a.Dependent Variable：不良贷款




图5.4　回归标准化残差的直方图




图5.5　回归分析残差的正态分检验P-P图




图5.6　被解释变量与回归标准化残差的散点图




图5.7　被解释变量与贷款余额的散点图




图5.8　被解释变量与累计应收贷款的散点图




图5.9　被解释变量与贷款项目个数的散点图




图5.10　被解释变量与固定资产投资额的散点图







实验6　时间序列经济数据的描述、分解与预测






6.1　实验目的



通过本次实验，系统掌握时间序列数据的描述统计及其内含成分判断方法，能够合理选用统计方法对综合性时间序列数据进行分解预测。




6.2　实验原理



按统计指标的性质不同，时间数列可分为绝对数时间数列、相对数时间数列和平均数时间数列三种类型。其中，绝对数时间数列是基本数列，其余两种是派生出来的数列。如图6.1所示。




图6.1　时间序列的种类




6.2.1　时间序列的描述统计指标体系



时间序列数据常用的描述统计指标可以归纳为表6.1。

表6.1　常用的时间序列描述统计指标




（续表）




时间序列的水平指标、发展指标与速度指标之间逻辑关系之间的逻辑关系如图6.2所示。




图6.2　时间序列水平指标、发展指标与速度指标之间的逻辑关系

时间序列速度指标之间的逻辑关系如图6.3所示。




图6.3　时间序列速度指标之间的逻辑关系




6.2.2　时间序列成分的判断



一个时间序列通常由4种成分构成：趋势性变动（T）、季节性变动（S）、周期性变动（C）、随机性波动（I）。

时间序列成分的判断方法主要是：

1）图形判断

用于时间序列成分观察的图形主要有序列图、直方图、自相关（ACF）图与偏自相关（PACF）图、谱密度图等。

按照时间绘制（时间）序列图，根据图形形状直观观察，判断该序列包含的成分，把握时间序列的正态性、平稳性、周期性以及异常值、集聚性等特征。

平稳时间序列在图形上的特征是：在水平方向上平稳发展，在垂直方向上波动幅度保持稳定；非平稳时间序列的特征主要是：趋势性、异方差性、波动性、周期性、季节性，以及这些特征的混合等。

利用年度折叠时间序列图，可以确定时间序列是否含有季节成分。

2）统计检验的方法

时间序列成分统计检验的方法主要是参数检验法、游程检验法。




6.2.3　时间序列的分解预测
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或加法模型：
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或更一般地写成：
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函数f究竟采取何种形式，取决于时间序列本身的变化规律和所采用的预测方法。

对应不同的时间序列类型，应当选择相应的分解预测方法。如图6.4所示。




图6.4　时间序列分解预测方法的选择

以忽略周期性因素的乘法模型为例，分解预测法的基本步骤：

1）确定并分离季节成分S

Ⅰ.计算季节指数，以确定时间序列中的季节成分

季节指数计算步骤如下：

（1）计算移动平均值（季度数据采用4项移动平均，月份数据采用12项移动平均），并将其结果进行“中心化”处理；

（2）计算移动平均的比值，也称为季节比率，将序列的各观察值除以相应的中心化移动平均值，然后，计算出各比值的季度（或月份）平均值，即季节指数；

（3）季节指数调整，各季节指数的平均数应等于1或100%，若根据第（2）步计算的季节比率的平均值不等于1时，则需要进行调整，具体方法是：将第（2）步计算的每个季节比率的平均值除以它们的总平均值；

Ⅱ.将季节成分从时间序列中分离出去，即用每一个观测值除以相应的季节指数，以消除季节性。即：




2）建立趋势预测模型并预测趋势T

Ⅰ.对消除季节成分的序列建立适当的趋势预测模型，并根据这一模型进行预测

一个时间序列适合于何种趋势模型，可以通过两种方法选择：

第一种是图形拟合识别法，即绘制时序图，然后将其与各类函数曲线模型的图形进行拟合比较而定。趋势模型大部分为曲线模型。调用SPSS中的Regression/ Curve Estimation过程可完成下列有关曲线拟合的功能。

（1）Linear：拟合直线方程Y=b
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 +b

1


 X；

（2）Quadratic：拟合二次曲线方程Y=b

0


 +b

1


 X+b

2


 X

2


 ；

（3）Compound：拟合复合曲线模型Y=b
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 ·


（4）Growth：拟合等比级数曲线模型Y=e

（b
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 +b

1


 X）


 ；

（5）Logarithmic：拟合对数曲线方程Y=b

0


 +b

1


 ln X；

（6）Cubic：拟合多项式曲线方程Y=b
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 X+b
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 X

2


 +b

3


 X

3


 ；

（7）S：拟合S形曲线Y=e

（b

0


 +b

1


 /X）


 ；

（8）Exponential：拟合指数方程Y=b

0


 e

b

1


 X


 ；

（9）Inverse：拟合双曲线Y=b

0


 +b

1


 /X；

（10）Power：拟合乘幂曲线模型Y=b

0


 X

b

1





 ；

（11）Logistic：拟合Logistic曲线模型Y=
 。

第二种是阶差法，即根据时序的阶差特征与各类模型的阶差特点进行比较而定。一些模型的阶差特点可以归纳为表6.2所示。

表6.2　一些趋势曲线模型的阶差特点




Ⅱ.计算出最后的趋势预测值

3）用趋势预测值乘以相应的季节指数，得到最终的预测值。即

Y
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6.2.4　时间序列的ARIMA模型预测



时间序列数据往往是自相关的，这时可以利用比较一般的d阶差分平稳化后的整合p阶自回归模型与q阶移动平均模型的自回归移动平均模型ARIMA（p，d， q）。使用该模型进行时间序列预测时，一般是先检验判断原始时间序列数据的平稳性、自相关性、偏自相关性等特征，再利用原始时间序列数据建立ARIMA（p，d， q）模型，进行样本期限内外的预测。




6.2.5　时间序列的季节性多元回归模型预测



对于含有多种成分的混合时间序列，可以采用分解预测，也可以采用季节性多元回归预测。该预测是在趋势预测模型的基础上，用虚拟变量表示季节或月份的多元回归预测方法。




6.3　实验数据与内容



本次实验所使用的数据主要是SPSS数据文件“实验6.1”、“实验6.2”、“实验6.3”和“实验6.4”中的数据。

实验内容主要是：时间序列的描述统计；时间序列成分的判断、分解及预测。




6.4　操作步骤与结果






6.4.1　时间序列数据的描述统计



时间序列描述统计指标的计算可以利用Excel或SPSS的变量公式法计算，也可以利用它们当中的“描述统计”工具进行计算。可以参照前面相关描述统计内容，此处略。




6.4.2　时间序列数据的时间定义



利用SPSS的时间定义功能，将SPSS文件“实验6.1苹果出口时间序列分析”中的数据编辑窗口中的CPI数据指定为时间序列变量，并设定时间标志。

选择菜单：“Data”→“Define Dates”，出现时间序列定义对话框，选定年月数据类型，设定起始时间为2000年1月，如图6.5所示。单击“OK”按钮，即完成时间序列数据的时间定义。




图6.5　时间序列数据的时间定义对话框




6.4.3　时间序列成分的判断



绘制图形，观察时间序列成分的构成情况。

打开“Analyze”→“Time Series”→“Sequence Charts”，如图6.6所示，设置绘制序列图对话框。




图6.6　绘制序列图对话框

单击“OK”按钮，绘制出序列图，如图6.7所示。




图6.7　时间序列图

由图6.7可知，该序列有向右上方上升的趋势，也具有明显的季节周期性特征，每个年度都有着从高到低，又从低到高的大致变化规律。为更准确地把握序列中的季节周期性，再绘制一阶逐期差分后的自相关函数图和偏自相关函数图。

打开“Analyze”→“Time Series”→“Autocorrelations”，如图6.8所示，设置绘制自相关图对话框。




图6.8　绘制自相关图对话框

单击“OK”按钮，绘制出自相关图、偏自相关图，如图6.9、图6.10所示。




图6.9　一阶差分后的自相关图




图6.10　一阶差分后的偏自相关图

由图6.9、图6.10可知，该出口额序列的各阶自相关系数值显著不为0，同时随着阶数的增大，函数值呈缓慢下降趋势；偏自相关则呈明显的下降趋势；周期数为12；这些说明该序列中存在一定的上升趋势，序列的上下波动幅度有逐年增大的趋势，适宜选用引入趋势因素与季节周期因素的乘法模型进行预测。




6.4.4　先季节调整再趋势拟合



（1）打开“Analyze”→“Time Series”→“Seasonal Decomposition”；

（2）在出现的季节调整对话框中，选择乘法模型、等权重的简单移动平均，勾选中“Display casewise listing”，在分析报告中输出整个计算过程；如图6.11所示。




图6.11　季节调整对话框的设置

（3）单击“Save”按钮，设置变量保存方式为“Add to file”，单击“Continue”返回；

（4）单击“OK”按钮，执行季节调整分解预测。计算得到的季节指数如表6.3所示。

表6.3　季节指数




分解预测结果如图6.12所示。




图6.12　分解预测结果

季节分解计算表数据如表6.4所示。

表6.4　Seasonal Decomposition




（续表）




（5）利用制图工具，设置对话框，绘制季节指数图、剔除季节因素后的序列平滑前的包含趋势和随机波动因素的序列图、随机波动序列图，以及季节调整后一阶差分的序列相关图，如图6.13、图6.14、图6.15所示。




图6.13　季节调整后的序列




图6.14　季节调整后一阶差分的序列自相关图




图6.15　季节调整后一阶差分的序列偏自相关图

由图可知，在周期数的整数倍处的自相关函数值、偏自相关函数值已经很小，说明选择的模型基本剔除了季节因素。再对季节调整后的序列进行曲线拟合得到趋势成分的估计。

选用曲线估计Curve Estimation命令做拟合，具体步骤如下：

（1）从菜单上依次点选“Analyze”→“Regression”→“Curve Estimation”，打开“Curve Estimation”对话框。

（2）在“Curve Estimation”对话框中，如图6.16所示，将变量季节调整后的序列移入因变量“Dependent（s）”框内；将时间t移入“Independent”栏下“Variable”框；将“年份”移入样品标识“Case Lables”框；勾选模型“Models”栏内的线性模型“Linear”项，并勾选下面的显示方差分析表“Display ANOVA table”项。




图6.16　“Curve Estimation”对话框

（3）单击“Save”按钮，打开“Save”对话框。如图6.17所示，在“Save”对话框的“Save Variables”栏中，勾选点预测值“Predicted values”项、残差“Residuals”项。然后，单击“Continue”回到“Curve Estimation”主对话框。




图6.17　“Save”对话框设置

（4）在“Curve Estimation”对话框中，单击“OK”按钮执行趋势曲线拟合，得到模型与参数估计结果如表6.5所示，曲线拟合效果如图6.18所示。

表6.5　Model Summary and Parameter Estimates



Dependent Variable：Seasonal adjusted series for money from SEASON，MOD_1，MUL EQU 12




The independent variable is t.




图6.18　曲线拟合效果

在11个常用的拟合曲线中，三次函数（Cubic）模型拟合情况最好。所以，趋势拟合模型可以选用如下模型：

YT

t


 =-361200+186800t-2556t

2


 +15.861t

3


 　　（6.1）




6.4.5　时间序列预测值的计算



为预测下一期的出口值，把t=133代入趋势拟合模型式（6.1），可得预测期时的趋势预测值为：T=16630291；再把该预测值乘以第1个月的季节指数88.2%，就可以得到同时包含趋势性成分、季节性成分的预测值为14667917。




6.4.6　ARIMA模型预测



第一步：分析时序特性。

（1）画出自相关分析图。打开SPSS数据文件“实验6.2 ARIMA”，从菜单上依次点选“Graphs”→“Time series”→“Autocorrelations”命令，打开“Autocorrelations”对话框。

（2）在“Autocorrelations”对话框中，如图6.19所示，将所分析的变量“出口额”从左侧源变量框移入“Variables”变量框内。在“Display”（显示）栏中，有两个系统默认选项，即“Autocorrelations”（自相关）和“Partial autocorrelations”（偏自相关）。一般要保留这两个选项，以绘制自相关图和偏自相关图。从时间序列图可以看出，该序列是非平稳的，有曲线趋势，所以，这里需要对其进行对数变换，之后再进行一阶逐期差分，因此，在“Transform”转换区域，勾选前面两项，输入差分阶数“1”。如图6.19所示。




图6.19　“Autocorrelations”对话框设置

打开“Options”，设置最大滞后阶数为36。单击“Continue”返回“Autocorrelations”主对话框。

（3）单击“OK”按钮，执行自相关分析，结果如图6.20、图6.21所示。




图6.20　自相关图




图6.21　偏自相关图

从自相关图可以看出，自相关系数、偏自相关系数都很小，滞后期k=1期之后都呈现正弦衰减，这里选用ARIMA（1，1，1）模型较为合适。

第二步：建立ARIMA模型。

（1）从菜单上依次点选“Analyze”→“Time Series”→“Create Models”命令，打开时间序列建模对话框。

（2）在时间序列建模对话框中，如图6.22所示，将变量“出口额”移入“Dependent Variables”框内；在“Method”栏选中“ARIMA”。




图6.22　时间序列建模主对话框

然后，单击“Criteria”，设置ARIMA模型。在“Model”（模型）栏中将“Autoregressive”自相关阶数p设为1，“Difference”逐期差分阶数d设为1，“Moving Average”移动平均阶数q设为1。在“Dependent Variable Transformation”列表框中选中“Natural log”；并且勾选模型中包括常数项（“Include constant in model”）。如图6.23所示，再单击“Continue”按钮，回到时间序列建模主对话框。

再单击“Statistics”按钮，全部选中计算选项，如图6.24所示；再点击“Plots按钮，设置图形输出对话框，如图6.25所示。




图6.23　ARIMA模型设置对话框




图6.24　统计计算选项设置




图6.25　图形输出选项设置

（3）然后单击“Save”按钮，打开其对话框。在“Save”对话框中，如图6.26所示，在“Save Variables”（生成预测变量）栏中，勾选“Predicted Values”、“Noise Residuals”。然后单击“Continue”按钮，回到ARIMA主对话框。再设置预测选项，如图6.27所示。




图6.26　计算结果输出选项设置




图6.27　预测选项设置

（4）在ARIMA对话框中，单击“OK”按钮，执行ARIMA分析，结果如表6.6、表6.7所示。

表6.6　Model Statistics




表6.7　ARIMA Model Parameters




根据参数估计结果，可得ARIMA模型为：

Δlogy

t


 =0.055+0.046logy

t-1


 +ε

t


 -0.226ε

t-1




数据编辑窗口会显示样本期限（t=132）内外的预测值、预测误差，如图6.28所示。




图6.28　样本期限（t=132）内外的ARIMA模型预测结果

第三步：模型的进一步检验。

从模型残差序列的自相关分析图6.29中可以看出，该序列基本上是纯随机序列，所以，用建立的ARIMA模型进行预测是合理的。




图6.29　模型残差序列的自相关分析图

从实际序列的模型序列拟合与预测图6.30中可以看出，该模型可以较好地拟合预测。




图6.30　出口额的实际值、样本期限内的拟合值及样本期限外的预测值




6.4.7　季节多元回归模型预测



第一步：趋势曲线拟合。

（1）打开SPSS数据编辑窗口。导入SPSS文件“实验6.3消费信贷额季节多元回归预测”中的数据，在“Analyze”菜单的“Regression”子菜单中选择“Curve Estimation”（曲线估计）命令。

（2）在弹出的“Curve Estimation”对话框中，从左侧的变量列表中选择“信贷额”变量，单击右转向按钮，使之添加到“Dependent（s）”框中，设置为因变量。选择时间变量，单击右转向按钮，使之添加到“Independent”框中，设置为自变量。

本例中选择“Models”栏内所有列出的11种曲线模型进行曲线估计，并选择“Include constant in equation”项和“Plot models”项。再选“Display ANOVA table”项。如图6.31所示。




图6.31　“Curve Estimation”对话框

（3）如果要保存“Predicted values”（因变量的预测值）、“Residuals”（残差值）等，在“Curve Estimation”对话框中，单击“Save”按钮，弹出如图6.32所示的对话框。




图6.32　“Curve Estimation：Save”对话框

“Save Variables”框中各选项的含义如下：

Predicted values：因变量的预测值。

Residuals：残差值。

Prediction intervals：预测区间。

Confidence interval：预测区间的置信区间。如果选中了“Prediction intervals”选项此框才可用，默认为95%。

如果选择了时间作为自变量，单击“Save”按钮后，可在“Predict Cases”选项中确定一种超过数据时间序列的预测周期。其中各选项含义如下：

Predict from estimation period through last cases：依据估计周期。

Predict through：如果预测的范围超过了当前数据文件中的最后一个观测量，选择此项在随后的“Observation”中输入一个周期数值。

（4）单击“Continue”按钮，返回上一个对话框。然后，单击“OK”按钮，即可得到SPSS曲线拟合结果，如表6.8、图6.33所示。

表6.8　Model Summary and Parameter Estimates







图6.33　趋势曲线拟合效果

从趋势曲线拟合程度看，乘幂曲线模型拟合趋势效果最好，根据参数估计结果，可得模型为：

y=66530t

0.982




两边取对数线性化，可得：

ln y=11.1+0.982ln t

第二步：季节性多元回归预测。

最优趋势拟合曲线为幂函数，为作多元线性回归，需要把它线性化，计算变量信贷额对数及其序列值，再作回归分析。

（1）在信贷额变量列的右侧插入一列，定义为信贷额对数；

（2）单击“Transform”→“Compute Variable”，弹出变量计算对话框；

（3）在变量计算对话框中，目标变量设置为“信贷额对数”，数值表达式栏中设置为“ln（信贷额）”，如图6.34所示。




图6.34　变量计算对话框设置

（4）单击“OK”按钮，即在数据编辑窗口得到信贷额对数序列。同理可得时间对数序列。

（5）从菜单上依次点选“Analyze”→“Regression”→“Linear”命令打开“Linear Regression”对话框。

（6）在“Linear Regression”对话框中，如图6.35所示，将“信贷额对数”变量右移到因变量（“Dependent”）框中，将自变量“时间对数”、“Q1”、“Q2”、“Q3”移入“Independent（s）”框中。并在“Method”框内选择“Enter”隐含设置，即自变量一次全部进入的方法。




图6.35　季节多元回归预测对话框设置

（7）单击“Linear Regression”对话框右上方的“Statistics”按钮，打开“Statistics”对话框，如图6.36所示。在“Statistics”对话框内，勾选模型拟合“Model fit”、R
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 的变化“R squaredchange”、描述统计结果“Descriptives”、部分相关与偏相关“Part and partial correlations”、共线性诊断“Collinearity diagnostics”，则在Linear Regression过程完成后会输出Model Summary表、Coefficients表和Collinearity Diagnostics表；勾选回归系数“Regression Coefficients”栏下的估计“Estimates”、置信区间“Confidence intervals”、协方差矩阵“Covariance matrix”以及最后还可勾选残差“Residuals”的DW检验“Durbin-Watson”奇异值诊断“Casewise diagnostics”项，选中“All cases”，会输出所有样本点的情况。然后，点击“Continue”按钮，回到“Linear Regression”主对话框。




图6.36　Statistics对话框设置

（8）单击“Linear Regression”对话框下方“Plots”按钮，打开“Plots”对话框，如图6.37所示。在“Plots”对话框左下角的标准化残差图栏中（“Standardized Residual Plots”），勾选“Normal probability plot”，以画出P-P图。当然，还可以将左侧框中的变量分别移入右侧Y框与X框中，以绘制散点图。本例不绘制散点图。然后，单击“Continue”按钮，回到“Linear Regression”主对话框。




图6.37　线性回归图表输出设置

（9）单击“Linear Regression”对话框下方的“Save”按钮，打开“Save”对话框。在“Save”对话框内被选中的项目，都将在数据编辑窗口显示。这里选择未标准化的点预测值“Unstandardized”及其置信度为95%的置信区间“Individual”；还可选择残差“Residuals”栏下的“Unstandardized”，即未标准化的残差值。然后，单击“Continue”按钮，回到“Linear Regression”主对话框。

（10）单击“Linear Regression”对话框下方的“Options”按钮，打开“Options”对话框。该对话框只有在筛选自变量方法“Method”框选择逐步回归法“Stepwise”项目后才需打开。临界值可以使用F的概率值（“Use probability of F”），也可以选用F值（“Use F value”）。但要注意，若使用F的概率值，则进入（“Entry”）的概率值要低于剔除（“Removal”）的概率值；若使用F值，则进入（“Entry”）的值要高于剔除（“Removal”）的值。然后，单击“Continue”按钮，回到“Linear Regression”主对话框。

（11）在“Linear Regression”主对话框中，单击“OK”按钮完成操作，主要结果如表6.9至表6.15、图6.38至图6.41所示。

表6.9　Descriptive Statistics




表6.10　Correlations




表6.11　Model Summary

b







a.Predictors：（Constant），Q3，时间对数，Q2，Q1



b.Dependent Variable：信贷额对数

表6.12　ANOVA

b







a.Predictors：（Constant），Q3，时间对数，Q2，Q1



b.Dependent Variable：信贷额对数

表6.13　Coefficients

a







a.Dependent Variable：信贷额对数

表6.14　Coefficient Correlations

a







a.Dependent Variable：信贷额对数

表6.15　Collinearity Diagnostics

a







a.Dependent Variable：信贷额对数




图6.38　信贷额对数回归的标准化残差直方图




图6.39　信贷额对数分布的正态分布拟合检验P-P图




图6.40　数据编辑窗口输出的预测值、残差等计算结果




图6.41　季节性多元回归模型预测及拟合情况

根据参数估计结果，可知季节性多元回归预测模型为：

ln y

t


 =11.165+0.980ln t-0.102Q

1


 -0.045Q

2


 -0.065Q

3




数据编辑窗口输出预测值、残差等计算结果，如图6.40所示。

季节性多元回归模型预测及拟合情况如图6.41所示。







实验7　跨国企业与本土企业竞争的策略选择






7.1　实验目的



（1）掌握数据分类汇总的方法。

（2）掌握聚类分析的方法。

（3）掌握非参数检验中χ

2


 检验两个不同样本比例的方法。




7.2　实验原理



通过判别企业销售产品的结构特征就能检测东道国企业和跨国企业的竞争策略是否存在差异。这是基于以下理由：如果东道国企业选择成本领先策略，其生产和销售的重心就集中在低端产品，则产品销售结构中低端产品的比重就相对较大；跨国企业选择技术领先策略，其生产和销售的重心就集中在高端产品，则产品销售结构中高端产品的销售比重就相对较大。那么采取不同策略的企业其产品销售的结构就会有显著的不同。由此我们得到以下2个假设：

假设1：如果本土企业和跨国企业采取不同竞争策略，则销售产品的结构有显著不同，并且本土企业之间的特征相似，跨国企业之间的特征相似。

假设2：如果本土企业采取成本领先战略，本土企业产品销售结构中低端产品占主要比重；跨国企业采取技术领先战略，跨国企业产品销售结构中高端产品占主要比重。




7.3　实验数据



以企业的市场零售份额作为衡量企业市场实力的指标，并以CR

n


 作为市场集中度的衡量指标。根据赛诺市场研究公司2001年至2004年全国75城市商场零售监测数据中“主要品牌彩电销售额占有率”的年度数据对彩电市场进行研究。

分析CR
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 的数据发现，跨国企业和本土企业前6名的企业基本能够代表市场总体。12家企业这一总体在彩电市场中占主体地位，而6家本土企业和6家跨国企业也在各自组别占有主体地位。4年里6家本土企业的市场零售份额基本保持市场零售总额的50%左右，占本土企业市场零售份额的90%多；跨国企业的市场零售份额基本保持市场零售总额的30%左右，占跨国企业市场零售份额的90%多。而12家企业的市场零售份额占到市场零售总额80%左右。其次，分别代表本土企业和跨国企业的12家企业市场零售额的排名除了组内更迭外基本保持稳定，数年来没有跌出各自组别的6名以外。

因此选择TCL、长虹、康佳、海信、海尔、创维作为本土企业的样本；索尼、东芝、飞利浦、松下、三星、LG作为跨国企业的样本。

2001年至2004年全国75城市商场零售监测数据库中“主要品牌彩电零售量结构（分规格）月度统计”数据。其中“主要品牌彩电零售量结构（分规格）月度统计”的数据结构是把各企业市场产品销售量按照产品不同的规格计算比重。对数据经过一定处理，把彩电的规格调整为20寸以下、21寸、25寸、29寸、33/34寸和34寸以上6档，以便更好地对应产品的不同档次，如表7.1。

表7.1　主要品牌彩电零售量结构（分规格）月度统计







7.4　实验内容



利用2001～2004年的彩电月度销售数据，研究中外彩电生产企业的市场竞争策略。

（1）对中外企业的彩电销售月度数据进行处理，把月度数据转化为年度数据，并分离不同年份的数据。

（2）按年度对12个中外样本企业的各个尺寸的彩电销售情况进行聚类分析，判别跨国企业和本土企业是否属于两个不同的企业类别。

（3）利用非参数检验中χ
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 检验，对聚类分析得到的类中心的可靠性进行验证。

（4）绘制两类企业销售结构的动态变化图，并分析其变化的特点。




7.5　操作步骤与结果






7.5.1　数据的读取和整理



（1）首先，我们需要把外部的Excel数据读入到SPSS软件中去，选择“File”→“Open Database”→“New Query”，在ODBC数据源中选择Excel Files数据源，如图7.1。点击“Browse”，选择读取文件的路径，然后选择“继续”。




图7.1　外部Excel数据的导入

（2）在可选变量窗口，选择需要读取的Excel数据表“data”，这样所有字段名就出现在右侧的字段表中，如图7.2。之后选择其默认选项，点击“确定”，完成外部数据读取的设置。




图7.2　外部Excel数据读入的变量选择

（3）这样，我们可以在SPSS中的数据视窗中，看到读入的数据，其中“stime”是日期，“class”是企业的类型，1表示国内品牌，2表示国外品牌。“name”是产品的品牌名称，“s20ls”、“s21”、“s25”、“s29”、“s34”和“s34mr”是依据彩色电视屏幕尺寸划分的类别，分别为：小于21寸、21寸、25寸、29寸、34寸和34寸以上，如图7.3。




图7.3　主要品牌彩电零售情况的数据结构

（4）我们研究的是不同品牌企业产品销售结构的变化，月度数据的频率就显得过高，一个品牌的月度销售结构之间的变化并不会很明显。因此首先把月度数据转换为年度数据，对年度数据进行研究。

我们选择“Transform”→“Compute Variables”，在“变量计算”菜单中，选择日期函数“XDATE.YEAR（）”，提取日期中的年度信息，并生成一个新的变量“nyear”，如图7.4，以便之后的数据汇总可以利用年度的分类信息。设置完毕后，点击“确定”。




图7.4　“变量计算”菜单中年份提取函数的设置

（5）我们在数据视图窗口可以看到多了一个年度变量“nyear”，这一变量属性是数值类型，如图7.5。




图7.5　加入年份变量后的数据结构

（6）选择“Data”→“Aggregate”，在分类变量（“Break Variables”）中选择刚才生成的年度信息“nyear”，以及品牌名称“name”，然后从左侧的变量列表中选择要进行分析的各个品牌电视的尺寸类别，然后在保存类型中选择“Create a new dataset containing only the aggregated variables”，即创建一个仅包含汇总数据的新记录集，并在“Dataset name”中设置新记录集的文件名，如图7.6。完成以上设置后，点击“Function”按钮，设置汇总所用的函数。




图7.6　“数据汇总”菜单的设置

（7）在“Aggregate Function”中勾选均值函数，如图7.7。完成汇总函数的设置后，点击“确定”，返回“数据汇总”的主菜单界面，最后单击“确定”完成设置。




图7.7　“数据汇总”中汇总函数的设置

（8）在数据视图窗口，我们可以看到新生成的数据汇总了各个品牌4个年度的销售比例数据。计算的方法就是对12个月的数据求均值，如图7.8。下面我们要研究各个年度不同品牌的销售结构，因此我们需要进一步按年度分离数据。




图7.8　新生成的按年度均值汇总的品牌彩电销售数据

（9）选择“Data”→“Select cases”，勾选“if condition is satisfied”选项，并点击“if”条件设置按钮，输入条件“nyear=2001”，然后返回主界面。选择输出条件设置中“Copy selected cases to a new dataset”，把满足条件的结果输出到新的数据集，并设置新数据集文件名“tv2001”，如图7.9。最后点击“确定”。




图7.9　“数据选择”菜单的设置

（10）在数据视图窗口我们可以看到2001年12家品牌企业的产品销售结构数据，如图7.10。重复上面的操作，生成“tv2002.sav”、“tv2003.sav”、“tv2004.sav”。




图7.10　分离后得到的2001年年度数据




7.5.2　聚类分析与企业类别研究



聚类是将数据分类到不同的类或者簇的过程，所以同一个簇中的对象有很大的相似性，而不同簇间的对象有很大的相异性。SPSS提供2步聚类、K-均值聚类和层次聚类三种方法。

由于我们研究不同品牌企业所属的类别，并假设跨国企业与本土企业是两类不同特征的企业，对数据进行验证分析。因此使用K-均值聚类方法。

K-均值聚类（K-means clustering）是Mac Queen提出的一种聚类算法，在最小化误差函数的基础上将数据划分为预定的类数K。

在K-means算法运行前必须先指定聚类数目K和迭代次数或收敛条件，并指定K个初始聚类中心，根据一定的相似性度量准则，将每一条基因分配到最近或“相似”的聚类中心，形成类，然后以每一类的平均矢量作为这一类的聚类中心，重新分配，反复迭代直到类收敛或达到最大的迭代次数。

在使用K-均值聚类分析时，初始设置聚类数为2。

（1）选择“Analyze”→“Classify”→“K-means Cluster”，进入K均值聚类分析菜单，在左侧的变量选择文本框中选择6个类别变量，从“s20ls_mean”到“s34mr_ mean”，进入右侧的“聚类变量”文本框。接着选择“name”作为类别标题，并在“Number of Clusters”中设置类别数2，如图7.11。然后点击“Options”按钮，对输出结果进行设置。




图7.11　K均值聚类分析菜单的设置

（2）在“Option”选项中勾选“Cluster information for each case”，如图7.12，这样在最后的输出结果中，就会生成一张表，标明每一个企业所属的类别，我们就可以判断是否本土企业和跨国企业的产品销售结构分属于不同的两个类别。




图7.12　K均值聚类分析菜单“Option”选项的设置

（3）完成“聚类分析”的设置，点击“确定”后，在“Output”窗口，我们就可以看到聚类分析的结果。注意名为“Cluster Membership”的表，这张表记录了每一个企业产品的销售结构所属的类别；以及名为“Final Cluster Center”的表，这张表记录了聚类后不同类别的结构。如表7.2所示，LG的产品销售结构属于第1类，与第1类中心的距离为11.999。

表7.2　2001年观察样本分类信息详表




如表7.3，“Final Cluster Center”记录了聚类分析之后，得到的类中心结构。如第1类企业，20寸以下、21寸、25寸、29寸、33/34寸和34寸的销售比重分别为1.56%、31.56%、17.72%、42.28%、4.43%和2.65%。

表7.3　2001年观察样本类中心结构表




对2002～2004年的数据重复使用SPSS的K均值聚类分析方法处理。然后整理得到2001年到2004年观察样本分类信息详表，见表7.4至表7.7。

表7.4　2001年观察样本分类信息详表




（续表）




表7.5　2002年观察样本分类信息详表




表7.6　2003年观察样本分类信息详表




（续表）




表7.7　2004年观察样本分类信息详表




分析各个企业所在的类别，可以看到12个样本企业确实具有不同的特征。在表7.4和表7.5中，本土企业无一例外地属于类型1，而跨国企业除了韩系跨国企业LG和三星外，都属于类型2。表7.6和表7.7中，本土企业都属于类型1，跨国企业包括韩系跨国企业都属于类型2。

对于上面的分析，我们自然而然会想到这样一个问题：2001年和2002年这两年当中，韩系跨国企业LG和三星是否与本土企业属于一个类型呢?

为了解答这个问题，我们首先使用层次聚类方法，来研究大体的类别结构。层次聚类方法对给定的数据集进行层次的分解，直到某种条件满足为止。我们采取凝聚层次聚类方法，它是一种自下而上的策略，首先将每个对象作为一个簇，然后层层递进，合并这些子簇为更大的簇，直到所有的对象都在一个簇中，或者某个终结条件被满足。

通过层次分析的过程，我们可以初步判断将韩系跨国企业LG和三星归入本土企业同一类别或者是划入新的一类是否合理。

（4）首先选择“Analyze”→“Classify”→“Hierarchical Cluster”，进入层次聚类的设置菜单。在左侧的变量选择文本框中选择6个类别变量，从“s20ls_mean”到“s34mr_mean”，进入右侧的聚类变量文本框。接着选择“name”作为类别标题，并勾选“cases”，如图7.13。然后点击“Plots”按钮，对输出结果进行设置。




图7.13　层次聚类分析菜单的设置

（5）在绘图选择中，勾选树形结构图（“Dendrogram”），并在“Orientation”选项中选择水平方向（“Horizontal”），如图7.14。这样就会输出水平方向延伸的树形结构图。




图7.14　输出图形设置中树形结构图的选择

（6）我们在输出窗口，能够看到一张树形的凝聚结构图，如图7.15。分析这张图，我们可以发现凝聚的过程中本土企业TCL、海信、长虹、康佳、创维和海尔首先聚合成一类，与此同时，韩系企业三星和LG也聚成一类，在距离超过10的时候，本土企业和韩系企业这两类才聚成一类。因此把韩系企业看做独立的一类具有合理性。




图7.15　树形的凝聚结构图

通过层次分析，把韩系企业看做独立的一类是合理的。我们重新使用K均值聚类分析来获得3类不同企业的类结构，进而研究其差异性。

（7）选择“Analyze”→“Classify”→“K-means Cluster”，进入K均值聚类分析菜单，在左侧的变量选择文本框中选择6个类别变量，进入右侧的聚类变量文本框。接着选择“name”作为类别标题，并在“Number of Clusters”中设置类别数3，如图7.16，然后点击“确定”。




图7.16　K均值聚类分析菜单的设置

（8）在结果（“Output”）窗口，我们可以看到聚类分析的结果。“Cluster Membership”表记录了每一个企业所属的类别，如表7.8。这时我们可以看到LG和三星聚为一类，编号为1；长虹、创维、海尔、海信和TCL等本土企业聚为一类，编号为2；飞利浦、东芝、松下、索尼等企业聚为一类，编号为3。

表7.8　2001年观察样本分类信息详表




（9）进一步分析“Final Cluster Center”表（表7.9），我们可以发现2001年的情况是，如果以29寸彩电为分界线，对于韩系品牌而言，低于29寸的产品比重约为46%，高于29寸的产品比重为11%，在低端为主的情况下，韩系品牌也占据一部分高端市场；对于本土品牌而言，低于29寸的产品比重约为50%，高于29寸的产品比重为6%，明显以低端为主；而其他欧美系和日系品牌，低于29寸的产品比重约为28%，高于29寸的产品比重为23%，高端的比例明显高于其他品牌。

表7.9　2001年观察样本类中心结构表







7.5.3　企业分类的可靠性验证



上面聚类分析得到的类中心是否能够很好说明3类企业的类别特征，我们需要进一步对企业分类的可靠性进行验证。我们使用的方法是非参数检验中的χ

2


 检验。

χ

2


 检验主要比较一个因素两项或多项分类的实际观察频数与理论频数分布是否相一致的问题，或者说是否存在显著差异。χ

2


 检验的计算公式为：




其中f

o


 是实际频数，f

e


 是理论频数。

如果我们把一个品牌的销售结构看做是实际频数，把聚类分析得到的类中心结构看做是理论频数，就转化为了一个χ

2


 检验的问题。我们希望批量分析12个品牌的销售结构，这一次使用Excel完成χ

2


 检验。

（1）首先把SPSS中2001年的数据复制入Excel表，结果如图7.17所示。




图7.17　复制SPSS数据到Excel表

（2）由于我们分析的是每个品牌产品的销售结构是否和聚类分析得到的类中心的结构一致，我们首先需要把数据进行转置，使品牌名称成为列名，产品的结构成为行名。

首先选中数据区域，然后右单击鼠标，出现浮动菜单，选择复制。然后选择Excel表新的区域，右单击鼠标，在浮动菜单中选中“选择性粘贴”，这时候在屏幕上会出现菜单，如图7.18。勾选其中的“全部”、“无”和“转置”三个选项，然后点击“确定”。




图7.18　选择性粘贴菜单设置

（3）可以看到数据就完成了转置，结构如图7.19。




图7.19　转置后的数据结构

（4）我们首先验证2001年数据聚类分析得到的类别1，韩系品牌的类中心结构是否符合韩系品牌的销售结构，而另一方面其他品牌的销售结构与之显著不同。首先在Excel表中输入表7.10的类中心数据。

表7.10　第1类韩系品牌的类中心




（5）然后构建一张空表，如图7.20，在单元格中LG对应tv20ls的单元格中输入公式“（B2-
 O
 2）^2/
 O
 2”，其中B2为LG小于20寸产品的销售比重，O2是类中心对应的值。




图7.20　χ

2


 检验的计算公式输入

（6）完成了单个（f

o


 -f

e


 ）/f

e


 的求值，下一步就是把所有的值加总，计算χ

2


 统计量。如图7.21，使用Excel中的求和函数“SUM（）”，计算χ

2


 统计量为3.77。




图7.21　数值求和

（7）下面计算χ

2


 统计量对应的P值。打开Excel的函数，在统计中选择函数CHIDIST（数值，自由度），该函数有两个参数构成，其中数值为χ

2


 统计量，自由度为K-1，值为5，如图7.22。最后求得的P值为0.6，显然大于5%的显著性水平，接受原假设，可以认为LG的销售结构与其类中心的结构相符。




图7.22　求χ

2


 统计量对应的P值

（8）拖动Excel单元格，我们就求出了各个品牌对应于类别1类中心结构的χ

2


 值以及其P值。我们整理结果得到表7.11、表7.12、表7.13。

表7.11　各品牌销售结构与类中心1销售结构的χ

2


 检验结果




表7.12　各品牌销售结构与类中心2销售结构的χ

2


 检验结果




（续表）




表7.13　各品牌销售结构与类中心3销售结构的χ

2


 检验结果




从3张表的P值分析，我们可以看到属于该类别的品牌其销售结构与类中心销售结构的χ

2


 检验的P值不显著，而不属于该类别的品牌其销售结构与类中心销售结构的χ

2


 检验P值显著。因此对2001年数据进行K均值聚类分析得到的类中心结构能够代表特定类别品牌销售结构的特征，其可靠性得到验证。同理，我们可以对2002年、2003年和2004年数据聚类分析得到的类中心进行χ

2


 检验。限于篇幅，这里不再复述。




7.5.4　产品线结构的时间变化特征研究



（1）既然类中心能够很好地代表该类别的产品销售特征，我们把各年类中心汇总，从时间维度分析类中心变化特征。如图7.23，把类中心数据复制入SPSS，在变量窗口设置各变量名。




图7.23　年度变化的类中心变量名设置

（2）返回数据视图，在类别变量（“Class”）中设置产品不同尺寸的分类名称，如图7.24。




图7.24　设置产品不同尺寸的分类名称

（3）选择“Graphs”→“Legacy Dialogs”→“Bar”，进入条形图的设置菜单，选择“Clustered”类型图形，并勾选“Values of individual cases”选项，对数值进行绘图。然后点击“Define”按钮，如图7.25。




图7.25　条形图参数设置

（4）如图7.26，在左侧的文本框中选择year2001到year2004这4年的年份变量，然后在“Category Labels”选项中，选择变量（“Variable”），并选择“class”变量。




图7.26　条形图的参数设置

（5）最后在“Output”窗口中，得到跨国企业和本土企业年度变动的产品销售结构图，如图7.27、图7.28。




图7.27　跨国企业2001年至2004年产品销售结构变动图




图7.28　本土企业2001年至2004年产品销售结构变动图

如图7.27，这是四年间跨国企业产品销售结构的动态变化过程。可以看到跨国公司21寸、25寸等低端产品的比重逐步减少，而34寸以上的比重逐渐增大，从2001年略超过10%增加到2004年超过34%。

对高端产品份额和低端产品份额做统计的相关性分析。结果显示两者的相关系数是-0.97，在0.01的水平上显著。这说明高端产品比例的增长和低端产品比例的减小是高度负相关的，两者确实存在明显的替代关系。跨国企业在四年间战略性地逐渐收缩低端产品线，延伸高端产品线。

如图7.28，这是四年间本土企业产品销售结构的动态变化过程。可以看到跨国公司21寸、25寸等低端产品的比重基本不变，而34寸以上的比重上升不大。

对本土企业做的相关性分析。结果四年间高端产品份额和低端产品份额的相关系数是0.177，并且不显著。这说明对于本土企业而言，四年间并不存在收缩低端产品线、延伸高端产品线这种技术领先战略表现出来的行为特征，本土企业战略的重心仍然是以低端产品为主。

通常情况下，低端市场的产品处于生命周期的末端，这一阶段技术已经成熟，产品规模化生产，而且市场的进入壁垒很低，这意味着潜在厂商能够较为容易地进出市场；而另一方面，市场需求趋向饱和，需求增量下降。从动态的角度看，随着时间的推移，较低的进入成本使得低端市场的厂商数量不断增加，从而加剧了市场竞争；而市场需求的饱和甚至下降将进一步恶化低端市场中企业的生存空间，低端市场动态的变动趋势正是处于生命周期末端的产品走向消亡的必然过程，而这种动态的变动趋势也改变了低端市场的微观环境。低端市场上厂商的市场空间不断受到挤压，利润水平不断下降。而此时新兴市场的产品技术不断成熟，消费群体稳步增长。拥有技术优势的厂商必然会收缩低端产品线，放弃低端市场，然后延伸高端产品线，进入新兴市场，从而提升自身的利润水平；由于低端市场上厂商的退出，市场竞争烈度的下降，低端市场在位企业的利润水平也会因此有所改善。







实验8　股票贝塔系数的计算






8.1　实验目的



（1）理解β系数的理论涵义。

（2）熟练掌握数据的读取、整理、收益率的计算。

（3）能够运用三种主要方法计算β系数。




8.2　实验原理



β系数，是特定资产（或资产组合）系统风险度量指标，体现了特定资产的价格对整体经济波动的敏感性。即，市场组合价值变动1个百分点，该资产的价值变动了几个百分点。

β系数一般有三种估计模型，分别是基于定义、CAPM模型以及单因素模型的估计。

1）基于定义估计

根据系数的定义，得到以下估计：




其中：r

k


 表示证券在第t个单位时间段的收益率，
 表示证券的平均收益率，r

m


 表示证券市场组合在第t个单位时间段的收益率，
 表示证券市场组合平均收益率。这种做法假设在某个时间段T内的β系数不变，没有衡量时变的β系数。

2）基于CAPM估计

CAPM指出，在市场处于均衡的时候，某种证券或组合的投资收益和风险存在一定的关系，CAPM可表示为：

E（r

k
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f


 +β
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 （E（r
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这里，β

k


 =cov（r

k


 ，r

m


 ）/D（r

m


 ）是资产K的贝塔系数，也是收益率对随机折现系数的敏感度，它表示资产K的系统风险测度，从而可以利用β系数将资产组合的风险区分为系统风险和非系统风险。r

m


 是最优风险证券组合的收益率，D（r

m


 ）是最优风险证券组合的方差，r

k


 是某种资产的收益率，cov（r

k


 ，r

m


 ）为资产K与最优风险证券组合之间收益率的协方差，r

f


 为无风险证券收益率。

3）基于单指数模型

与CAPM相比，单指数模型也叫市场模型（Market Model），是一种基于现实市场中证券资产的价格或收益变动普遍存在同涨同跌现象，认为这种联动关系式由市场收益这个共同因素影响。模型不需要太多的假设，可以表示如下：
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8.3　实验数据



现有股票上海机场的日价格数据stk.xls、上证指数的日价格数据idx.xls，以及期间1年期的存款利率，日期从2000年1月5日到2008月12月31日，摘自锐思数据库。

上海机场的日价格数据由两个变量构成：日期sdate和日收盘价stk，数据样式如表8.1。

表8.1　单个股票的数据结构




上证指数的日价格数据由两个变量构成：日期sdate和上证指数idx，数据样式如表8.2。

表8.2　股票指数的数据结构




1年期的存款利率两个变量构成：日期sdate和1年期存款利率iret，数据样式如表8.3。

表8.3　存款利率的数据结构







8.4　实验内容



下面利用SPSS软件计算单个股票的β系数。请完成下列步骤：

（1）使用SPSS软件读取数据stk.xls和idx.xls。

（2）对数据进行整理，把价格数据转化为对数收益率数据。

（3）分别利用β系数定义、CAPM模型和单指数模型计算单个股票的β系数。

（4）比较三者的结果并作出必要的理论解释。




8.5　操作步骤与结果






8.5.1　数据的读取



（1）我们下载的原始数据分别为上证指数（idx.xls）、股票上海机场收盘价（stk.xls）和一年期的存款利率（ist.xls）。在把数据读入到SPSS前，首先要利用Excel中对数据进行一定的处理。其中最关键一点，就是要把日期数据转换成SPSS能够读取的格式。如图8.1，第一列sdate是日期变量，它的格式为“yyyy-mm-dd”。对于SPSS而言，一般能够读取的日期格式“mm/dd/yyyy”，因此我们设法在Excel中将格式转化为“mm/dd/yyyy”。




图8.1　idx.xls的数据格式

（2）在Excel中，选中sdate这一列，右单击鼠标，跳出菜单框，选择其中的设置单元格格式一项，如图8.2。




图8.2　选中日期列并设置单元格格式

（3）在“单元格格式”的菜单中，我们并不直接选择”日期“格式，因为“mm/dd/yyyy”并不是Excel中的常用日期格式，在“日期”格式的固有选项中无法找到。我们选择“自定义”，在类型中输入“mm/dd/yyyy”，创建新的一类日期格式。最后点击“确定”，如图8.3。




图8.3　自定义日期格式

（4）此时我们就可以看到在Excel中，日期格式已经满足SPSS的识别要求，如图8.4。下面就是把数据导入到SPSS。




图8.4　调整后的Excel的日期格式

（5）打开SPSS，注意我们选择“Open Database”→“New Query”导入数据，由于它是通过特定的数据引擎打开数据，因此这个方法导入数据比使用Open方法读取数据更好，读入格式不容易出错，如图8.5。




图8.5　SPSS New Query方法

（6）进入“外部数据导入”向导，我们选择Excel Files格式，图8.6。然后点击“OK”确定。




图8.6　“外部数据导入”选择Excel数据引擎

（7）然后就会跳出“数据选择“的对话框。左侧的文本框读取了Excel表格的结构，展开Sheet1
 ，我们可以看到这张表下有4个变量sdate、idx、F3、F4，我们需要读入的是前两个变量。单击需要读取的变量，这两个变量就会出现在右侧的文本框中，如图8.7。




图8.7　设置需要从Excel中读取的字段名

（8）之后的几个对话框按照默认设置选择“确定”后，我们就把数据读入到SPSS中，保持数据为idx.sav，数据结构如图8.8。




图8.8　读入数据的数据结构

（9）同理，我们把股票上海机场收盘价（stk.xls）数据读入SPSS，保持为stk.sav。




8.5.2　收益率的计算



下面，我们以上证综指idx.sav为例，说明如何运用SPSS的“Transform”选项，把价格数据转化为收益率数据。

（1）我们利用公式R

t


 =ln（P

t


 ）-ln（P

t-1


 ）计算对数收益率。在SPSS中，选择菜单栏“Transform”→“Compute Variable”，出现操作菜单，如图8.9。




图8.9　“变量计算”菜单中计算指数的对数

（2）我们在操作菜单的函数组（Function group）中可以选择相应的函数组，现选择Arithmetic组，则在下面的选择框中出现对应的各类运算函数，选中对数函数LN（）就会在Numeric Expression文字框出现，选中要分析的字段idx，并重新命名一个变量Indix，就生成一个新的变量，这样不会替代原有变量，如图8.10。




图8.10　修改后的数据结构

（3）我们仍然运用菜单栏中“Transform”菜单转换数据。选择之前生成的Indix变量，然后减去Indix变量的滞后一项，选择Lag（）函数实现对Indix变量滞后一项，这样就能生成需要的对数收益率，最后重新命名一个变量ret，如图8.11，点击“OK”按钮，我们就完成了收益率的转换。




图8.11　“变量计算”菜单中计算对数收益率

（4）在SPSS中我们就得到上证指数的收益率数据ret，如图8.12。由于滞后一项的原因，使得ret少去一个自由度，缺失第一项。




图8.12　计算对数收益率后数据视窗的数据结构

（5）最后我们把idx、Indix等变量剔除，保留日期sdate和收益率ret，如图8.13，对idx.sav的收益率转换就完成了。




图8.13　整理后的数据结构

（6）同理，我们完成对stk.sav的收益率转换。




8.5.3　数据的合并



要利用CAPM模型回归分析，我们需要把idx和stk的收益率数据合并到一起。注意，由于股票存在各种停牌的情况，如分红、公告等。股票的数据通常都不是完整的，会少于上证指数的数据。在合并数据的过程中，我们必须对齐idx和stk的日期，也就是需要剔除股票停牌日对应上证指数的数据。如果手工做的话，就需要校对两组数据的日期，而通过SPSS的数据合并方法，我们可以很方便实现数据的合并。

在实施数据合并前，我们需要选择关键变量，关键变量必须没有重复，每个变量值能够明确地指出一个特定的case。然后必须对两个数据库（.sav文件）按照关键变量升序排序，否则程序会出错。

在idx和stk这两个数据中，关键变量就是日期sdate。注意两个数据中关键变量的变量名需要相同，但其他变量名不能相同，否则合并中相同变量名的数据就会被覆盖。

（1）在idxret.sav中，首先使用SPSS菜单项中“Transform”→“Compute Variable”，跳出“变量计算”对话框。我们在“Numeric Expression”中选择ret变量，并在“Target Variable”文本框中命名一个新的变量名idxret，如图8.14，点击“确定”后，就能生成一个新的变量。然后我们把原来的变量ret删除掉。




图8.14　利用“变量计算”菜单设置新变量的变量名

（2）这样我们就得到了包含sdate和idxret两个变量的SPSS数据集，如图8.15。




图8.15　转换后的数据结构

（3）下面，我们必须对数据按照关键变量进行排序。选择SPSS菜单栏中“Data”→“Sort Cases”选项，如图8.16。




图8.16　数据排序的菜单选择

（4）如图8.17，“数据排序”菜单栏中，选择关键变量sdate，同时选择默认的升序Ascending后，点击“OK”确定。




图8.17　设置排序的关键变量

（5）这样就完成了idx.sav变量名的转换，以及按照关键变量sdate的排序，我们把结果保存为idxret.sav，如图8.18。




图8.18　指数收益率设置后的数据结构

（6）同理，完成对stk.sav的变量名转换，并依据关键变量sdate，对数据进行排序，结果如下，保存为stkret.sav，其数据结构如图8.19。




图8.19　个股收益率设置后的数据结构

（7）首先我们打开stkret.sav，作为数据导入集。我们打开“Data”→“Merge Files”→“Add Variables”，如图8.20。




图8.20　数据合并的菜单选择

（8）在“增加变量”对话框中，选择“外部SPSS文件选项”，点击“Browse”选择数据集idxret.sav，如图8.21。




图8.21　选择外部数据集

（9）在“添加变量”选项卡中，出现了加号（+）和星号（*）的两类变量名。星号（*）对应的是导入数据集中的变量名，而加号（+）则对应的是导出数据集中的变量名。由于两个数据集的长度不同，我们需要依据关键变量sdate进行数据取舍。因此我们要勾选“Match cases on key variables in sorted files”，即依据关键变量匹配排序数据集。选择sdate作为关键变量，并且选择导入数据集作为关键数据集，如图8.22。这样就生成了数据合并程序。




图8.22　合并数据集的菜单设置

（10）数据集合并的程序如下：




（11）运行后我们得到数据集，如图8.23。




图8.23　整理后的数据结构




8.5.4　风险溢价的计算



要使用CAPM模型，我们要计算风险溢价的大小，即市场收益率必须要减掉无风险收益率。我们使用1年期的金融机构存款利率作为市场无风险利率，数据结构如图8.24。由于利率变化是离散的，在计算风险溢价的过程中，我们首先需要把无风险利率加入刚才处理完毕的收益率数据集中。




图8.24　无风险收益率的数据结构

（1）选择“Transform”→“Compute Variable”选项，在“Target Variable”文本框中生成一个新的变量rskf用于存放无风险利率，由于日期“02/21/2002”前的无风险利率是2.25，因此在“Numeric Expression”文本框中键入2.25，并选择“If”条件框。这里的思路是进行日期筛选，即对满足早于日期“02/21/2002”的rskf设置值为2.25，如图8.25。




图8.25　“变量计算”中设置无风险变量rskf

（2）点击“If”选项，就会弹出“数据筛选”对话框，在“数据筛选”对话框中，我们选择“Function group”选择框中的“All”，即全部函数，然后在函数选择框“Functions and Special Variables”中找到“Date.Mdy（）”函数。

注意这里之所以要选择这一函数，是我们要进行日期比较，必须要把日期条件“02/21/2002”转换为SPSS能够识别的日期格式，由于我们idxret.sav中的日期格式为“mm/dd/yyyy”类型，因此我们选择“Date.Mdy（）”。如果是其他格式如“dd/mm/yyyy”，则要使用函数“Date.Dmy（）”。

Date.Mdy（mm，dd，yyyy）的参数为月，日和年。因此对应于“02/21/2002”，我们输入Date.Mdy（2，21，2002）则生成SPSS能够识别的“mm/dd/yyyy”类型的日期数据。

选择“include if case satisfies condition”选项，并在文本框中输入判别条件：“sdate＜date.mdy（2，21，2002）”，如图8.26。




图8.26　“变量计算”中日期函数的选择

（3）点击“确定”后，得到数据如图8.27所示，我们看到所有早于2002年2月21日无风险收益率rskf都设置为2.25。




图8.27　计算后的数据结构

（4）在2004年10月29日和2002年2月21日之间无风险收益率为1.98。我们继续使用“Transform”→“Compute Variable”选项来设置rskf的值。

注意，此时“Target Variable”文本框中的变量必须设置为rskf，即与上一次的无风险利率变量名相同，这样做的目的是在于替换原有的变量rskf，由于是依据条件If替换，新条件与原来的条件不重叠，因此新生成的结果并不会把原来的结果覆盖，这样就实现了新记录的“添加”。

由于2004年10月29日和2002年2月21日之间的无风险利率是1.98，因此在“Numeric Expression文本框中键入1.98”，并选择If条件框，在If条件框中设置满足日期在2004年10月29日和2002年2月21日之间的记录对应的rskf变量修改为1.98，如图8.28。从而整个记录集实现一次条件更新。




图8.28　“变量计算”中无风险利率值的设置

（5）点击“If”选项，就会弹出“数据筛选”对话框，在“数据筛选”对话框中，我们首先选择选项栏“include if case satisfies condition”，然后双击左侧文本框中的sdate变量，此时在条件文本框中出现sdate变量。我们在中间的运算符号键盘区选择“>=”符号，在条件文本框中出现“>=”比较符号。

接着，继续选择“Function group”选择框中的“All”，即全部函数，在函数选择框“Functions and Special Variables”中找到“Date.Mdy（）”函数，设置“Date.Mdy（2， 21，2001）”。

在运算符号键盘区选择“＆”符号，然后重复上面步骤的操作，生成第二个条件“sdate＜Date.Mdy（2，21，2001）”，如图8.29。




图8.29　“变量计算”菜单中设置If条件

（6）完成以上设置，点击“确定”后，得到数据如下：我们可以看到从2002年2月25日起最后一列，即rskf的值变为1.98，而原来的值2.25并没有覆盖掉，仍然存在。实现了记录的“添加”，最后的结果如图8.30。




图8.30　完成设置后的数据结构

（7）下面就是要重复上面的步骤，把2000年1月1日至2008年12月31日之间的无风险利率全部“添加”到记录集中。为了简化过程，我们有一个十分有用的技巧，就是使用SPSS的程序。在Output窗口中，我们可以看到执行刚才操作的程序段：




我们复制这段程序，然后点击“File”→“New”→“Syntax”，生成一个新的“syntax”命令编辑窗口，复制刚才在Output窗口中的那条程序。







在syntax命令窗口中编辑我们刚才复制的程序，修改条件和rskf的值，就生成了以上的程序段。选择以上程序段然后单击“运行”，就生成最终的结果。syntax命令编辑窗口中的这段程序实际就是重复窗口操作过程。

我们通过命令行实现了简化，提高了效率，这个技巧我们在SPSS的操作中可以一直使用。

（8）生成的结果如下，由于第一行有两个变量没有结果，我们选中第一行，右单击鼠标，出现选择菜单，删除第1条记录。




图8.31　删除数据集中不必要的变量

（9）注意，此时的无风险利率是年化的利率，我们需要除以250（交易日），转化为日无风险收益率。我们仍然选择“Transform”→“Compute Variable”选项来计算日无风险收益率，在“Numeric Expression”选项中输入公式“rskf/250”，同时在“Target Variable”文本框中输入一个新的变量名rskfd。单击“确定”后，就生成了日无风险收益率rskfd，如图8.32。




图8.32　“变量计算”中设置日收益率

（10）最后我们要把市场的收益率剔除掉无风险的收益率。再一次选择“Transform”→“Compute Variable”选项来计算风险溢价。

首先选择“变量计算”菜单中的“重置”键（reset），清空之前的公式。然后在“Numeric Expression”选项中，然后输入公式“idxret-rskfd”，同时在“Target Variable”文本框中输入一个新的变量名rskfret。单击“确定”后，就生成了风险溢价rskfret，如图8.33。




图8.33　“变量计算”菜单中设置风险溢价

（11）清除不需要的中间变量，最后我们生成结果如图8.34，这样我们数据的整理和转换就全部完成了。




图8.34　整理后的数据结构




8.5.5　计算β系数



1）定义计算β系数

（1）下面我们利用CAPM模型计算β系数。根据CAPM模型，我们需要做的是单个股票收益率对风险溢价率的回归，如图8.35。




图8.35　计算相关系数

（2）点击“确定”后，我们就能在Output窗口，看到输出结果。注意我们要求的是变量idxret与stkret之间的相关系数，即是β系数0.623，在0.01的水平下显著，如表8.4。

表8.4　相关性分析结果



Correlations




**.Correlation is significant at the 0.01 level（2-tailed）.

最后，根据定义计算得到的β系数为0.623。

2）CAPM模型计算β系数

（1）下面我们利用CAPM模型计算β系数。根据CAPM模型，我们需要做的是单个股票收益率对风险溢价率的回归。选择SPSS菜单栏中“Analyze”→“Regression”→“Linear”选项。




图8.36　线性回归的选择

（2）在线性回归的选择框中设置回归的参数。选择“被解释变量”（Dependent）为stkret；解释变量（Independent）为rskfret，如图8.37。




图8.37　回归参数的选择

（3）点击“确定”后，我们就能在Output窗口，看到输出结果。我们主要分析的是三张表。

第一张表是模型概况（Model Summary），其中有模型回归的拟合优度值，用来判断回归的质量，如表8.5。拟合优度值为0.39，不算太差。

表8.5　回归模型概况



Model Summary




a.Predictors：（Constant），rskfret

第二张表是方差分析（ANOVA），如表8.6，在0.01的显著性水平下显著。

表8.6　回归方差分析



ANOVA

b







a.Predictors：（Constant），rskfret



b.Dependent Variable：stkret

第三张表是回归系数表（Coefficients），如表8.7，常数项系数为0.006，在0.01的显著性水平下显著；变量rskfret之前的系数为0.787，在0.01的显著性水平下显著。

表8.7　回归系数表



Coefficients

a







a.Dependent Variable：stkret

根据CAPM模型的假设，我们可以看到回归结果中α和β都统计显著。利用CAPM模型计算得到的β系数为0.787。

3）单指数模型计算β系数

（1）利用单指数模型选择计算β系数，仍然使用回归的方法。相对于CAPM模型而言，单指数模型使用单个股票收益率和市场指数收益率。在SPSS菜单栏中“Analyze”→“Regression”→“Linear”选项。在“被解释变量”（Dependent）选项框中选择stkret变量，在“解释变量”（idxret）选项框中选择idxret变量。然后选择“确定”。




图8.38　单指数模型回归参数的设置

（2）我们能在Output窗口，看到输出结果。分析三张表的结果。

第一张表是模型概况（Model Summary），如表8.8，模型回归的拟合优度值0.388，与之前CAPM模型求得的拟合优度值0.39，两者相差不大。

表8.8　回归模型概况



Model Summary




a.Predictors：（Constant），idxret

第二张表是方差分析（ANOVA），如表8.9，方差分析在0.01的水平下显著。

表8.9　回归方差分析



ANOVA

b







a.Predictors：（Constant），idxret



b.Dependent Variable：stkret

第三张表是回归系数表（Coefficients），如表8.10，变量idxret之前的系数为0. 795，在0.01的显著性水平下显著。

表8.10　回归系数表



Coefficients

a







a.Dependent Variable：stkret

根据单指数模型的定义，利用单指数模型计算得到的β系数为0.795。






实验9　财务指标对市盈率解释能力的研究






9.1　实验目的



（1）掌握SPSS中日度数据转化为季度数据的方法。

（2）掌握多元回归中多重共线性问题的诊断。

（3）掌握多重共线性解决的方法，重点了解如何使用因子分析进行降维来解决多重共线性。




9.2　实验原理



在多元回归中，有时候回归的结果会发现估计系数t统计量普遍不显著，但F统计量却显著，这就说明有可能存在多重共线性。所谓多重共线性（Multicollinearity）是指线性回归模型中的解释变量之间由于存在精确相关关系或高度相关关系而使模型估计失真或难以估计准确。

多重共线性解决的方法主要有三种：

（1）采用多种自变量筛选方法相结合的方式，建立一个最优的逐步回归方程。

（2）从专业的角度加以判断，人为地去除在专业上比较次要的，或者缺失值比较多，测量误差比较大的共线性因子。

（3）进行主成分分析，用提取的因子代替原变量进行回归分析。




9.3　实验数据



（1）2001年6月到2011年3月房地产开发与经营行业季度财务指标，如表9.1所示（数据取自财汇资讯）。

表9.1　房地产开发与经营行业季度财务指标




（2）2001年6月到2011年3月房地产开发与经营行业日度市盈率，如表9.2所示（数据取自财汇资讯）。

表9.2　房地产开发与经营行业日度市盈率







9.4　实验内容



市盈率指在一个考察期内，资产的价格和每股收益的比例，该比例通常是衡量资产投资价值的重要指标。企业的股票是否存在投资价值，与企业经营状况的好坏直接相关，而企业经营状况往往能够通过财务数据的变化一窥端倪。因此从内在逻辑看，某个资产市盈率的高低应该与其财务指标存在关联。

本实验选择房地产行业从2002年到2010年8个主要的季度财务指标数据，以及期间的月度行业平均市盈率。通过回归模型研究行业市盈率与行业财务指标的内在联系。

（1）整理行业平均市盈率数据PE.xls，利用SPSS把月度数据转化为季度数据，并与季度财务数据fdata.xls合并，形成新的数据集pefdata.xls。

（2）把8个财务指标作为解释变量，市盈率指标作为被解释变量，进行多元回归分析，分析回归结果。

（3）采取相关变量剔除法，解决回归中出现的多重共线性问题，并分析回归结果。

（4）采取逐步回归法，解决回归中出现的多重共线性问题，并分析回归结果。

（5）运用因子分析方法进行降维，解决回归中出现的多重共线性问题，并分析回归结果。




9.5　操作步骤与结果






9.5.1　季度数据的计算



（1）首先把房地产企业的市盈率数据读入SPSS，方法与之前各个练习相同，使用SPSS提供的数据引擎读取Excel文件。我们可以看到， PE数据是日频率数据，如图9.1所示。但是房地产企业的财务数据是季度数据。因此我们要设法把市盈率数据转换为季度数据。




图9.1　市盈率的数据结构

我们的思路是充分利用日期数据的性质，通过SPSS的日期函数，求出每条记录所在的季度，然后利用其“aggregate”选项计算每季度的平均数，这样就能把市盈率日度数据转换为季度数据。

（2）选择“Transform”→“Compute Variable”选项。然后在函数中选择日期函数“XDATE.QUARTER（）”，这是计算日期数据的所属季度的函数。注意这一函数只能处理日期类型的数据。在“Target Variable”文本框输入quar，把数据保存为新的变量，如图9.2，然后点击“确定”。




图9.2　“变量计算”菜单中提取日期季度信息

（3）然后我们可以看到生成了一个新的变量quar，类型为数值型，如图9.3。




图9.3　生成季度标示的数据结构

通过日期季度函数的计算，我们获得每个数据的所属季度信息。但由于缺乏年度信息，仅仅利用quar变量，我们无法区分数据的不同年度，也就不能做分组统计。解决的思路是利用日期年度函数，把每条记录日期中的年度信息分离出来。

（4）仍然选择“Transform”→“Compute Variable”选项。然后在函数中选择日期函数“XDATE.YEAR（）”，这是计算日期数据所属年度的函数，如图9.4。同样生成一个新的year变量。




图9.4　“变量计算”菜单中提取日期年度信息

（5）这样数据中多了两个变量year和quar，分别包含了每条记录的年度信息和季度信息，如图9.5。




图9.5　包含年度信息和季度信息的数据结构

（6）为了按照季度分组，我们需要综合使用年度信息和季度信息。这里我们需要运用一个技巧把两个信息合在一起，生成不重复的唯一组别标志，它的原理是：我们把year变量的数值乘以10然后加上quar变量，这样新生成数值个位数包含了原来的季度信息，而个位以上的各个位置包含了年度信息。这样新生成的数值就能区分每条记录不同年度和不同季度。

选择“Transform”→“Compute Variable”选项，生成一个新变量flag，用来作为分组的变量，如图9.6。




图9.6　“变量计算”菜单中合成新的日期信息

（7）点击“确定”后，我们可以看到生成了新的变量flag，如图9.7。




图9.7　包含年份和季度日期信息的数据结构

（8）有了分组标志，下面就能够分组汇总计算获得季度平均数据。如图9.8，选择“Data”→“Aggregate”选项，如图9.8。




图9.8　数据汇总的菜单选择

（9）在“Aggregate Data”选项卡中，Break Variable是分组变量，在文本框中选择“flag”。而汇总数据中，我们选择均值函数“Mean（）”。同时保存为新数据集，如图9.9。




图9.9　数据汇总菜单的设置

我们把新数据集命名为data。

（10）这样就会跳出新数据集data，如图9.10，数据类型如下：




图9.10　市盈率的季度数据结构




9.5.2　数据合并



（1）房地产企业从2001年到2011年的季度财务数据指标结构如下，变量x1至x8分别为销售净利率、息税前利润率、销售毛利率、存货周转率、应收账款周转率、固定资产周转率、流动比率和速动比率，如图9.11。




图9.11　财务数据的数据结构

（2）在“增加变量”对话框中，选择“外部SPSS文件选项”，点击“Browse”选择外部数据集data.sav，如图9.12。




图9.12　“数据合并”菜单中外部数据的读取

（3）在“添加变量”选项卡中，出现了加号（+）和星号（*）的两类变量名。星号（*）对应的是导入数据集中的变量名，而加号（+）则对应的是导出数据集中的变量名。由于两个数据集的长度相同，而且有唯一的关键变量sdate。我们依据关键变量sdate进行数据取舍，勾选“Match cases on key variables in sorted files”，即依据关键变量匹配排序数据集。选择“sdate”作为关键变量，并且选择导入数据集作为关键数据集。这样就生成了数据合并程序，如图9.13。




图9.13　“数据合并”中菜单的设置

（4）我们在数据集financial index下，我们看到新添加了一个变量pe_mean，如图9.14。




图9.14　数据合并后视图窗口的数据结构




9.5.3　市盈率与财务指标的回归分析



（1）为了研究房地产企业股票市盈率与房地产企业财务指标的关系，我们使用“Analyze”→“Regression”分析两者之间的关系，如图9.15。




图9.15　线性回归分析菜单的设置

在“被解释变量”选项中，选择“pe_mean”。同时在“解释变量”选项中，选择所有财务指标变量。点击“确定”后，就得到回归的结果。

（2）在Output窗口，我们可以得到回归的结果。下面我们简单分析回归的结果：

如表9.3，模型的拟合优度为0.403，调整的拟合优度为0.243。

表9.3　回归概况表



Model Summary




a.Predictors：（Constant），速动比率，固定周转率，存货周转率，息税前利润率，流动比率，销售毛利率，销售净利率，应收账款周转率

如表9.4，方差分析中F值为2.526，在0.05的显著性水平下显著。

表9.4　回归方差分析表



ANOVA

b







a.Predictors：（Constant），速动比率，固定周转率，存货周转率，息税前利润率，流动比率，销售毛利率，销售净利率，应收账款周转率



b.Dependent Variable：pe_mean

观察回归系数表9.5，我们发现在0.05的显著性水平下，几乎所有解释变量的P值都不显著。出现这样的结果，我们必须考虑是否解释变量选择存在一定的问题。虽然我们选取了8个不同的财务指标，但这些指标之间可能存在相关性，同时进入回归方程，就会产生多重共线性的问题，造成最后的系数检验不显著。

表9.5　回归系数表



Coefficients

a







a.Dependent Variable：pe_mean

（3）相关性分析。为了检验多元回归是否存在多重共线性的问题，我们需要对8个不同的财务指标进行相关性分析，观察不同的财务指标之间是否高度相关。我们选择“Analyze”→“Correlate”→“Bivariate Correlations”。

在“Bivariate Correlations”分析菜单中，所有变量名都列在右侧的选项框中，从中选择8个财务指标，点击中间的方向按钮，需要分析的变量就会出现在“Variables”选项框中。然后我们勾选“Correlation Coefficients”（相关系数）选择框中的“Pearson”系数选项。最后点击“确定”，如图9.16。




图9.16　相关分析菜单的设置

在Output窗口中，就出现了8个财务指标变量之间的相关系数表9.6。其中Pearson Correlation对应的是变量之间的相关系数，Sig对应的是显著性检验的P值。从相关分析表可以看到，某些变量之间存在高度的相关关系，例如，“销售净利率”指标和“息税前利润率”指标相关程度高达0.911，而“销售净利率”指标和“销售毛利率”指标的相关程度也有0.871。这验证了我们的猜测，即回归存在多重共线性的问题。

表9.6　回归分析表



Correlations




（续表）




″.Correlation is significant at the 0.01 level（2-tailed）.



′.Correlation is significant at the 0.05 level（2-tailed）.




9.5.4　多重共线性的解决方法



（1）多重共线性的一个解决途径就是找出引起多重共线性的解释变量，将它排除出去。仔细分析相关系数表，以及8个财务指标的特点，我们可以发现财务指标可以分成3个类别，第一类是盈利能力指标，包含销售净利率、息税前利润率、销售毛利率；第二类是营运能力指标，包含存货周转率、应收账款周转率和固定资产周转率；第三类是偿债能力指标，包含流动比率和速动比率。

变量之间较高的相关程度显然很大程度上由于财务指标的性质造成。那么在剔除相关变量的过程中，一方面尽量使得剔除后的指标之间相关程度降低。另一方面，我们需要考虑财务指标的性质，使得剩下的变量有较强的利润解释能力。

基于这样的思想，我们考虑从3类指标中各选取一个财务数据变量，分别为销售净利率、存货周转率和速动比率。

（2）在回归分析之前，我们首先仍然进行变量的相关性分析，确定新选择变量之间是否存在线性相关，如果个别变量之间相关程度仍然较高，我们就需要调整一下选择的变量。

在“Bivariate Correlations”分析菜单中，从右侧的选项框中选择销售净利率、存货周转率和速动比率这3个财务指标。如图9.17，然后勾选“Correlation Coefficients”（相关系数）选择框中的“Pearson”系数选项，最后点击“确定”。




图9.17　相关分析的菜单设置

（3）在Output窗口中，出现了3个财务指标变量之间的相关系数表9.7。可以看到，除了销售净利率与速动比率这两个指标之间存在一定的负相关关系，相关系数为-0.39，对应的P值为0.014，在5%显著性水平下显著，其他指标两两之间都不存在相关关系。

表9.7　相关性分析表



Correlations




*.Correlation is significant at the 0.05 level（2-tailed）.

（4）我们更换偿债能力指标中另一个变量“流动比率”，再做一次变量之间的相关性分析。分析得到的结果如表9.8，可以发现“流动比率”与“销售净利率”仍存在一定的相关关系，它们之间的相关系数为0.488。而且相较“速动比率”，“流动比率”的P值为0.002，在1%显著性水平下显著。因此，最后我们引入“速动比率”进入回归方程。

表9.8　相关分析表



Correlations




**.Correlation is significant at the 0.01 level（2-tailed）.



*.Correlation is significant at the 0.05 level（2-tailed）.

需要特别提醒的是，一切研究的基础是根据我们的理论假设展开的。这里之所以我们没有同时剔除“速动比率”以及“流动比率”，就是因为这两个变量代表的是一个重要的理论指标—偿债能力。

（5）我们进行回归分析。利用“Analyze”→“Regression”→“Linear”，选择回归分析选项框，被解释变量选择“pe_mean”变量，解释变量选择销售净利率、存货周转率和速动比率，然后点击“确定”。

在Output窗口，我们就可以看到回归的结果。第一张表9.9，回归概况表中列出了模型的回归拟合优度0.298，虽然不高但可以接受。

表9.9　回归概况表



Model Summary




a.Predictors：（Constant），速动比率，存货周转率，销售净利率

在表9.10中，方差分析表中F值为4.95，在0.01的显著性水平显著。这说明解释变量作为一个整体对被解释变量有解释能力。

表9.10　回归方差分析表



ANOVA

b







a.Predictors：（Constant），速动比率，存货周转率，销售净利率



b.Dependent Variable：pe_mean

最后，我们观察回归系数表9.11。其中销售净利率和存货周转率两项指标对应的P值分别为0.296和0.503，说明这两项对应的变量对市盈率的影响统计意义不显著。速动比率的P值为0.008，在0.01的显著性水平下显著。

表9.11　回归系数表



Coefficients

a







a.Dependent Variable：pe_mean

由此我们再一次调整进入回归的变量，只留下一个变量速动比率。利用SPSS再一次做回归分析，对得到的结果我们省略其他各表，仅列出回归参数表9.12，并对结果进行分析。

表9.12　回归系数表



Coefficients

a







a.Dependent Variable：pe_mean

由此我们可以写出回归方程：

pe=-75.03+2.163x

8




回归方程中pe是市盈率，x

8


 是速动比率，回归的结果说明房地产股票的市盈率与速动比率成正比。速动比率增加1个单位，房地产股票的市盈率增加2.16个单位。




9.5.5　运用逐步回归方法进行回归分析



逐步回归分析的实施过程是每一步都要对已引入回归方程的变量计算其偏回归平方和，然后选一个偏回归平方和最小的变量，在预先给定的F水平下进行显著性检验，如果显著则该变量不必从回归方程中剔除，这时方程中其他的几个变量也都不需要剔除（因为其他的几个变量的偏回归平方和都大于最小的一个更不需要剔除）。相反，如果不显著，则该变量要剔除，然后按偏回归平方和由小到大地依次对方程中其他变量进行F检验。将影响不显著的变量全部剔除，保留都是统计显著的。接着再对未引入回归方程中的变量分别计算其偏回归平方和，并选其中偏回归平方和最大的一个变量，同样在给定F水平下作显著性检验，如果显著则将该变量引入回归方程，这一过程一直继续下去，直到在回归方程中的变量都不能剔除而又无新变量可以引入时为止，这时逐步回归过程结束。

利用逐步回归方法，我们可以筛选有效的解释变量，从而实现消除多个变量相关而形成的多重共线性影响。

（1）首先选择“Analyze”→“Regression”→“Linear”选项，进入线性回归分析的界面。在被解释变量选项框中选择x1至x8共8个财务指标，在解释变量框中选择市盈率数据“pe_mean”。在“method”框中选择“Stepwise”，即逐步回归，这样SPSS会按照逐步回归的方法对数据进行回归分析。完成设定后点击“确定”，如图9.18。




图9.18　回归分析菜单中逐步回归的设置

（2）在Output窗口，我们可以看到运行的结果。首先是表9.13模型概况分析，调整拟合优度为0.232。

表9.13　回归概况表



Model Summary




a.Predictors：（Constant），速动比率

表9.14方差分析，反映回归的F值为12.48，在0.01的显著性水平下显著。

表9.14　回归方差分析表



ANOVA

b







a.Predictors：（Constant），速动比率



b.Dependent Variable：pe_mean

从表9.15系数分析表的情况看，逐步回归的结果是最后仅留下一个变量，即速动比率。其系数在1%的显著性水平下显著。因此最后我们得到方程：

pe_mean=-75.03+2.163x

8




表9.15　回归系数表



Coefficients

a







a.Dependent Variable：pe_mean

表9.16剔除变量表，分析了逐步回归中被排除在回归方程中的各个变量，详细说明了排除判断过程。

表9.16　剔除变量表



Excluded Variables

b







a.Predictors in the Model：（Constant），速动比率



b.Dependent Variable：pe_mean




9.5.6　利用因子分析对解释变量降维



多重共线性问题的出现关键在于解释变量之间高度相关。解决多重共线性问题的一种方法就是通过剔除部分相关变量，降低解释变量之间的相关程度。但这种方法的一个问题就是剔除变量的过程就会丢弃部分有用的信息。

另一种解决的思路是利用因子分析寻找解释变量之间的关系，挖掘出公共因子，然后用公共因子作为新的解释变量，替代原来的解释变量，从而实现降维。这一方法的思想：某些解释变量之所以高度相关，是因为它们是某个因素的不同表现方面。因此我们通过析出公共因子，找出这些因素，然后再利用这些因素建立回归方程。

我们首先利用探索性因子分析，寻找解释变量之间的关系，挖掘公共因子。选择SPSS菜单中“Analyze”→“Data Reduction”→“Factor”选项，如图9.19。




图9.19　因子分析的菜单设置

在“Factor Analysis”左侧的文本框中选择需要进行分析的8个财务指标变量，然后点击两个文本框中间的箭头按钮，把需要分析的变量转换到右侧的“Variables”选项框中。

（1）点击“Descriptives”按钮，跳出“Factor Analysis”菜单。选择“Correlation Matrix”选项框中“KMO and Bartlett’s test of sphericity”。这两个指标是用来分析数据是否合适进行探索性因子分析，如图9.20。




图9.20　因子分子的统计检验设置

KMO统计量是取值在0和1之间。当所有变量间的简单相关系数平方和远远大于偏相关系数平方和时，KMO值接近1。KMO值越接近于1，意味着变量间的相关性越强，原有变量越适合作因子分析；当所有变量间的简单相关系数平方和接近0时，KMO值接近0。KMO值越接近于0，意味着变量间的相关性越弱，原有变量越不适合作因子分析。

巴特利特球形检验是以变量的相关系数矩阵为出发点的。它的零假设相关系数矩阵是一个单位矩阵，即相关系数矩阵对角线上的所有元素都是1，所有非对角线上的元素都为零。一般在做因子分析之前都要进行巴特利特球形检验，用于判断变量是否适合用于做因子分析。

（2）设置完“Descriptives”，点击“Extraction”按钮。在“Method”（方法）中选择“主成分分析”，如图9.21。在筛选原则中，设置特征值大于1。




图9.21　因子分析中的降维方法设置

（3）设置完“Extraction”，点击“Rotation”按钮。选择旋转的方法。如图9.22，这里我们选择方差最大原则：“Varimax”，这样析出的因子间相关系数接近0，利用析出因子进行回归就不会存在多重共线性的问题。




图9.22　因子分析旋转变换的方法设置

（4）继续设置“Score”选项。我们需要勾选“Display factor score coefficient matrix”，如图9.23。这样最后我们能够得到析出因子作为被解释变量，原来的变量作为解释变量的回归方程。




图9.23　因子分析中因子得分显示的方法设置

（5）继续对“Options”进行设置。这里对旋转后因子得分系数的显示原则是其绝对值大小大于0.3，即勾选“Suppress absolute values less than”。当然我们也可以根据具体的情况选择大于0.3。另一方面我们也可以勾选“Sorted by size”，即旋转后因子得分系数按照大小排序，如图9.24。




图9.24　因子分析的因子载荷系数显示设置

（6）一切设置完毕后，点击“确定”，我们就能在Output窗口看到对应的结果，如表9.17。

表9.17　KMO和Bartlett球形检验

KMO and Bartlett’s Test




首先是KMO and Bartlett球形检验。KMO系数为0.634，这个系数越接近于1，说明数据越适合于做因子分析，反之则不适合做因子分析。通常情况下，这个系数大于0.5就说明可以进行因子分析。

其次是Bartlett球形检验的χ

2


 统计量为365.8，自由度为28，对应的P值在0. 01显著性水平下显著。拒绝原假设，接受备折假设，说明数据适合进行因子分析。

第二张表是方差分析表，如表9.18。首先看特征根情况（Initial Eigenvalues），我们的原则是选择特征根大于1的值。这里我们可以看到所有因子的特征根按降序排列，前4个数值分别为4.066、1.953、1.334、0.354，可以看到有3个因子的特征根大于1，这也就意味着最后析出3个公共因子。

表9.18　方差分析表



Total Variance Explained




Extraction Method：Principal Axis Factoring.

其次看其方差贡献，原始情况是前三个因子能够解释91.91%的变动。中间一列是提取三个因子后因子载荷的方差贡献，可以看到第一个因子贡献最大，为49.6%。而三个因子一共能够解释85.97%的变动。最后一列是旋转后因子载荷的方差贡献，基本的结果不会相差太大，三个因子一共能解释85.97%的变动。

第三张表9.19是选择后的因子得分矩阵。由于我们设置了0.3的显示原则，这意味着小于0.3的因子得分系数将不会出现。其次所有的得分系数都按照降序排列。

表9.19　因子得分矩阵表



Rotated Component Matrix

a







Extraction Method：Principal Component Analysis.



Rotation Method：Varimax with Kaiser Normalization.

我们可以看到第1列销售净利率、息税前利润率、存货周转率的因子得分为0.944、0.921和0.904，其他两列2和3的得分小于0.3。因此我们可以把这三个财务指标归入第1个因子。我们会发现这三个财务指标正是盈利能力指标。

然后我们看第2个因子，可以发现在存货周转率、应收账款周转率和固定资产周转率三项下因子得分分别为0.905、0.889和0.801，其得分的绝对值要明显大于其他两列的因子得分，因此我们把这三个财务指标归为一类，考察其实际意义，就会发现这就是营运能力指标。

最后还剩下2个指标流动比率和速动比率，虽然流动比率在因子1上的得分0.731要大于因子3上的得分0.569，但根据理论意义我们把流动比率归入第3个因子，即偿债能力指标。

最后我们看到的是表9.20，因子得分系数表，这张表建立了析出因子与原变量之间的回归关系。每1列的系数对应的是每个指标对因子的偏相关系数。

表9.20　因子得分系数表



Component Score Coefficient Matrix




Extraction Method：Principal Component Analysis.



Rotation Method：Varimax with Kaiser Normalization.

根据因子得分系数表的数据，我们可以得到以下3个方程：

Factor

1


 =0.26x

1


 +0.25x

2


 +0.27x

3


 -0.22x

4


 +0.03x

5


 +0.01x

6


 +0.2x

7


 -0.07x

8




Factor

2


 =-0.043x

1


 -0.06x

3


 +0.42x

4


 +0.37x

5


 +0.386x

6


 +0.003x

7


 +0.026x

8




Factor

3


 =-0.20x

1


 +0.02x

2


 -0.10x

3


 -0.11x

4


 +0.03x

5


 +0.09x

6


 +0.42x

7


 +0.7x

8







9.5.7　析出因子的回归分析



通过探索性因子分析我们得到了三个新的解释变量：盈利能力（因子1），营运能力（因子2）和偿债能力（因子3）。而且得到了因子和原有变量的回归方程式。下面我们第一步要做的就是把原来的变量转化为新的变量，然后在利用新的变量建立回归。

（1）点击“Transform”→“Compute Variable”。在表达式文本框中输入第一个回归方程的表达式：x1×0.262+x2×0.247+x3×0.272-x4×0.223+x5×0.029+x6×0. 013+x7×0.197-x8×0.065。并设置新生成的变量名为f1，如图9.25。同理，设置新变量f2和f3，如图9.26、图9.27。




图9.25　“变量计算”菜单中盈利能力指标的计算




图9.26　“变量计算”菜单中营运能力指标的计算




图9.27　“变量计算”菜单中偿债能力指标的计算

（2）选择“Analyze”→“Regression”→“Linear”选项进行回归分析。在线性回归菜单窗口中选择“pe_mean”为被解释变量，f1、f2和f3为解释变量，如图9.28，点击“确定”，进行回归分析。




图9.28　回归分析中参数的设置

在Output的窗口我们获得回归的结果。分析表9.21，回归的拟合优度为0.301，调整拟合优度为0.241，与其他两种方法计算的结果相差不大。

表9.21　回归概况表



Model Summary




a.Predictors：（Constant），f3，f2，f1

从表9.22方差分析表的结果看，F值为5.03，在0.01的显著性水平下显著，说明解释变量对被解释变量有解释能力。

表9.22　回归方差分析表



ANOVA

b







a.Predictors：（Constant），f3，f2，f1



b.Dependent Variable：pe_mean

我们看表9.23，回归系数表，盈利能力（f1）的系数是-2.421，由于市盈率指标中，每股收益是分母，当企业的盈利能力上升，在股价变动不大的情况下，必然会带来每股收益的增长，从而引起市盈率的下降。在0.05的显著性水平下显著。营运能力（f2）统计不显著，而偿债能力（f3）为2.07，在0.01的显著性水平下显著。偿债能力上升，公司的流动性能力强，运营情况良好，会推动股价上升，在每股收益不变的情况下，引起市盈率指标上升。

表9.23　回归系数表



Coefficients

a







a.Dependent Variable：pe_mean

最后我们可以写出回归方程：

pe_mean=-2.421f

1


 -0.512f

2


 +2.07f

3




由此我们可以发现偿债能力与市盈率存在正相关的关系，偿债能力每上升1个单位，则市盈率上升2.07个单位。而盈利能力与市盈率负相关，盈利能力每上升1个单位，则市盈率下降2.42个单位。







实验10　认购权证的行权对标的股票股价的影响






10.1　实验目的



（1）了解事件研究法的原理和主要步骤。

（2）掌握形成期、检验期的构造方法。

（3）掌握超额收益率和累计超额收益率检验的方法。




10.2　实验原理



事件研究法（Event Study）是一种统计方法，是在研究当市场上某一个事件发生的时候，股价是否会产生波动，以及是否会产生“异常报酬率”（abnormal returns），借由此种资讯，我们可以了解到股价的波动与该事件是否相关。

在研究过程中，首先必须确定研究的假说。决定研究假说以后，须确定事件的种类及对应事件日，估计期及事件期的计算期间，并以股价日报酬率估算其预期报酬率，再透过实际报酬与预期报酬的差额，观察整体股利发放事件，判断宣告期间是否具有异常报酬的产生，最后借由统计检验来判断其统计值是否显著。

其具体步骤为：

1）决定研究假说

譬如假设估计期间的CAR并没有产生资讯效果，而事件期的CAR可能产生资讯效果。

2）事件日的确定

事件研究法的第二步，即确定所要研究的事件。所谓的“事件日”，系指市场“接收”到该事件即将发生或可能发生的时间点，而非该事件“实际”上发生的时间点，此时点通常以“宣告日”为准。时点认定的适当与否，对于研究的正确性，会有决定性的影响。

3）市场模式

估计某一事件发生或公布后，对于股价影响，必须建立股票报酬率的“预期模式”，以估计“预期报酬”（expected returns）。股票报酬率的预期模式有很多种，应用最广的是“市场模式”（Market Model）。市场模式假设个股股票的报酬率与市场报酬率间存在线性关系，并以市场报酬率建立股价报酬率的回归模式，公式如下：
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 表示i公司t期的报酬率，计算方式为：（该股t日时收盘价-该股（t-1）日时收盘价）/市场（t-1）日时收盘价。
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 ：表示t期的市场加权指数股票的报酬率，计算方式为：（市场t日时收盘指数-市场（t-1）日时收盘指数）/市场（t-1）日时收盘指数。
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 表示回归截距项。β表示回归斜率。
 表示回归残差项。

4）建立股票报酬率的“预期模式”

针对误差项的部分，根据Fama（1968）、Beja（1972）及Fama（1973）的研究，市场模式有下列的假设：

因此，经由以上所示的公式，可求得个别证券在“事件期”某一期的“预期报酬率”，即为：
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 表示i公司t期的预期报酬率，经由估计期计算得来。
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 表示第t期市场加权指数股票的报酬率。

5）估计平均异常报酬率（AR）、累积异常报酬率（CAR）

一但估计出“预期报酬率”，也就可以得到异常报酬率。为了了解某一特定事件的异常报酬率或累积效果的行为，并且提供有关异常报酬率，何时开始出现关联以及何时结束，采用异常报酬率（AR）及累积异常报酬率（CAR）以看出此项反应。

异常报酬（Abnormal Returns，AR）指以事件期的实际报酬减去事件期的预期报酬：
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 表示i公司第t期的实际报酬率。
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 ）表示i公司第t期的预期报酬率。

而累积异常报酬率（Cumulative Abnormal Returns，CAR），则为特定期间内每日异常报酬率的累加值。

6）异常报酬率的检定

如果异常报酬率为“正”，我们可以推论事件对股价有正的影响；如果异常报酬率为“负”，我们可以推论事件对股价有负的影响。但只知道正负仍不够，因为我们不确定此种影响是否足够明显，因此必须进行“显著性检定”。

7）分析结果

依据研究假说，对于异常报酬率以及检定的结果进行分析，并提出解释。




10.3　实验数据



（1）2001年6月到2011年3月的上证综指和深圳成指的日期和收盘指数，数据取自财汇资讯。

（2）2001年6月到2011年3月认购权证标的股票的日收盘价数据，数据取自财汇资讯。

（3）全部认购权证的行权信息，数据取自锐思数据。

见表10.1。

表10.1　认购权证的信息数据的数据结构







10.4　实验内容



选择中国权证市场所有的认购权证数据，研究认购权证的行权是否会在短期对标的股票的收益率产生影响。

（1）构造标的股票的检验期和形成期。

（2）设定事件检验期为10天，分别计算超额收益率和累计超额收益率。

（3）利用t检验判断认购权证行权对标的股票股价的影响。




10.5　操作步骤与结果






10.5.1　数据的梳理



（1）首先选择SPSS中的“File”→“Open Database”→“New Query”。利用SPSS的数据接口读取外部Excel数据。使用ODBC的Excel文件读取接口（Excel Files），在“ODBC Driver Login”菜单中选择需要读取文件的路径，如图10.1。




图10.1　数据向导读入外部的Excel数据

（2）点击“确定”后，读取第一个标的股票深发展（000001）的数据。其结构如图10.2所示，由交易日期和收盘价构成。




图10.2　标的股票的数据结构

（3）利用SPSS的“Transformation”→“Compute Variable”，首先计算收盘价的对数值lstk，然后仍然使用“Compute Variable”菜单，根据公式ret=lstk-lag（lstk），计算收益率数据，从而形成股价价格的日收益率数据，如图10.3。




图10.3　股价价格日收益率计算的结果

（4）如图10.4，把结果保存为n000001.sav，以便后面进行进一步的分析使用。因为要进行事件研究，我们需要把30个股票超额收益率都用相同的方法计算出来，然后再进行合并后，对所有超额收益率进行统计分析。




图10.4　保存单个股票转化之后的收益率数据集

（5）保存成功后，下一步就需要把指数数据引入数据集，在使用merge方法之前，首先要设置一个合并的关键变量——日期，注意两个数据集的日期必须使用相同的变量名，这样合并才可以进行。因此我们点击n000001.sav中的变量视窗“variable view”，修改n000001.sav中的日期变量名为sdate，如图10.5。




图10.5　合并关键变量（日期）的统一命名

（6）点击“Data”→“Merge Files”→“Add Variables”，选择现存的外部文件选项，并用“Browse”选择要合并数据集的物理地址，如图10.6。




图10.6　从外部的SPSS数据集增加指数收益率变量

（7）如图10.7，勾选“Match cases on key variables in sorted files”选项，并选择“Active dataset is keyed table”选项，然后双击“Excluded Variables”文本框中的sdate变量，这样sdate作为两个SPSS数据集的关键变量，就能实现文件的合并。




图10.7　合并关键变量sdate的设置

（8）完成增加变量菜单的设置后，点击“Paste”按钮，我们就会在syntax窗口看到程序代码。




（9）执行程序代码后，SPSS会把两个数据集合并，生成的文件包含变量：日期（sdate）、个股收益率（ret）和指数收益率（idxret），如图10.8。




图10.8　个数和指数收益率数据合并之后的结构




10.5.2　缺失数据处理



虽然数据集顺利完成了合并，但我们还有一个问题需要解决，就是合并数据集中存在缺失数据，由于个股因为信息公告、召开董事会等原因会出现停牌，相对于指数数据，某些交易日必然存在数值缺失。由于数据量相对较大，一个可行的措施就是剔除这些缺失值所在的记录。

（1）如图10.9，选择“Transformation”→“Compute Variable”，在“Target Variable”中设置一个新的变量名X1，用以标记存在缺失数据的记录。然后设置Numeric Expression为0，点击“确定”。




图10.9　在“变量计算”设置一个新变量X1标记记录缺失信息

（2）这样在SPSS数据集中生产了一个新的变量X1，此时其值都为0。然后我们仍然选择“Transformation”→“Compute Variable”，如图10.10，点击条件（“If”）选项，然后在“If Cases”菜单中，点击“Include if cases satisfies condition”，然后使用NMISS（）函数。这是一个判断是否为缺失值的函数。我们选择“ret”，设置函数值为“NMISS（ret）”。




图10.10　在“变量计算”的条件选择菜单中设置缺失数据统计函数

（3）完成设置后，回到“Compute Variable”主界面，在“Numeric Expression”文本框中设置值为1，如图10.11。这样存在缺失值的记录，则X1就显示为1。




图10.11　设置变量X1中存在缺失的记录所对应的数值

（4）选择“Data”→“Select Cases”，在“选择记录”（Select Cases）菜单中，选择“If condition is satisfied”，然后点击“If”按钮，进入记录选择条件的设置。我们设置条件为“X1=0”，然后在输出选项中选择“Copy selected cases to a new dataset”，并命名记录集名n000001.sav，如图10.12。




图10.12　选择满足条件记录输出到新的记录集




10.5.3　形成期与检验期的分离



下面我们要设法分离形成期和检验期。大体的思路是我们以事件发生日为参照点（通常数值为0）生成一个标志变量，这样就可以依据标志变量截取事件发生日之前的一段时间作为形成期，以及事件发生日左右的一段时间作为检验期。

（1）首先需要对数据按照日期降序规则排序。选择“Data”→“Sort Cases”，双击日期变量Sdate，把它选入排序依据的变量。然后在排序规则（“Sort Order”）中选择降序，如图10.13，设置完成后点击“确定”。




图10.13　对数据按日期排序

（2）在数据视图中我们可以看到，数据按照日期降序排列，如图10.14。




图10.14　排序后的数据结构

（3）下面我们要生成一个标志变量flag，这个标志序列的原点（数值为0），对应的是事件发生日“2007年11月19日”。实现这一目标的思路就是：我们首先生成一个1，2，…，n递增序列，找到这一递增序列中对应日期“2007年11月19日”的值，假设恰好是260，然后把这个递增序列的每个值都减去260，这样在递增序列中对应日期“2007年11月19日”的值就转化为0，之前的数值就为-1，-2，…，-259；而之后的数值为1，2，…，n。

首先生成一个递增序列，变量名为flag，我们可以运用一个简单的循环语句实现，具体代码如下：




我们打开一个新的“Syntax”窗口，输入上面的程序段，如图10.15。然后点击“运行”。




图10.15　在Syntax窗口输入程序段

（4）执行该程序段后，我们在数据视窗就可以看到一列递增序列flag，1， 2，…，n的形式递增，如图10.16。寻找事件执行日期“2007年11月19日”在flag序列中的数值，恰好是697。




图10.16　新生成递增序列之后的数据结构

（5）选择“Transformation”→“Compute Variable”菜单，设置一个新的变量，变量名为ndate，生成规则为“flag-697”，如图10. 17。然后点击“确定”。




图10.17　“变量计算”菜单中设置新的顺序变量

（6）执行上面的操作后，我们在视图可以看到一个新的变量ndate，对应于“11/19/2007”，其值为0，如图10.18。这正是我们需要的新的“日期变量”，我们可以据此分割“形成期”和“检验期”。




图10.18　生成新的“日期变量”后的数据结构

（7）如图10.19，选择“Data”→“Select Cases”。我们通过选择满足条件的记录，并生成新的数据集的方式，分离“形成期”和“检验期”。




图10.19　数据拆分的菜单选择

（8）在“Select Cases”菜单中，选择“If condition is satisfied”选项，进入“If”条件的设置，如图10.20。




图10.20　“数据拆分”菜单中条件设置的选择

（9）对于检验窗口而言，我们检验事件发生日前后2个星期是否存在超额收益率，由于一周的交易日通常为5天，因此2个星期就是10天，而窗口期是计算CAPM模型的区间。通常我们选择最近1年的数据进行分析，我们设置其值为250。两段时间相加，就是选择-10到260之间的所有值。然后删除其他多余的值。我们在“If”设置中，设置条件“ndate＞=-10＆ndate＜=260”，如图10.21。




图10.21　“数据拆分”菜单中数据选择条件的设置

（10）完成条件设置后，在输出窗口中选择“Copy selected cases to a new dataset”，从而把结果输出到一个新的数据集，并命名为f000001.sav，如图10.22。




图10.22　“数据拆分”菜单中输出的设置

（11）新的数据集f000001.sav包含5个变量，分别为日期（sdate）、个股日收益率（ret），大盘指数日收益率（idxret）、日期位置标志（ndate），如图10.23。下面我们设法分离“检验期”和“形成期”。可行的做法是再生产一个标志变量区分检验期和形成期，然后利用Select Cases方法分离两个不同时间的数据，并对应生产两个不同的数据集。




图10.23　拆分后的数据结构

（12）选择“Transformation”→“Compute Variable”选项，设置一个区分不同时期数据的变量class，并设置初试值为0，如图10.24，然后点击“确定”按钮。




图10.24　“变量计算”菜单中设置新的变量class

（13）再次选择“Transformation”→“Compute Variable”选项，设置变量class的值为1，并选择“If”条件选项，如图10.25。




图10.25　“变量计算”菜单中满足条件的变量设置

（14）在条件选项中，勾选“Include if cases satisfies condition”，然后设置条件“ndate＜=10”。完成后点击“确定”，数据集中原变量class中满足条件的值都会被替换为1。这样就完成了“检验期”和“形成期”的标记，如图10.26。




图10.26　在“If”选择中的条件设置

（15）运行后，我们可以在视图窗口观测到新生成的一个新的变量class，如图10.27，注意最后一列就是分类标志class。




图10.27　“窗口期”和“检验期”区分后的数据结构

（16）下面就需要分离“窗口期”和“检测期”的数据。我们选择“Data”→“Select Cases”菜单，然后在“Select Cases”菜单中选择“If condition is satisfied”，点击“If”选项，在条件选项菜单中设置“class=1”，如图10.28。




图10.28　“数据拆分”菜单中条件的设置

（17）回到主界面，在输出选项中，选择“Copy selected cases to a new dataset”，把结果输出到一个新的数据集，并设置数据集名称f000001w.sav，如图10.29。




图10.29　“数据拆分”菜单中“形成期”数据集输出设置

（18）再次选择“Data”→“Select Cases”菜单，然后在“Select Cases”菜单中选择“If condition is satisfied”，点击“If”选项，在条件选项菜单中设置“class=0”。回到主界面，在输出选项中，选择“Copy selected cases to a new dataset”，把结果输出到一个新的数据集，并设置数据集名称f000001e.sav，如图10.30。




图10.30　“数据拆分”菜单中“检验期”数据集输出设置




10.5.4　收益率理论模型的构建



（1）打开“形成期”文件f000001w.sav。使用CAPM模型，选择“Analyze”→“Regression”→“Linear Regression”。在线性回归菜单中，在“解释变量”文本框中选择指数变量idxret，在“被解释变量”文本框中选择个股变量ret，然后在“解释变量”文本框中选择指数变量idxret，如图10.31。设置完成后，点击“确定”。




图10.31　回归菜单的设置

（2）在Output窗口中，观测回归系数表10.2，可以发现常数项为0.004，在10%的显著性水平下显著；而idxret前的系数为0.912，在1%显著性水平下显著。写出CAPM模型为：
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 =0.004+0.912R

m




表10.2　回归系数表



Coefficients

a







a.Dependent Variable：ret

（3）通过形成期求出的模型，我们就能够计算检验期个股的理论收益率。打开检验期数据集f000001e.sav。然后选择“Transformation”→“Computer Variable”，计算检验期个股的超额收益率。设置“Target Variable”为aret，“Numeric Expression”文本框中写入：

aret=ret-0.004-0.9121×idxret。

把检验期每天的收益率减去用模型计算得到的理论收益率，就得到了超额收益率，如图10.32。设置完成后点击“确定”。




图10.32　超额收益率的计算

（4）在Output窗口中，我们就能看到数据多了一列aret，这就是在检验期的超额收益率，如图10.33。




图10.33　超额收益率计算后的数据结构

（5）我们对个股深发展000001的基本整理完成。下面把不需要的变量剔除，留下之后合并需要的日期变量ndate，为了避免后面合并时个股的超额收益率变量重名，我们再把名字改为股票编号ar000001。最后得到的结果如图10.34。




图10.34　整理后的数据结构

（6）最后我们保存数据文件，把结果保存为final1.sav，如图10.35。这样第一个需要整理的股票就完成了。




图10.35　转换完成数据集的保存




10.5.5　不同股票检验期数据的合并



重复上面的过程，我们可以计算26个认购权证对应标的股票在认购权证行权期前后10天的超额收益率。下一步就需要把这些数据合并，然后进行t检验，以识别权证行权是否会对标的股票产生影响。

（1）首先打开一个final.sav数据集，其数据格式如图10.36。




图10.36　final.sav的数据结构

（2）然后选择“Data”→“Merge Files”→“Add Variables”，增加其他各个标的股票检验期的超额收益率数据。我们在“添加变量”菜单中选择外部SPSS数据集，并用“Browse”找到文件的路径，然后点击“Continue”，如图10.37。




图10.37　“添加变量”菜单中选择外部的SPSS数据集

（3）然后在“添加变量”菜单中勾选“Match cases on key variables in sorted files”，选择合并的关键变量ndate，如图10.38。最后点击“确定”。




图10.38　“添加变量”菜单中合并的关键变量设置

（4）我们在Output窗口，就能看到合并之后的数据格式，如图10.39。其中第一列是“日期”标志，以升序排列，第二列是标的股票“深发展”在检验期的超额收益率，第三列是标的股票“宝钢股份”在检验期的超额收益率。




图10.39　合并变量之后的数据结构




10.5.6　检验期数据的转置



重复上面的过程，我们把各个标的股票检验期超额收益率的数据合并到一张表上，下面我们把检验期每一天所有股票的超额收益率看做一个检验样本，检验每一天权证行权对标的股票收益率影响是否统计意义上显著不为0。而当前的数据仍然是按个股排列的，因此在检验之前，我们需要把检验期的数据整体旋转，让其按日期排列。

（1）首先我们需要修改一下日期变量的类型，把原来的数值型转化为字符型，以便作为变量的标识。在变量视图窗口，我们选择ndate的类型为string，如图10.40。




图10.40　日期变量类型的修改

（2）在数据视图中，我们修改ndate的数据形式，从d_-10开始到d_10，如图10.41。




图10.41　日期数据的修改

除了检验每日的超额收益率之外，我们还可以检验每日的累积超额收益率作为检验认购权证行权对标的股票收益率影响的一个补充。累积超额收益率就是把对数收益率累加，因此我们要用SPSS生成一个累积超额收益率序列，这可以通过“时序数列生成”菜单实现。

（3）选择“Transform”→“Create Time Series”，在函数（“Function”）中选择“Cumulative sum”，在“New Variable”窗口中出现函数，选择左侧文本框中需要转变的变量，最后写成赋值程序段“ar1=CSUM（ar600019）”，如图10.42。




图10.42　累积超额收益率的生成

（4）点击“确定”后，我们就能够在数据视图看到累积超额收益率的数据，如图10.43。




图10.43　累积超额收益率的数据视图

（5）最后我们把累积超额收益率的数据保存为edata_cum.sav，以便进一步分析，如图10.44。




图10.44　累积超额收益率的数据保存

（6）打开超额收益率edata.sav数据集。选择“Data”→“Transpose”，在“数据转置”菜单中，把变量ndate选入“Name Variable”，作为转置后新变量的变量名，其他的变量选入“Variables”，如图10.45。




图10.45　数据转置的设置

（7）在数据视图，我们可以看到数据进行了转置，数据结构如图10.46。




图10.46　数据转置之后的数据结构




10.5.7　超额收益率的t检验



（1）打开超额收益率数据集edata.sav。选择“Analysis”→“Compare Means”→“One-Sample T Test”，在单样本t检验“Test Variables”的文本框中选择21个检验日变量，点击“确定”（见图10.47）。




图10.47　单样本t检验菜单设置

（2）在Output窗口，我们可以看到超额收益率的单样本t检验结果，如表10.3。在行权日前第4天和行权日后的第9天，在5%的显著性水平显著；在行权日后的第8天，在10%的显著性水平显著。行权日前第4天收益率为负，行权日的第9天收益率为正。

表10.3　超额收益率的单样本t检验结果



One-Sample Test




总体来说，行权日前后10天t值显著的不多，因此权证行权对标的股票收益率的影响并不是很显著的。

（3）在Output窗口，我们可以看到累积超额收益率的单样本t检验结果，如表10.4。在行权日行权日后的第6、7、8天，在10%的显著性水平下显著，对应的收益率为负。

表10.4　累积超额收益率的单样本t检验结果



One-Sample Test




从累积超额收益率的角度看，行权后的第二个交易周，权证行权对标的股票收益率有一定的负面影响。







实验11　投资理财行为的问卷调查与分析






11.1　实验目的



通过问卷调查的实训与统计分析的实验练习，系统掌握统计调查方案设计的基本原理，掌握调查结果的数据整理、统计分析方法的基本原理及其软件操作，能够撰写出比较专业的调查报告。




11.2　实验原理



问卷调查与分析中涉及的基本原理主要是调研方案设计、问卷设计、统计分析技术的综合应用、调查分析报告写作技术等。具体如下：

（1）问卷调研方案的设计，如抽样技术、调查方式方法、必要样本量的计算等；

（2）调查问卷的设计技术，如量表测度技术等；

（3）信度分析；

（4）数据的图表展示与透视分析技术；

（5）分类汇总、频数分析与描述统计；

（6）假设检验；

（7）列联分析；

（8）对应分析；

　　（8.1）二元对应分析

　　（8.2）多元对应分析

（9）方差分析；

　　（9.1）单因素方差分析

　　（9.2）多因素方差分析

（10）相关分析；

　　（10.1）二元变量相关分析

　　（10.2）偏相关分析

（11）多元回归分析。




11.3　实验数据与内容






11.3.1　调查问卷



投资理财行为研究的问卷调查

您好!本调查主要是为了解目前国内投资者家庭财产性投资理财行为特征，希望您能花费几分钟时间回答以下问题。谢谢!

1.受访者基本情况：

a.性别：B1□男　B2□女

b.年龄： C________

c.学历：

D1□初中　　　D2□高中　　　D3□大专（学）　　　D4□大专（学）以上

2.请问您是否投资理财?

E1□是　　　　E2□否

3.您经常在哪一家银行办理投资理财?

F1□中国银行　　　F2□中国建设银行　　　F3□中国工商银行

F4□中国农业银行　F5□招商银行　　　　　F6□其他

4.你通常投资哪些理财产品?

G1□储蓄存款　　　G2□债券　　　G3□黄金　　　G4□股票

G5□基金　　　　　G6□房产　　　G7□其他

5.H请问您每周投资金额大约为________万元?

6.依您对下列问题的认同程度，在相应的单元格内打√。




7.近期您是否会再投资?

N1□会　　N2□不会




11.3.2　实验数据



本次实验数据就是该问卷调查的原始结果，见Excel文件“实验11投资理财行为的问卷调查与分析（数据及参考答案）”；SPSS数据文件“实验11投资理财行为的调查数据”。




11.3.3　实验内容



（1）设计调查方案、调查问卷；

（2）计算必要样本量；

（3）给调查结果编码；

（4）对投资理财态度进行信度分析；

（5）对样本组成进行分类汇总分析；

（6）对编码后的调查结果进行频数分析与描述统计；

（7）利用假设检验，确定不同性别对投资金额是否有影响；

（8）利用列联分析方法，确定学历对理财产品选择的是否有影响；

（9）利用二元对应分析，分析理财地点对理财产品选择的影响；

（10）利用多元对应分析，分析五个理财态度对理财产品选择的影响；

（11）利用单因素方差分析，分析理财产品的类别选择对理财金额的影响；

（12）利用多因素方差分析，分析理财地点、理财产品、风险收益态度对理财金额的影响；

（13）利用二元变量相关分析，分析理财产品对理财金额的影响；

（14）利用偏相关分析，分析年龄、理财地点、理财产品与理财金额之间的相关关系；

（15）利用多元回归分析，研究五个理财态度对理财金额大小的作用。




11.4　统计操作与结果分析






11.4.1　必要样本量的计算



使用Excel正态分布函数功能，建立一个必要样本量计算模型，求出在估计“经常在中国建设银行办理投资理财”的总体比例为p=0.5时的必要样本大小，其中，置信水平为0.9，可容忍的误差大小e为0.06。

（1）打开Excel文件中的“样本大小”工作表，首先因正态分布是属于双尾分布，因此以NORMINV（）函数计算z值。当要求“置信水平”为0.9时，从左边单侧累积的概率应0.95。

（2）在模型的设计上，我们可以使用Excel的简单公式来计算累积概率值。首先在A2单元格中输入置信水平0.9，接着在B2单元格中设置公式，根据A2的置信水平计算累积概率值。公式设置为“=50%+A2/2”。

（3）选择C2单元格，选择菜单栏中的“公式”/“插入函数”命令，打开“插入函数”对话框，在“或选择类别”列表框中选择“统计”选项，在“选择函数”列表框中选择“NORMINV”选项，单击“确定”按钮，打开NORMINV“函数参数”对话框，进行各项参数设置：Probability（概率）为B2单元格的值，因要查出标准正态分布的z值，因此，Mean（平均数）为0，Standard-dev（标准差）为1，设置完毕后单击“确定”按钮即可得到结果。

有时候会设置显著水平α的值（即置信水平为1-α）来计算样本数的大小，如假设α=0.10时，只需在NOUMINV（）函数的Probability单元格输入1-α/2= 0.95即可。

（4）在D2单元格中输入比率p值0.5，在E2单元格中输入可容忍误差为0.06，最后，因为样本数不可以为小数，并且应该要无条件进位。因此，F2单元格中应使用ROUNDUP（）函数，以无条件进位为整数，整个函数的写法为“= ROUNDUP（C2 2*D2*（1-D2）/E2 2，0）”。即可求出所需调查样本大小约为188。如图11.1所示。




图11.1　求样本大小的公式设置及其结果

当建立好此模型后，便可以变换其他参数值，而试算得到不同的样本大小。例如，当要求计算总体比例p为0.4，置信水平为0.8，可容忍的误差大小e为0.05的样本大小，则只需要代入这些参数，便可以得到结果为158。




11.4.2　调查结果编码



1）初步检查

问卷回收后，首先要进行初步的检查，如有未按规定选择、未完成问卷或字迹模型难以辨认者，均列为无效问卷进行删除。本次调查250份中共有33份无效问卷，因此，有效问卷有217份。在专业的问卷设计中，还会加入相互矛盾的两个问题，以根据受访者回答的内容，自动检查是否有冲突或是验证受访者是否有专注回答问题，以判断是否为有效问卷。

2）利用直接替换进行编码

通过编码的过程，我们将所有问卷的答案换成数字以便于计算或列表。编码可在收集数据之前便在问卷中编好，也可在问卷回收之后才进行编码的工作。每一个答案都将对应一个代码，且彼此不可重复，以免妨碍数据的整理。编码所用的英文代号将与未来Excel数据库中的字段名称对应。本次调查采用事后编码。

编码一般采用两位或三位（超过十个问题时），前面一位用英文字母表示问题编码，后面一位或两位表示答案编码。在编码的过程中，我们从B开始编，主要是将A留给问卷编号使用。同时，若是遇到封闭性问卷，每一个编码后面的数字便是要输入到Excel数据库中代表被调查者所选择的答案编码。

在编码的过程中，最需要注意的地方就是针对态度方面的问卷编号，若是在问卷设计时，使用了如李克特尺度问卷，其中部分问题是负面描述性质的，则编码时，必须与正面描述的题目顺序相反。

此外，对于一个题目中只有两个选项的逻辑式问题，如性别、是否等题目的编码，若是考虑到未来分析时，可能会以统计量来代表程度，则使用（0，1）的编码组合，替换（1，2）的组合，以便未来分析时可以直接以此编码数字进行统计。如当是否会再投资的统计量为0.8时，表示很有可能会再购买。

3）替换编码

为了简化数据的输入，将问卷结果进行编码，但之后的分析过程，除了特定数字类型的数据外，希望能同时直接显示各选项的内容，以彰显统计分析的意义。要达到此目的，可利用菜单栏中的“编辑”/“替换”命令或利用VLOOKUP函数，将数据库的数字编码改为原始文字。以下介绍应用VLOOKUP（）函数进行替换编码。

（1）在每一个已编码的列的右边，都插入一列，用于放置对应的答案文字；

（2）在单元格区域AA1：AH9中输入编码与文字的对应方式，如图11.2所示。




图11.2　编号与相对文字的对照表

（3）在单元格C3输入“=VLOOKUP（B3，
 AA
 3：
 AH
 9，2，0）”，往下复制到单元格区域C4：C219；

在单元格F3输入“=VLOOKUP（E3，
 AA
 2：
 AH
 9，3）”，往下复制到单元格区域F4：F219；

在单元格H3输入“=VLOOKUP（G3，
 AA
 3：
 AH
 9，4，0）”，往下复制到单元格区域H4：H219；

在单元格J3输入“=VLOOKUP（I3，
 AA
 2：
 AH
 9，5）”，往下复制到单元格区域J4：J219；

在单元格L3输入“=VLOOKUP（K3，
 AA
 2：
 AH
 9，6）”，往下复制到单元格区域L4：L219；

在单元格O3输入“=VLOOKUP（N3，
 AA
 2：
 AH
 9，7）”，往下复制到单元格区域O4：O219；

在单元格Q3输入“=VLOOKUP（P3，
 AA
 2：
 AH
 9，7）”，往下复制到单元格区域Q4：Q219；

在单元格S3输入“=VLOOKUP（R3，
 AA
 2：
 AH
 9，7）”，往下复制到单元格区域S4：S219；

在单元格U3输入“=VLOOKUP（T3，
 AA
 2：
 AH
 9，7）”，往下复制到单元格区域U4：U219；

在单元格W3输入“=VLOOKUP（V3，
 AA
 2：
 AH
 9，7）”，往下复制到单元格区域W4：W219；

在单元格Y3输入“=VLOOKUP（X3，
 AA
 2：
 AH
 9，8）”，往下复制到单元格区域Y4：Y219；

经过上述操作，就可以得到编码与答案文字对应的调查结果表。




11.4.3　投资理财态度的信度分析



（1）打开SPSS数据文件“实验11投资理财行为的调查数据”，在变量窗口设定变量为数值型变量，设置数据为数值，然后在数据窗口复制粘贴编码后的问卷调查结果数据。

（2）选择“Analyze”→“Scale”→“Reliability Analysis”命令，显示图11.3所示的“Reliability Analysis”（信度分析）对话框。




图11.3　信度分析对话框设置

（3）选择评估项目。

在左侧的变量列表框中选择两个或两个以上的变量作为评估项目，单击右转向箭头按钮，将其移动到“Items”列表框中。本实验对问题6中不同态度调查变量Q8.1、Q8.2、Q8.3、Q8.4、Q8.5的信度进行评估分析。

单击“Statistics”（统计量）按纽，进入“Reliability Analysis：Statistics”（信度分析：统计量）对话框，并在“Descriptives for”（描述性分析统计量）选项组中选择“Item”（项目）选项，在“Inter-Item”（项内项目）选项组中选择“Correlations”（相关分析）选项；单击“Continue”按钮，返回到主对话框。

（4）选择信度分析模型。

在“Model”（模型）下拉列表框中选择信度分析模型，SPSS给出了5种模型：

◆　Alpha Cronbachα模型。默认选项，计算用于度量表内部的一致性的克朗巴哈（Cronbach）α系数。

◆　Split-half拆半信度系数模型。选择该项，计算度量外在信度的表间相关程度的拆半信度系数。输出结果中给出Guttman和Spearman-Brown拆半信度系数以及拆半后两部分的克朗巴哈α系数，考察两部分之间的相关性。

◆　Guttman模型法。计算最低下限的真实信度法，输出结果中产生6个信度系数，从lamda 1～lamda 6。

◆　Parallel平行模型法。计算各评估项目变异数同质时的最大概率（maximum-likelihood）信度，该模型假设所有项目具有相等的方差和相等的方差误差。

◆　Strict parallel严格平行模型法。该模型是假设评估项目具有相等均值的平行模型法。输出结果中包含有模型的拟合优度检验、各评估项目的方差估计值、项内相关系数、信度的无偏估计等统计量。

本实验分别选择Alpha Cronbachα模型、折半系数模型，分次进行信度分析。如图11.3所示。

（5）执行操作。单击“OK”按钮，执行信度分析操作。

克郎巴哈（Cronbach）阿尔法系数分析结果如表11.1、表11.2所示。

表11.1　评估项目的相关系数矩阵



Inter-Item Correlation Matrix




表11.2　信度分析的克朗巴哈（Cronbach）α系数（Reliability Statistics）




从表11.1可以看出，五个评价项目之间的相关系数都不大。

克郎巴哈（Cronbach）α系数是度量信度的一种重要方法，该例中的克朗巴哈α系数由表11.2的信度统计分析表中给出。表11.2中不但给出了克朗巴哈α系数，还给出了评估项目的标准化克朗巴哈α系数；由于信度系数为0.594，略小于0.7，因此总体上该调查的内在信度是可以接受，但是不很理想的。

折半系数分析结果如表11.3、表11.4所示，表11.3是拆半信度分析的基本描述统计量列表。

表11.3　拆半信度分析的基本描述统计量



Scale Statistics




a.The items are：Q8.1，Q8.2，Q8.3.



b.The items are：Q8.4，Q8.5.

表11.4　拆半信度分析的信度系数




a.The items are：Q8.1，Q8.2，Q8.3.



b.The items are：Q8.4，Q8.5.

Reliability Statistics

表11.3中给出拆半后的统计量描述，由于有5个评估项目，拆分时按照原顺序，前3个作为一组项目，后面的2个作为另一组项目。第一组项目的均值为9.50，方差为6.372，标准差为2.524；第二组项目的均值为6.1，方差为3.616，标准差为1.901。

表11.4所示为拆半信度分析的信度系数。Correlation Between Forms是两部分量表总分的相关系数，为0.440，相关程度不算高。而Spearman-Brown Equal Length系数为0.611是利用两部分的标准化α系数计算得到，是中等相关程度。Guttman拆半系数是利用两组项目的Cronbach α系数计算得到的，为0.595。

注意：项目不同的拆半会产生不同的信度系数估计值。在拆半过程中，如果使具有高相关性的项目分在一组，这时拆半系数将接近于其最小值。当高相关性的项目成对拆分时，拆半系数将达到其最大值。




11.4.4　不同学历投资者理财行为的分类汇总分析



（1）将调查结果编码数据文件读入SPSS的数据编辑窗口。

（2）打开主对话框。在数据编辑窗口，选择“Data”→“Aggregate”命令，打开“Aggregate Data”（数据汇总）对话框。

（3）选择分类变量。在对话框左侧的变量列表框中选择一个或多个变量作为分类变量，单击上方的右转向箭头按钮，将变量移动到“Break Variable（s）”（分类变量）列表框中。在本例中，选择变量“学历”为分类变量。

（4）选择汇总变量。在对话框的左侧变量列表框中选择一个或多个变量作为汇总变量，单击下侧的右向箭头按钮，将该变量移动到“Aggregate Variable（s）”（汇总变量）中，移动到“Bread Variable（s）”列表框内的汇总变量自动改名。在本例中，汇总变量为“理财产品”、“是否理财”、“理财地点”、“理财金额”和“风险收益态度”，在“Aggregate Variable（s）”中分别显示为“理财产品_mean=MEAN[理财产品]”、“是否理财_mean=MEAN[是否理财]”等。如图11.4所示。




图11.4　分类汇总对话框

（5）汇总函数的选择和计算。在“Break Variable（s）”列表框中选择相应的变量后，单击“Function”按钮，打开“Aggregate Data：Aggregate Function”（数据汇总：汇总函数）对话框，指定对汇总变量选择计算的统计量，默认选择“Mean”（均值），即计算变量的平均值。单击“Continue”按钮，返回到“Aggregate Data”对话框。

（6）添加变量标签。在“Aggregate Variable（s）”中选择相应汇总变量后，单击“Name Label”按钮，出现如图11.5所示的“Aggregate Data：Variable Name and Label”（数据汇总：变量名和变量标签）对话框，重新命名汇总数据文件中的相应变量名或添加变量标签，其中包括如下两个文本框：




图11.5　“Aggregate Data：Variable Name and Label”对话框

Name：定义汇总变量的变量名。

Label：定义汇总变量的变量标签。

重命名后，单击“Continue”按钮，返回到“Aggregate Data”对话框。

本例使用默认变量名称。

（7）选择汇总结果保存方式为“Create a new dataset containing only the Aggregated Variables”。

（8）执行数据汇总操作。

以上设置完毕，操作无误后，单击“OK”按钮，执行数据汇总操作。这时，会在新数据编辑窗口中添加汇总变量，图11.6显示例子的部分汇总结果。




图11.6　数据汇总操作后的数据编辑窗口

由图11.6的汇总结果可以看出，大专（学）及以下学历的受调查者多选用债券理财，而大专（学）以上的受调查者多选用黄金理财，而理财地点选择差异较大，依次主要选择中国银行、中国建设银行；高中、大专（学）多数不同意“投资理财风险太大，收益不一定大”，初中、大专（学）以上的受调查者多数基本认同“投资理财风险太大，收益不一定大”；初中、高中、大专（学）、大专（学）以上的受调查者理财金额平均值分别为1176.6、950.82、935.06、1125。




11.4.5　调查结果的频数分析与描述统计



（1）选择“File”→“Open”→“Data”命令，打开SPSS文件“实验11投资理财行为的调查数据”。

（2）打开数据分析对话框。选择“Analyze”→“Descriptive Statistics”→“Frequencies...”命令，弹出“Frequencies”（频数分析）对话框。

（3）选择进行频数分析的变量。在左侧变量框中选择变量，单击右转向按钮，逐个把变量选入右侧的变量框，如图11.7所示。




图11.7　　频数分析对话框设置

（4）选择所需进行计算的基本统计量。

单击“Statistics...”按钮，弹出“Frequencies：Statistics”（频数分析：统计量）对话框，这个对话框中有很多频数统计量可以选择，分为“Percentile Values”（百分位数）、“Central Tendency”（集中趋势）、“Dispersion”（离中趋势）、“Distribution”（分布特征）四个部分，每一个部分都有若干统计量，在实际工作中我们可以根据需要选用。在本次实验中，为了尽可能完整地展示SPSS的分析功能，我们把所有的统计量都选上，如图11.8所示。




图11.8　频数分析统计量的设置

（5）选择图形类型。单击“Continue”按钮回到“Frequencies”（频数分析）主对话框，单击“Charts...”按钮，弹出“Frequencies：Charts”（频数分析：图形）对话框，选择“Histograms”（直方图），并把“With normal curve”（带正态分布曲线）选项选上，如图11.9所示。




图11.9　频数分析图表的设置

（6）选择输出格式。单击“Continue”按钮回到“Frequencies”（频数分析）主对话框，再单击“Format...”按钮，弹出“Frequencies：Format”（频数分析：格式）对话框。将“Order by”（排序方式）选为“Ascending values”（升序排列），“Multiple Variables”（多变量）选为“Compare Variables”（比较变量），这样，输出结果就会在一个表中显示所有变量的统计结果。最后，把“Suppress tables with more than n categories”（压缩超过n类的频数表）复选框选上，这样当频数表的分类超过n时，则不显示频数表此时可以设定“Maximum number of categories”（最大分类数），系统默认值为10。

（7）最后单击“Continue”按钮，回到“Frequencies”（频数分析）对话框，单击“OK”按钮，执行计算分析，就会得到结果。部分主要结果如表11.5至表11.8、图11.10至图11.12所示。

表11.5　Statisties




表11.6　理财产品




表11.7　理财地点




表11.8　理财金额




（续表）







图11.10　理财产品的频数分布图




图11.11　理财地点的频数分布图




图11.12　理财金额的频数分布图




11.4.6　性别对投资金额影响的假设检验



打开SPSS数据文件“实验11投资理财行为的调查数据”。

在“Analyze”菜单的“Compare Means”子菜单中选择“Independent-Samples T Test”命令。在弹出如图11.13所示的“Independent-Samples T Test”对话框中，从左侧的变量列表中选择“理财金额”变量，并添加到“Test Variable（s）”框中；选择“性别”变量，添加到“Grouping Variable”框中。




图11.13　“Independent-Samples T Test”对话框

单击“Define Groups”按钮，弹出“Define Groups”对话框，如图11.14所示。在该对话框中指定标识变量的区分方法。选择“Use specified values”选项，表示根据标识变量的取值进行区分。在“Group 1”中输入1，在“Group 2”中输入2。如图11.14所示。




图11.14　“Define Groups”对话框

如果选择“Cut point”选项，则表示要选择一个分割点，高于该值的个案组成一个样本，低于该值的个案组成另外一个样本，这适合于标识变量为连续变量的情况。

单击“Continue”按钮，返回“Independent-Samples T Test”对话框。再单击“OK”按钮，SPSS即完成所要求的计算。结果如表11.9、表11.10所示。

表11.9　Group Statistics




表11.10　Independent Samples Test




在SPSS中，将会根据计算的t值和T分布表给出相应的相伴概率值。这里的两个相伴概率值都小于显著性水平α=0.05，则拒绝H

0


 ，认为两总体均值之间存在显著差异。




11.4.7　学历对理财产品选择影响的列联分析



（1）打开SPSS数据文件，从SPSS的“Analyze”→“Descriptive statistics”→“Crosstabs”，进入列联分析“Crosstabs”对话框；

（2）选择“学历”变量，单击右转向按钮“
 ”，使之进入“Row（s）”框，选择“理财产品”变量单击右转向按钮，使之进入“Column（s）”框，如图11.15所示。




图11.15　列联分析“Crosstabs”对话框设置

（3）单击“Statistics”按钮，弹出“Crosstabs：Statistics”对话框，选中相关选项，如图11.16所示。




图11.16　“Crosstabs：Statistics”对话框

（4）单击“Cells”按钮，弹出“Crosstabs：Cells Display”对话框，用于定义列联表单元格中需要计算的指标，本例选中全部计数、百分比栏下的所有复选框，如图11.17所示。




图11.17　“Crosstabs：Cells Display”对话框设置

单击“Continue”按钮，返回“Crosstabs”对话框。

（5）单击“OK”按钮，提交运行，即得列联分析结果，如表11.11至表11.14、图11.18所示。

表11.11　Case Processing Summary




表11.12　Chi-Square Tests




a.13 cells（54.2%）have expected count less than 5.The minimum expected count is.78.

表11.13　Directional Measures




a.Not assuming the null hypothesis.



b.Using the asymptotic standard error assuming the null hypothesis.



c.Based on chi-square approximation.



d.Likelihood ratio chi-square probability.

表11.14　Symmetric Measures




a.Not assuming the null hypothesis.



b.Using the asymptotic standard error assuming the null hypothesis.



c.Based on normal approximation.




图11.18　不同学历的投资者理财产品的频数统计




11.4.8　理财地点对理财产品选择影响的对应分析



（1）打开SPSS数据文件。

（2）对数据文件进行处理。

如果数据文件中有频数变量，应该首先做加权处理，将该变量指定为权数。选择“Data”→“Weight Cases”命令，在“Weight Cases”（个案加权）对话框中选中“Weight cases by”（加权根据）单选按钮，将频数变量移动至“Frequency Variable”（频数变量）列表框，单击“OK”按钮，执行加权变量设定操作。

（3）打开对应分析主对话框。

选择“Analyze”→“Data Reduction”→“Correspondence Analysis”命令，打开“Correspondence Analysis”（对应分析）主对话框。

（4）指定行（列）变量及其范围。

在主对话框中，在左侧的变量列表框中选择变量，单击上方的右转向箭头按钮，将其移动至“Row”（行）文本框内，则该变量作为对应分析的行变量；然后单击该窗口的“Define Range”按钮，显示图11.19所示的“Correspon-dence Analysis：Define Row Range”（对应分析：定义行范围）子对话框。在该对话框中指定选取行变量的范围，分别在“Minimum”（最小值）文本框和“Maximum”（最大值）文本框中输入该行变量中参与对应分析的最小变量值和最大变量值，单击“Update”按钮，确认操作。如图11.19所示。




图11.19　“Correspondence Analysis ：Define Row Range”子对话框

对于列变量的选择和指定范围的方法与行变量的基本相同。本例中行变量指定为“理财地点”，变量值范围最小值选择1，最大值选择6；列变量指定为“理财产品”，变量值最小为1，最大为7。设定好后单击“Continue”，返回对应分析的主对话框。

（5）执行对应分析过程。

单击“OK”按钮，执行对应分析操作，得到理财地点对理财产品选择影响的对应分析结果，如表11.15至表11.18、图11.20所示。

表11.15　Correspondence Table




表11.16　Overview Row Points

a







a.Symmetrical normalization

表11.17　Overview Column Points

a







a.Symmetrical normalization

表11.18　Summary




a.30 degrees of freedom




图11.20　对应分析的量化散点图

表11.15所示是理财地点和理财产品的交叉列联表。行变量表示理财地点的分类变量，列变量表示理财产品的分类变量，表中单元格的数据为相应人数，Active Margin为相应行或列的汇总数据，代表某一类理财地点的人数（行）或者某一种理财产品类型的人数（列）。

表11.16是对应分析过程中理财地点和理财产品的行变量分类降维表。表中的第2列表示行分类的各类别的频数百分比；第3列和第4列分别表示行变量各分类对于第1和第2个因子上的因子载荷，同时它们也将成为散点图中相应类别的坐标；第5列为各类别的特征值；第6、第7列是行变量各分类对第1和第2个因子的差异影响程度。最后3列是两因子对行变量各分类差异的解释程度。

表11.17是列变量分类降维表。含义与行变量分类降维表类似。

表11.18所示是对应分析的主要分析过程和关键结果的汇总表。

表中第1列是对应分析中分类数的序号，共有4行，表示对应分析的解的维度为4，也就是提取特征值的个数；由对应分析理论可知，提取特征根的个数为行变量个数和列变量个数中的最小值减2。这里，由于理财地点变量有6个，理财产品分类变量有7个，因此提取特征根的个数应为min{6，7}-2=4。

第2列是奇异值（Singular Value），奇异值可以解释为行和列得分的相关系数，类似于相关分析中的Pearson相关系数，对奇异值平方则得到第3列，即惯量（Inertia），也就是特征根。

从第3列可以看出，第1个特征根的值最大，第2和第3个特征根依次减小，根据因子分析中特征根的含义知道，特征根越大表示该因子对各类差异的解释越强；显然，这里的特征根的重要性依次递减，该列的最后一行0.090为各特征值之和。

第4列是对交叉列联表做卡方检验得到的观测值，为15.035。

第5列是利用检验观测值计算得到的概率P值，为0.990；假设显著性水平为0.05，由于概率P值大于显著性水平，所以接受零假设，认为行变量和列变量具有显著的相关关系。

第6列是每个特征值的方差贡献率，方差贡献率是该特征值和特征值总和的比值。

第7列是每个特征值的累积方差贡献率，3个特征值的累积方差贡献率为1。由于2个特征根的累积方差贡献率已经解释了各类别的差异的92.4%，因此最终提取2个因子是可行的，信息丢失较少。

图11.20所示是理财地点和理财产品的对应分析散点图。借助对应分析的散点图，可以从纵坐标轴、横坐标轴中直观地看出理财地点和理财产品的倾向性。散点图中距离越接近的类别表示其关系越密切。一般认为落在由原点出发接近相同方位的及图形相同区域的同一变量的不同类别具有相似的性质，并且落在由原点出发接近相同方位及图形相同区域的不同变量的类别间可能有联系。




11.4.9　五个理财态度对理财产品选择影响的多元对应分析



（1）建立或读入SPSS数据文件。

（2）选择“Analyze”→“Data Reduction”→“Optimal Scaling”命令，在“Optimal Scaling”（最优尺度）对话框中单击“Define”按钮，进入“Multiple Correspondence Analysis”（多元对应分析）主对话框，选择所有的变量，单击右向箭头，将其移动至“Analysis Variables”（分析变量）列表框内。

（3）其他选择默认项。单击“OK”按钮，执行多元对应分析操作，得到五个理财态度对理财产品选择影响的多元对应分析结果，如表11.19至表11.21、图11.21所示。

表11.19　多元对应分析的模型概况表（Model Summary）




a.Mean Cronbach’s Alpha is based on the mean Eigenvalue.

表11.20　转换变量的相关性（Correlations Transformed Variables）




a.Missing values were imputed with the mode of the quantified variable.

表11.21　多元对应分析的区分测度（Discrimination Measures）







图11.21　多元对应分析的区分测度图形

表11.19是多元对应分析的模型概况表。表中列出了两维度的特征值和惯量，其中第3列为各维度的特征值、总特征值和平均特征值；第4列为维度的惯量，显示了两维度的惯量以及它们的均值和总惯量。从表中可以看出，超过67.2%的方差被两维数解释，其中第1个维度解释了总方差的39.9%，第2个维度解释了总方差的27.2%。解释效果可以接受。

（4）转换变量的相关性。表11.20、表11.21分别为两个维度转换变量的相关系数矩阵。从表中的相关系数矩阵可以看出，两两变量线性关系的远近程度，为进一步分析给出一个直观的表示。

（5）区分测度。表11.21是各变量在两维度上的区分测度，图11.21是多元对应分析的区分测度图。这是以表11.21中两个维度上的区分测度值为坐标在二维平面上绘制得到的散点图形，是表11.20的图形表达形式。区分测度的大小在0～1之间，数值越大表明区分程度越高。




11.4.10　理财产品类别选择对理财金额影响的方差分析



（1）打开SPSS数据文件，在“Analyze”菜单的“Compare Means”子菜单中选择“One-Way ANOVA”命令。

（2）在弹出图11.22所示的“One-Way ANOVA”对话框中，从左侧的变量列表中选择“理财金额”变量，使之添加到“Dependent List”框中，选择“理财产品”变量，使之添加到“Factor”框中。




图11.22　“One-Way ANOVA”对话框设置

（3）单击“Options”按钮，弹出“One-Way ANOVA：Options”对话框，如图11.23所示。




图11.23　“One-Way ANOVA： Options”对话框

方差分析的前提是各个水平下（以这里为组别变量不同取值）的总体服从方差相等的正态分布。其中正态分布的要求并不是很严格，但对于方差相等的要求是比较严格的。因此必须对方差分析的前提进行检验。

在这里方差相等检验方法是Homogen-eity of variance test方法。该方法也是统计推断的方法，其零假设是各水平下总体方差没有显著差异。SPSS具体检验方法与独立样本T检验中方差是否相等的检验方法完全相同。

选中图11.23所示中的“Homogeneity of variance test”选项，在SPSS的运行结果中就会出现关于方差是否相等的检验结果和相伴概率值。如果相伴概率值小于或等于显著性水平，则拒绝零假设，认为各水平下总体方差不等；相反，如果相伴概率值大于显著性水平，则接受零假设，认为各水平下总体方差相等。

在本例中，选中其中的“Homogeneity of variance test”选项和“Means plot”选项，单击“Continue”按钮，返回上一对话框。

（4）通过上面的步骤，只能判断控制变量的不同水平是否对观察变量产生了显著影响。如果想进一步了解究竟是哪个组（或哪些组）和其他组有显著的均值差别，就需要在多个样本均数间两两比较。

单击图11.22所示对话框中的“Post Hoc”按钮，弹出“One-Way ANOVA：Post Hoc Multiple Comparisons”对话框，如图11.24所示。在其中可以选择一种或几种比较分析的方法。




图11.24　“One-Way ANOVA：Post Hoc Multiple Comparisons”对话框

其中最常用的比较方法有以下几种：

LSD（Least-Significant Difference）：最小显著差法。α可指定0～1之间任何显著性水平，默认值为0.05。

Bonferroni：修正差别检验法。α可指定0～1之间任何显著性水平，默认值为0.05。

Duncan：多范围检验。只能指定α为0.05，0.01或0.1，默认值为0.05。

S-N-K（Student-Newman-Keuls）：Student-Newman-Keuls检验，即q检验。α只能为0.05。

Tukey：显著性检验，α只能为0.05。

Tukey’s-b：Tukey另一种显著性检验。α只能为0.05。

Scheffe：差别检验法。α可指定0～1之间任何显著性水平，默认值为0.05。

本例中选择“LSD”和“S-N-K”显著性检验法。单击“Continue”按钮，返回“One-Way ANOVA”对话框。

（5）将组间平方和分解为线性、二次、三次或更高次的多项式。这样在方差分析结果中，就不仅可以输出组间平方和，还可以显示组间平方和的各个分解结果以及F统计量和相伴概率。这也就是单因素方差分析的多项式检验。

单击图11.22所示对话框中的“Contrasts”按钮，打开“One-Way ANOVA：Contrasts”对话框，如图11.25所示。




图11.25　“One-Way ANOVA： Contrasts”对话框

选中“Polynomial”选项，在其后的“Degree”下拉框中指定“Linear”，作线性分解。也可以进行二次、三次等分解。

这里指定对组间平方和作线性分解，实质是对结果与控制变量进行一次线性回归分析，计算回归平方和，并对回归方程进行检验，给出F统计量和相伴概率。如果相伴概率大于显著性水平，也说明控制变量的各个观察水平无法反映结果的线性变化，也就是认为控制变量的不同水平对结果的线性影响不显著；相反，则认为结果随着控制变量不同水平的变化产生了线性变化。

（6）单击“OK”，进行单因素方差分析，得到理财产品类别选择对理财金额影响的方差分析，如表11.22至表11.27、图11.26所示。

表11.22　理财金额Descriptives




（续表）




a.Warning：Between-component variance is negative.It was replaced by 0.0 in computing this random effects measure.

表11.23　Test of Homogeneity of Variances




表11.24　理财金额ANOVA




表11.25　理财金额Robust Tests of Equality of Means




a.Asymptotically F distributed.

表11.26　Multiple Comparisons（Dependent Variable：理财金额）




表11.27　理财金额




Means for groups in homogeneous subsets are displayed.



a.Uses Harmonic Mean Sample Size=12.670.




图11.26　不同理财产品对应的理财金额平均值




11.4.11　理财金额的多因素方差分析



（1）打开SPSS数据文件，在“Analyze”菜单的“General Linear Model”子菜单中选择“Univariate”命令。

（2）在弹出图11.27所示的“Univariate”对话框中，从左侧的变量列表中选择“理财金额”变量，使之添加到“Dependent Variable”框中，选择“理财地点”、“理财产品”、“风险收益态度”变量，使之添加到“Fixed Factor”框中，如图11.27所示。




图11.27　“Univariate”对话框

（3）单击“Options”按钮，弹出“Univariate：Options”对话框，选中“Display”框中的“Homogeneity tests”选项。如图11.28所示。




图11.28　“Univariate：Options”对话框

单击“Continue”按钮，返回上一对话框。

（4）为了判断两个控制变量的不同水平是否对观察变量产生了显著影响，单击对话框中的“Post Hoc”按钮，弹出“Univariate：Post Hoc Multiple Comparisons for Observed Means”对话框，如图11.29所示。




图11.29　“Univariate： Post Hoc Multiple Comparisons for Observed Means”对话框

在其中可以选择需要进行比较分析的控制变量。本例中，选择“理财产品”变量，并将其添加到“Post Hoc Tests for”框中。然后选择比较方法。

本例中选择“LSD”和“S-N-K”显著性检验法。单击“Continue”按钮，返回“Univariate”对话框。

（5）单击图11.27所示对话框中的“Model”按钮，弹出“Univariate：Model”对话框，选中“Full factorial”项，单击“Continue”按钮，返回“Univariate”对话框。

（6）单击对话框中的“Plots”按钮，弹出“Univariate：Profile plots”对话框，如图11.30所示。




图11.30　“Univariate：Profile Plots”对话框

通过选择“Univariate：Profile plots”对话框中的内容，可以设置以图形的方式展现控制变量之间是否有交互影响。如果各个控制变量之间没有交互作用，那么各个水平对应的图形应近于平行，否则相交。

本例中选择显示两个变量交互作用，然后返回“Univariate”对话框。

（7）单击对话框中的“Contrasts”按钮，弹出“Univariate：Contrasts”对话框，如图11.31所示。




图11.31　“Univariate：Contrasts”对话框

对两个变量都选择“Simple”方式，并以最后一个水平的观察变量均值为标准。选择好“Contrast”项中的方式后，需要单击“Change”按钮进行确认。

（8）在“Contrasts”对话框中选择完毕后，单击“Continue”按钮，返回“Univariate”对话框，完成设置。单击“OK”按钮，SPSS完成计算，得到理财地点、理财产品、风险收益态度对理财金额影响的多因素方差分析结果，如表11.28至表11.33、图11.32、图11.33所示。

表11.28　Between-Subjects Factors




表11.29　Levene’s Test of Equality of Error Variances

a


 （Dependent Variable：理财金额）




Tests the null hypothesis that the error variance of the dependent variable is equal across groups.



a.Design：Intercept+理财地点+风险收益态度+理财产品+理财地点×风险收益态度+理财地点×理财产品+风险收益态度×理财产品+理财地点×风险收益态度×理财产品

表11.30　Tests of Between-Subjects Effects（Dependent Variable：理财金额）




a.R Squared=.400（Adjusted R Squared=.051）

表11.31　Contrast Results（K Matrix）




（续表）




a.Reference category=5

表11.32　Test Results（Dependent Variable：理财金额）




表11.33　Multiple Comparisons（Dependent Variable：理财金额）




（续表）




Based on observed means.



The error term is Mean Square（Error）=206360.781.




图11.32　不同风险态度与理财地点组合的理财金额平均值




图11.33　不同风险收益态度与理财产品组合的理财金额平均值




11.4.12　理财产品对理财金额影响的二元变量相关分析



（1）在“Analyze”菜单的“Correlate”子菜单中选择“Bivariate”命令。

（2）在弹出的“Bivariate Correlations”对话框中，从对话框左侧的变量列表中分别选择“理财产品”和“理财金额”变量，单击右转向按钮使这两个变量进入“Variables”框。

再在“Correlation Coefficients”框中选择相关系数的类型，共有3种：Pearson简单相关系数、Kendall’s tau-b和Spearman等级相关系数，本例选用3项。

在“Test of Significance”框中可选择相关系数的单侧（One-tailed）或双侧（Two-tailed）检验，本例选择双侧检验。

双侧检验可以检验两个变量之间的相关取向，即可以从结果得知两个变量是正相关还是负相关。如果在运算前已经知道两个相关取向，则可以直接选用单侧检验。

本例中还选中了“Flag significations correlations”选项，如图11.34所示。它表示相关分析结果中将不显示统计检验的相伴概率，而以星号（*）表示。一个星号表示当用户指定的显著性水平为0.05时，统计检验的相伴概率值小于或等于0.05，即总体无显著线性相关的可能性小于等于0.05；两个星号表示当用户指定的显著性水平面为0.01时，统计检验的相伴概率值小于等于0.01，即总体无显著线性相关的可能性小于等于0.01。显然，两个星号比一个星号的检验更精确。




图11.34　“Bivariate Correlations”对话框

（3）单击“Options”按钮，弹出“Bivariate Correlations：Options”对话框，选择“Means and standard deviations”和“Exclude cases pairwise”项，单击“Continue”按钮，返回“Bivariat Correlations”对话框，单击“OK”按钮，即可得到SPSS相关分析的结果。如表11.34、表11.35、表11.36所示。

表11.34　Descriptive Statistics




表11.35　Correlations




表11.36　Correlations







11.4.13　年龄、理财地点、理财产品与理财金额之间的偏相关分析



（1）打开SPSS数据文件，在“Analyze”菜单的“Correlate”子菜单中选择“Partial”命令。

（2）在弹出如图11.35所示的“Partial Correlations”对话框中，从左侧的变量列表中分别选“年龄”、“理财地点”、“理财产品”与“理财金额”变量，单击右转向按钮，使这四个变量添加到“Variables”框中，再选择五个态度变量，单击右转向按钮使这个变量添加到“Controlling For”框中，表示现在所求的是剔除五个态度变量影响后“年龄”、“理财地点”、“理财产品”与“理财金额”变量之间偏相关系数。




图11.35　“Partial Correlations”对话框

在“Test of Significance”框中选择SPSS默认的双侧（Two-tailed）检验。

本例中还选中了“Display actual significance level”选项，它表示相关分析结果中将显示统计检验中具体的相伴概率。否则以星号（*）表示，星号的意义与计算简单相关系数中的相同。

（3）单击“Options”按钮，弹出“Partial Correlations：Options”对话框。

“Statistics”框中的“Means and standard deviations”项，表示在输出相关系数的同时计算输出各变量的平均值和标准差；“Zero-order correlations”项表示在输出偏相关系数的同时还输出变量间的简单相关系数。

“Missing Values”框中可对缺失值进行处理，“Exclude cases pairwise”表示如果正参与计算的两变量中有缺失值，则暂时剔除那些在这两个变量上取缺失值的个案：“Exclude cases listwise”剔除所有具有缺失值的个案后再计算。

本例中选择“Zero-order correlations”项、“Exclude cases listwise”选项。

（4）单击“Continue”按钮，返回“Partial Correlations”对话框，单击“OK”按钮，即可得到SPSS相关分析的结果，如表11.37、表11.38所示。

表11.37　Descriptive Statistics




表11.38　Correlations







11.4.14　理财金额对理财态度的多元回归分析



（1）打开SPSS数据文件。

（2）从菜单上依次点选“Analyze”→“Regression”→“Linear”命令，打开“Linear Regression”对话框。

（3）在“Linear Regression”对话框中，如图11.36所示，将“理财金额”变量右移到因变量（Dependent）框中，将自变量“是否态度”、“功效态度”、“主体态度”、“知识态度”、“风险收益态度”移入“Independent（s）”框中。并在Method框内选择Enter隐含设置，即自变量一次全部进入的方法。




图11.36　“Linear Regression”对话框设置

（4）单击“Linear Regression”对话框下方的“Statistics”按钮，打开“Statistics”对话框，如图11.37所示。在“Statistics”对话框内，勾选“Model fit”项，则在“Linear Regression”过程完成后会输出“Model Summary”表；勾选回归系数“Regression Coefficients”栏下的估计“Estimates”、置信区间“Confidence intervals”，以及部分相关与偏相关“Part and partial correlations”、共线性诊断“Collinearity diagnostics”，则会输出Coefficients表和Collinearity Diagnostics表；最后还可勾选残差“Residuals”的奇异值诊断“Casewise diagnostics”项，选中“All cases”，会输出所有样本点的情况。然后，点击“Continue”按钮，回到“Linear Regression”主对话框。




图11.37　Statistics对话框

（5）单击“Linear Regression”对话框下方“Plots”按钮，打开“Plots”对话框。在“Plots”对话框左下角的标准化残差图栏中（“Standardized Residual Plots”），勾选“Normal probability plot”，以画出P-P图。当然，还可以将左侧框中的变量分别移入右侧Y框与X框中，以绘制散点图。本例不绘制散点图。然后，单击“Continue”按钮，回到“Linear Regression”主对话框。

（6）单击“Linear Regression”对话框下方的“Save”按钮，打开“Save”对话框。在“Save”对话框内被选中的项目，都将在数据编辑窗口显示。这里选择未标准化的点预测值“Unstandardized”及其置信度为95%的置信区间“Individual”；还可选择残差“Residuals”栏下的“Unstandardized”，即未标准化的残差值。然后，单击“Continue”按钮，回到“Linear Regression”主对话框。

（7）单击“Linear Regression”对话框下方的“Options”按钮，打开“Options”对话框。该对话框只有在筛选自变量方法“Method”框选择逐步回归法“Stepwise”项目后才需打开。临界值可以使用F的概率值（“Use probability of F”），也可以选用F值（“Use F value”）。但要注意，若使用F的概率值，则进入（“Entry”）的概率值要低于剔除（“Removal”）的概率值；若使用F值，则进入（“Entry”）的值要高于剔除（“Removal”）的值。然后，单击“Continue”按钮，回到“Linear Regression”主对话框。

（8）在“Linear Regression”主对话框中，单击“OK”按钮完成操作，主要结果如表11.39至表11.45、图11.38至图11.39所示。

表11.39　Correlations




表11.40　Model Summary

b







a.Predictors：（Constant），风险收益态度，主体态度，功效态度，知识态度，是否态度



b.Dependent Variable：理财金额

表11.42　Coefficients

a







a.Dependent Variable：理财金额

表11.41　ANOVA

b







a.Predictors：（Constant），风险收益态度，主体态度，功效态度，知识态度，是否态度



b.Dependent Variable：理财金额

表11.43　Coefficient Correlations

a







a.Dependent Variable：理财金额

表11.44　Collinearity Diagnostics

a







a.Dependent Variable：理财金额

表11.45　Residuals Statistics

a







a.Dependent Variable：理财金额




图11.38　标准化回归残差的直方图




图11.39　标准化回归残差的正态分布P-P图




11.5　调研报告写作



调研报告的核心写作结构建议如下，内容略。

（1）标题封面。

（2）报告目录。

　　（2.1）统计表目录

　　（2.2）统计图目录

　　（2.3）附件目录

　　　　（2.3.1）答案编码表

　　　　（2.3.2）原始调查结果

（3）调查报告摘要。

简要说明调查分析的目的、对象、内容、分析方法、结果。

（4）正文。

　　（4.1）调研的背景与意义

　　（4.2）调查方案的介绍

　　（4.3）调查结果的统计分析与解释

　　（4.4）调查结论与启示或建议

（5）附件。

　　（5.1）调查问卷

　　（5.2）答案编码表

　　（5.3）原始调查结果
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Model Sum of Squares df Mean Square F Sig.
Regression 6.055E7 5 1.211E7 59.272 | .000*
Residual 4.311E7 211 204 322.475
Total 1.037E8 216






OEBPS/Image00203.jpg
304
q
5 201 AT
g —
=
z o
2 L
= —
10 pa
oL e q\k
—3 -2 -1 0 1 2 3

Regression Standardized Residual

Mean=2.81E—16
Std. Dev. =0.988
N=217





OEBPS/Image00324.jpg
Bar Charts

Simple

‘ ' Clustered

i

Stacked

E

rData in Chart Are—— e

| () Summaries for groups of cases

) Summaries of separste variables

(#) Values of individual cases

| Define ” Cancel ” Help






OEBPS/Image00206.jpg
l sdate stkret idxret
1 01/04/2000] . .
! 01/05/2000 0.00 0.00
3 01/06/2000 0.02 0.04
4 01/07/2000 0.03 0.04
5 01/10/2000 0.0z 0.0z
] 01/11/2000 -0.03 -0.04
v 01/12/2000 -0.05 -0.03





OEBPS/Image00445.jpg
95% Confidence

Me:
(1) Hr () . ean . Interval

- - Difference Std. Error Sig.
T T (1-)) Lower Upper
Bound Bound
LSD 1 2 26.22 105.454 .804 | -182.87 235.32
3 -54.52 87.551 .535 -228.12 119.08
4 247.22 169. 296 . 147 -88.46 582.91
5 -27.78 132.688 .835 -290.87 235.32






OEBPS/Image00205.jpg
PRAE & LV 42 400

Levene Statistic

df1

df2

Sig.

1.063

161

.383






OEBPS/Image00326.jpg
EH K-Means Cluster Analysis (&)

“ariahles:
W nyear | f z20ls_mean
f s21_mean
f 25_mean
. & =29_mean
f =34_mean
& S34mr_mean

Lakel Cases by:

- |_name
Mumber of Clusters: !'MEthDd

() tterate and classify () Classify only

rCIusﬂar Centers





OEBPS/Image00446.jpg
8 One—Sample E-5: Options
rStatistics
Descriptive

Missing Values

() Exclude cazes test-by-test

l::':r Exclude cases listwise

Continue “ Cancel H Help






OEBPS/Image00317.jpg
NO. LG TCL KirT €4 &KZ WFEH WK O WE ORE =2 mT RE
5 51 0.0 0.2 0.1 43 93 0.2 0.0 00 22 4.6  35.8
6 178.7 0.1 0.9 0.1 2113.7 158 0.0 0.0 0.0 1277 141 760.5
X 192.4 2.7 2.4 0.2 2130.2 175.6 7.4 1.5 1.1 1287.3 157.4 817.1
P 0.0 0.7 0.8 1.0 0.0 0.0 0.2 0.9 1.0 0.0 0.0 0.0






OEBPS/Image00439.jpg
LNOV 2010
LJUN 2010
LJAN 2010
LAUG 2009
LMAR 2009
LOCT 2008
EMAY 2008
LDEC 2007
LJUL 2007
LFEB 2007
LSEP 2006

L APR 2006
LNOV 2005 »
FIUN 2005 2
LJAN 2005
LAUG 2004
LMAR 2004
LOCT 2003
LMAY 2003
LDEC 2002
LJUL 2002
LFEB 2002
LSEP 2001
LAPR 2001
FNOV 2000
LJUN 2000
LJAN 2000

30 000 000 A
25000 000 ~
20 000 000 ~
15 000 000
10 000 000 A

5000 000 -

I NI TN T AOW
‘NOSVAS Wwoly Aouow Joj SoLIds pajsnipe [euosesg





OEBPS/Image00440.jpg
@ K-Means Cluster Analysis (3]

“ariahles:
f nyear @” =20ls_mean
Fa name & s21_mean
& s25_mean
@ =28_mean
& =34 _mean
f =34mr_mean

abel Cases by:

.

Mumber of Clusters:

Classify only





OEBPS/Image00198.jpg
IS i

Model e | EEEE | RGEE | MIRSE | BERSE
ﬁ]].u:»E

1 Correlations KU &S 1.000 -. 046 -.053 -.013 -.158

TR -. 046 1..000 -.097 —.147 -.122

Ui -.053 -.097 1.000 -.245 -.228

RS -.013 - 147 -.245 1.000 -.228

RESE -. 158 - 122 -.228 -.228 1.000

Covariances KUK Ui 25 A5 652.014 | -30.571 | —-41.946 | -8.441 | -117.022

RS -30.571| 683.024 | -77.590 |-100.073 -92.767

YIS —41.946 | -77.590 | 944.449 |-196.426 | -203.497

RS -8.441(-100.073 | -196.426 | 679.943 | -172.995

RESE -117.022| -92.767 | -203.497 | -172.995 845.990






OEBPS/Image00319.jpg
| ’year2DEI4
1

Mame Type Width | Decimals
1 class String g 0
2 year2001 Murneric 8 2
& year2002 Nurneric g 2
4 year2003 MNumeric g 2
& Numeric 8 2





OEBPS/Image00437.jpg
| R
il
AR D:

i pEE

(IS THE—T L

Fi I
o HidiGetet @)
O HIT{ERAE )

HIEHW
YIRS ©
v TEAERE W
V% K AE®):
W% KMEW:

$E$3 . $E$102

© & ©)

AT ®)

e

5.5

——

FERE
q






OEBPS/Image00197.jpg
A B
R HEA —5
2011-7-7 a5
2011-4-6 3.25
2011-2-9 3

2010-12-26 2.75
2010-10-20 2.5






OEBPS/Image00318.jpg
NO. LG TCL Kir @4 K2 CFE wROEE O BRME =2 BT RE
1 1.1 46.7 316.2 510.5 0.0 0.0 4633.7 120.2 351.2 0.0 0.0 0.0
2 395 52 23.7 152 0.2 0.9 1.8 7.1 19.1 142 0.1 0.6
3 0.0 7.4 3.0 40 0.3 0.1 1.8 5.4 6.4 0.8 0.2 2.0
4 .1 0.1 1.5 0.7 0.7 0.0 1.2 0.1 2.2 0.5 0.5 0.0
5 12.9 43 58 54 0.6 0.0 3.4 4.5 42 9.5 0.6 3.0
6 2.0 10.0 9.0 10.0 7.5 2.3 9.9 9.8 9.9 2.1 2.6 0.2
XAl 56.6 73.6 359.3 545.7 9.4 3.4 4661.9 147.1 393.0 27.1 4.0 5.8
P{i 00 00 00 00 01 0.6 0.0 0.0 0.0 0.0 0.5 0.3






OEBPS/Image00438.jpg
#* % * % * HI ERARCHI CAL CLUSTER ANALYSI S * * * *

Dendrogram  using  Average Linkage (Between  Groups)

Rescaled Distance Cluster Combine

CASE 0 5 10 15 20 25
Label Num +--------- Fommmmm Fommmm e fommmmmmee o +
TCL 2 ——

5 8§ |

L 34 I 1

fE 9 —+ | I

L T : .
R 7 — | I
LG 1 T I |
=B 10 _ |
KA 6 —0 |
WF p— —— |
ZR 12 ] | ]






OEBPS/Image00211.jpg
Bivariate Correlations ==

“ariables:
= Options..
P B FTTT 2ol
& w4 & BHaw
& 25
& REEM :
& BHES +
& BREERE
& s
& EhEE E
& BIRERE bt
- Correlation Coefficients
Pearson Kendall's tau-b
r Test of Significance
(3) Twodtailed () One-tailed

Flag significant correlations

[ ok ” paste H Reset H Cancel H Help J






OEBPS/Image00332.jpg





OEBPS/Image00454.jpg
sdate ret idxret flag ndate
1172272007 -0.05101 -0.04513 £94.00 -3.00
1172172007 -0.03382 -0.01513 £95.00 -2.00
1142042007 0.03243 0.00452 £96.00 -1.00
11419/2007 -0.01962 -0.00878 697.00 0.00
11416/2007 -0.04806 -0.00917 £98.00 1.00
11/415/2007 -0.01202 -0.00880 £99.00 2.00
11414/2007 0.02444 0.04818 700.00 3.00





OEBPS/Image00210.jpg
MATCH FILES /TABLE = #*
/FILE = "E . \% 112 \idxret. sav’
/BY sdate.

EXECUTE.






OEBPS/Image00331.jpg
DATE_ ERR_1 SAS_1 SAF_1 STC_1
1 JAN 2000 0.63 29985527 0.88 47345858
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12 DEC 2000 1.74 369225250 2.42 2117341.79
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. PRI 440 | BRIV = | BRI | AR
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PRIF 4% Correlation 1. 000 -.007 . 041 . 423
Significance (2-tailed) ; .934 . 604 . 000
df 0 160 160 160
EAABLEE | BUWFR5 Correlation —-. 007 1. 000 . 009 .013
& IR Significance (2-tailed) .934 . 912 . 869
B & A df 160 0 160 160
HEE &
ik | FEMHBAL Correlation . 041 . 009 1.000 | -.055
& KU Ik Significance (2-tailed) . 604 .912 . .490
A df 160 160 0 160
AR Correlation .423 .013 —. 055 1. 000
Significance (2-tailed) . 000 . 869 .490 :
df 160 160 160 0






OEBPS/Image00186.jpg
ﬁ sclate
& sthret
f ichxret
f rskf

() Include all cases

@ Include if case satisfies condition:

sdate=date mdy(2,21,2002)

Function group:

Al

Arithmetic

CDF & Noncentral CDF
Conversion

Current Date/Time
Date Arithmetic

-

Eunctions and Special Yariables:

Date Dmy

-

bATEMDV(momh.dev.vear]. MNumeric. Returns a date

Mely

Nate bdmoy






OEBPS/Image00177.jpg
T = Pearson Correlation 1 .009
Sig. (2-tailed) 911
N 167 167

TV 4 51 Pearson Correlation .009 1
Sig. (2-tailed) 911

N 167 217

B i P 700






OEBPS/Image00179.jpg
H ™ | B &R
Kendall’s tau_b PRI 7 Correlation Coefficient 1. 000 .017
Sig. (2-tailed) . 781
N 167 167
I 4 %51 Correlation Coefficient .017 1. 000
Sig. (2—tailed) . 781 .
N 167 217
Spearman’s tho BRIV = Correlation Coefficient 1. 000 . 025
Sig. (2—tailed) .751
N 167 167
HHIE 4 %5 Correlation Coefficient .025 1. 000
Sig. (2-tailed) .751 ;
N 167 217






OEBPS/Image00178.jpg
20

10

—10

20

10

anjeA [euLoN pajadxyy

T
=)
I

-20

-20

Observed Value





OEBPS/Image00192.jpg
Change Statistics

. E
Model | R R Adjusted B ‘ thrror Durbin-
ode Square | R Square ’ . ¢ R Square K dfl an Sig- ' | Watson
Estimate Change | Change Change
1 .764" | 584 .574 452.020 584 |59.272 | 5 211 .000 1.776






OEBPS/Image00191.jpg
Database Wizard

Welcome to the Database V B

This wizard will help you get data from a non-SPE

“You can choose the data source, specify which
natmes and propetties here. Some features are a

From which data source(s) would you like to retri

ODBC Driver Login

e

Data Source: Excel Files

Database: ‘E:\éﬁ B ERFR000001 s ‘ Browse...
] Cancel
ODBEC Data Sources
&3 dBASE Files
&3 Excel Files

% M3 Access Database
Qﬂ Xtreme Sample Database 2003 CHS





OEBPS/Image00096.jpg
Unstandardized Standardized
Model Coefficients Coefficients t Sig.
B Std. Error Beta
( Constant) -75.028 36.377 -2.063 . 046
R 2.163 .612 .502 3.533 .001






OEBPS/Image00194.jpg
€80T 056 * ez: | 1ie’ 16¢” A 8T°TL | 000" | S4°F VAV €767 | 167121 | BEI¥EHMEIN
2521 66L " oTe" | €ev” 946" 97 '€€2 9°0¢e1 000" | 86°9 Lve” L0°9Z | 90281 iy
P01 T 906 * 761" | 887" 607 98 691 €829 | 000" | LE°F 702 ° €1°92 | SE VIl ESYE
6£2°1 108" L61" | 262" 267 28 961 997G, | 000" | €7°F 612" €708 | V2 9€l IR0 4Ta
42T 18L" 102" | 862" 916" 66 981 T€F, | 000" | 25°F L2z 80°6Z | 99 °TET B9
€'068— | 607 T— | 000" | L'8— L'TET  |'0ST TI— (ueIsuoy))
Uﬂﬂom ﬁcﬂom
AIA | 2oueId[O], | e [enie [19p10-0197 wddr) e ©1aq] 10115 ‘PIS q
EIN 3 [PPOIN
Sonsne JI0T TeAI91U SIUIII0 SIUDIIII0
\CCMQM:WU el L omku_uwwou MA M@ _vhﬁ?mw:mww BLE%WEMD






OEBPS/Image00193.jpg
sdate
0541172004

05/12/2004
05/13/2004
05/14/2004
05A7/2004
05/18/2004

ret

idxret

0.01
0.0z

-0.00
-0.02
0.01

0.0z

0.00
0.0z
-0.00
0.02
0.01
0.01





OEBPS/Image00094.jpg
Compute Yariable (3]

Target Variable:

It

Type & Label...

& BB [x1]
& EBATREE 2
& e B [x3]

& T M [xd]

& B RRR & [x5]
& B [x6)

Mumeric Expression:

1#-0.199+x2*0 02+ 3%-0.104+:4**-0.11 3+x5*0 027 +x6*0.094+x7*0 41 9+x3*0.704

Function group:

! il

@ Arithmetic
@ CDF & Noncentral COF






OEBPS/Image00196.jpg
95% Confidence

Std. Devi-|  Std. Interval for Mean | Mini- | Maxi- | DeM"een”
N Mean . Compone-
ation Error Lower Upper | mum | mum .
nt Variance
Bound Bound
4 8 1075.00 | 559.974 | 197.981 606.85 | 1543.15 | 200 | 1700
5 14 | 1350.00 | 387.795 | 103.642 [1126.09 | 1573.91 | 600 | 1900
6 5| 1400.00 | 360.555 | 161.245 | 952.31 | 1847.69 | 900 | 1900
Total 167 | 1325.15 | 466.300 36.083 [1253.91 | 1396.39 | 100 | 2200
Model Fixed 469. 047 36.296 |1253.47 | 1396.83
Effects
Random 36.296" [1231.85" | 1418.45" -3570.430

Effects






OEBPS/Image00095.jpg
©0

T

0.6

1.0

0.8+

© =+
(==} [}
qo14 wn)) pajoadxy

0.2+

0.0

1.0

0.4 0.8

Observed Cum Prob

0.2

0.0





OEBPS/Image00195.jpg
Compute Variable

Target Variahle: Numeric Expression:

[rskl 98

&2 sdate

& sthret '

59 icheret Function grougp:

& rski An_ _
Arithmetic
CDF & Moncentral CDF
Conversion
Current Date/Time
Date Arithmetic -

sdate==Date mdy(2,21 2002) & sdate=Date mdy(10,29,2004)

Functions and Special Yariables:






OEBPS/Image00092.jpg
BN SRR #XE I b
WEIERR | SR

AF e Kt WMKR | R

FILGEN)|  — | R FIRKE | SRR R

HRHEIR |EIECRD|  — | ek EMRRER | IR

R — | iEE EHRCR | R R






OEBPS/Image00093.jpg
S f
Model o df Mean Square F Sig.
Squares
Regression 9437.175 1 9437.175 12.480 .001*
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AR | e || e | | erteof ot

1 2 1 2 Total
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5 .018 | -1.366| -2.137| .024 . 158 .420 .299 | .673 | .972
6 .000

Active Total 1.000 .090 1.000 | 1.000
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Dependent Variable ; {7 5345

Model Summary

Parameter Estimates

Equation
R Square F dft | df2 | Sig. Constant bl b2 b3

Linear .261 |45.806 | 1 | 130 | .000 | 1.086E6| 7.350E4
Logarithmic .205 |33.454 | 1 | 130 | .000 | -4.387E6| 2.651E6
Inverse . 060 8.271 | 1 | 130 | .005 | 6.511E6| —1.298E7
Quadratic L2710 |23.943 | 2 | 129 | .000 | 2.352E6| 1.684FE4| 426.030
Cubic .310 | 19.162 | 3 | 128 | .000 | —6.567E5| 2.833E5| -4.563E3]| 25.007
Compound .356 | 71.846 | 1 | 130 | .000 | 6.463ES 1.024
Power .375 | 77.886 | 1 | 130 |.000 | 6.653E4 .982
S .124 | 18.408 | 1 | 130 |.000 15.155 -5.116
Growth .356 | 71.846 | 1 | 130 | .000 13.379 .024
Exponential .356 | 71.846 | 1 | 130 | .000 | 6.463ES .024

.356 | 71.846 | 1 | 130 |.000 | 1.547E-6 .977

Logistic
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PR P KU Mean Std. Deviation N
1 1 -.2815 .896 72 13
2 L1967 .693 96 6
Total -.1305 .849 71 19
2 2 .6229 .945 93 7
3 -.074 6 .946 48 13
Total .169 5 .982 27 20
Total 1 -.2815 .896 72 13
2 .426 2 .834 84 13
3 -.074 6 .946 48 13
Total .0233 .920 60 39
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Frequency Percent Valid Percent Cumulative Percent
Valid 2 2 2.0 2.1 2.1
3 2 2.0 2.1 4.3
4 4 4.0 4.3 8.5
5 6 6.0 6.4 14.9
6 7 7.0 7.4 22.3
7 14 14.0 14.9 37.2
8 12 12.0 12.8 50.0
9 10 10.0 10.6 60.6
10 14 14.0 14.9 75.5
11 12 12.0 12.8 88.3
12 7 7.0 7.4 95.7
13 1 1.0 1.1 96.8
14 3 3.0 3.2 100.0
Total 94 94.0 100.0
Missing System 6 6.0
Total 100 100.0
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stkret idxret

Stkret  Pearson Correlation 1 .623""

Sig. (2-tailed) . 000

Sum of Squares and Cross-products 1.021 .499

Covariance .000 .000

N 2127 2127
Idxret Pearson Correlation .6237 " 1

Sig. (2-tailed) .000

Sum of Squares and Cross-products .499 .638

Covariance .000 .000

N 2127 2170
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Model Coefficients Coefficients t Sig.
B Std. Error Beta
( Constant) -46.961 53.427 -.879 . 385
YRR —-1.649 1.556 -.172 -1.060 .296
TE 5T R 4% 24.094 35.628 .102 .676 .503
BT 7 3 1.921 .681 . 446 2.821 .008
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Source Sum of Squares df Mean Square F Sig.
Contrast 704 260. 351 4 176 065. 088 .853 .495
Error 2. 167E7 105 206 360. 781
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IF  (sdate>=Date. mdy(2,21,2002)
EXECUTE.

&

sdate<Date. mdy(10,29,2004) ) rskf=1.98.
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S f
Model o df Mean Square F Sig.
Squares
Regression 11 145.786 3 3715.262 4.950 . 006"
Residual 26 269.782 35 750. 565
Total 37 415.569 38
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Valid 0 50 22.9 23.0 23.0
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700 3 1.4 1.4 33.6
800 3 1.4 1.4 35.0
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3 01/01,/2001 1.00 BEE 219 3516 2755 3038 457 015
4 014012001 1.00 &5 102 2935 2504 4062 380 D016
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Frequency Percent Valid Percent Cumulative Percent

Valid 1 96 44.0 57.5 57.5

2 23 10.6 13.8 71.3

3 11 5.0 6.6 77.8

4 34 15.6 20.4 98.2

5 3 1.4 1.8 100.0

Total 167 76.6 100.0
Missing System 51 23.4
Total 218 100.0
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Bl Pearson Correlation .426"|  .501"| .410"| .482"| .976" 1 . 443" | -, 060
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Ry
it%‘ Sig. (2—tailed) .002 . 000 . 000 .036 . 009 . 005 . 060
) 39 39 39 39 39 39 | 39 39
- Pearson Correlation |-.390" |-.092 |-.339’ |-.109 |-.144 |-.060 | .304 1
E; Sig. (2—tailed) .014 .578 .035 .510 . 380 .715 | . 060
39 39 39 39 39 39 39 39
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EE 139 2045568855
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s Pearson Correlation 1 .911"| .871"}-.252 .490" | . 426" 488" -.390'
V| % Sig. (2-tailed) .000 | .000 | .122|.002 |.007 | .002| .014
N 39 39 39 39 | 39 39 39 39
BB Pearson Correlation .911” 1 .807"}-.234 .529" | .501" .607"| -. 092
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Type Il Sum

Source T — df Mean Square F Sig.
Corrected Model 1.443E7* 61 236 499. 824 1.146 | .267
Intercept 8. 118E7 1 8.118E7 | 393.410 | .000
FLIV b 27 135 072. 509 4 33768. 127 .164 | .956
DR Wi 2o 25 1322 538.415 4 330 634. 604 1.602 | .179
FHIVE ™= 485 381.413 5 97 076. 283 470 | .798
PR b o5 RS WAL i 2 B 1903 461.001 9 211 495. 667 1.025 | .425
TV 3 55 < BRIV 7 A 2 886 899.372 11 262 445.397 1.272 | .251
DRSS AL i A5 B BV 77 iy 3390 142.970 16 211 883.936 1.027 | .435
PRIV M 5 < XUBS R ZE AR BE | 4 962 804. 948 10 496 280. 495 2.405 | .013
xHLIA = fih
Error 2.167E7 105 206 360. 781
Total 3.294E8 167
Corrected Total 3. 609E7 166
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Variance Proportions

Model Higerlus Condition pree - presmp e
Dimension ’ ) Index (Constant) | :‘3‘ = TI“E:‘L o TJ\‘I,J\ ﬂj:/\ 7
A | bR | B | B
1 1 4.538 1. 000 .01 .00 .01 .00 .00
2 .203 4.733 .68 .03 .02 .01 .09
3 157 5.378 .16 .00 .66 .01 .13
4 . 066 8.287 .00 .09 220 .36 .72
5 .036 11.215 .15 .87 J12 .63 .05






OEBPS/Image00148.jpg
stime |c|ass‘ name‘ s2IIII5| 521 ‘ 525 ’ 929‘ 534 |534mr‘ nyear ’

01/01/2001  1.00 44T 141 3626 2494 3239 472 029 2001.00
01/01/2001  1.00 TCL 069 2659 2442 4083 733 008 2001.00
01/01/2001  1.00 £ 219 3516 2755 3038 457 015 2001.00
010172001 1.00 &5 102 2935 2504 4062 380 016 2001.00
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Create Time Series
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&5 ar600019
& arsonnos
& arsono10
& aré00001
& ars00008
& ar6003039
& arB00177
& ars00so0n
& arson7as
& arB00ae7T
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nyear | name |s20ls_mean| s21_mean s25_mean| s29_mean |s34_mean s34mr_mean

2001.00) LG 0.10 40.63 12.42 41.08 0.20 558
2001.00 TCL 0.59 2473 2215 46.71 8.77 0.0s
2001.00 4T 143 35.03 18.61 39.74 4.53 0.56
2001.00 B 1.94 31.16 19.56 42.44 4.85 0.06

2001.00 FwF 0.00 13.89 14.47 42.43 10.41 18.80
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Source Type Il Sum of Squares df Mean Square F Sig.
Corrected Model 4.029* 3 1.343 . 668 .192
Intercept 124 1 .124 .154 .697
WG .587 1 .587 .729 .399
P e Wk 3.152 2 1.576 .958 . 156
PR BB -000 0 :

Error 28.176 35 . 805
Total 32.226 39
Corrected Total 32.205 38






OEBPS/Image00268.jpg
Percentiles

FEARLIE

N Mean St,d', Minimum | Maximum
Deviation 25th | 50th (Median) | 75th
100 | .6060 | 5.912 87 -13.20 13.70 [-3.2750 .5000 5.2750
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Unstandardized Standardized
Model Coefficients Coefficients T Sig.
B Std. Error Beta
1 (Constant) -233.981 102. 648 -2.279 .030
B R R 2.437 5.566 .254 .438 . 665
BBATRE R -3.439 4.117 -.431 -.835 .410
HEBMRE . 600 3.392 .079 177 .861
G % 117.958 61.297 . 498 1.924 .064
o7 AT S i 7 1.028 3.403 .230 .302 .765
I 2 S i % ~7.045 8.146 -.678 -.865 .394
sl R .961 . 845 . 407 1.137 . 264
B LR 2.202 1.289 .511 1.708 .098
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PRI
HRIU Hb i
1 2 3 4 5 6 7 Active Margin
1 44 14 20 7 7 4 0 96
2 9 3 8 1 2 0 0 23
3 5 2 2 0 2 0 0 11
4 13 5 13 0 2 1 0 34
5 1 1 0 0 1 0 0 3
6 0 0 0 0 0 0 0 0
Active Margin 72 25 43 8 14 5 0 167
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sdate

& idret
f flag
& noste

rSelect

() All cases
(%) If condition is satisfied

ndste==-10 & ndate==260

() Random sample of cases

I

) Use fiter variable:

EN

rOutput
() Fitter out unselected cases

() Copy selected cases to a new dataset

Datazet name: |f000001
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rDisplay Order—
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Break Variable(s):

&} stime T & nyear

& class + ‘ &g name

f s20ls A=

& <2t Aggregated Variables ———————————————————
& s25

f <29 Summaries of Variable(s):

09 534 520ls_mean = MEAN(s20s)

f - 521 _mean = MEAN(S21)

525_mean = MEAN(=25)
@ 529_mean = MEAN(S29)

534_mean = MEAN(S34)

|sS4mr_mean = MEAN(s34mr)

Function... e

[ Mumber of cases Name:

) Add aggregsted variables to active dataset

) Create & new dataset containing only the aggregsted variables
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BEG . | BITHK | Seacdi H TR
Model Erd el i i

1 Correlations  [F 2 %= 4% W46 1.000 .135 -.262 —.429
ES Al Ehee .135 1.000 —.060 —.437

BRI H N5 -.262 -.060 1.000 -.548

TERRH —.429 —.437 —.548 1.000

Covariances  [& & Y= # W45 .000 .000 .000 —6.747E-5

ES Al Ehee .000 .006 .000 .000

PRI H AL .000 .000 .007 .000

TR AR -6.747E-5 . 000 . 000 .000
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&) Aggregate Data: Aggregate Function

Summary Statistics Specific Values Mumber of cases

() Weighted

() Weighted missing

() Minimurm () Unweighted
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1 d_-10 0.0 oo
2 d_-8 0.00 0.00
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4 d_-7 oo -0.00
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Percentiles

4P E

N Mean St,d'. Minimum | Maximum
Deviation 25th | 50th (Median) | 75th
100 | .52 5.854 -13 13 -3.00 1.00 5.00
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B Crosstabs: Statistics

Chi-square

Nominal
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Phi and Cramer's %
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Q Factor Analysis: Options (3]

-Missing Values
(2) Exclude cases listwise
() Exclude cases pairwise

() Replace with mean

-Coefficient Display Format ——

["] Sorted by size

Suppress absolute values less than:

l Continue ” Cancel H Help I






OEBPS/Image00154.jpg
@ Compute Yariable

Target Wariable: Mumeric Expression:
Irskfret | - ideretrskid

Type & Lakel...

aoate
&P sthret
& idret

@ rakf
& rekid






OEBPS/Image00275.jpg
Dependert(s):
& #E

CA Wariable:

Eee s =

(%) Time

Case Labels: Include constant in equation

rModels

Linear Quadratic Compound Growth

Logarithmic [v] Exponential
nverse Power: Loggistic

Upper bound: l:l

| Eisplaz ANOYVA tablel
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vuf E-Neans Cluster Analysi...

[ Statistics
| [v] Initial cluster centers

| [(] ANOVA table

‘ Iglusier infarmation for each casze

rMissing Values

) Exclude cazes listwize

() Exclude cazes pairwise
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, nyear

name ‘s2EIIs_mean| 521_meanl s25_mean s29_mean |534_mean| s34mr_mean

2001.00| LG 0.10 40.63 12.42 41.08 020 5.58
2001.00 TCL 0.59 24.73 2215 46.71 577 0.058
2001.00 44T 1.53 35.03 18.61 39.74 453 0.56
2001.00 i 1.94 31.16 19.56 42.44 4.85 0.06
2001.00 F# 0.00 13.89 14.47 42.43 10.41 18.80
2001.00 “&FiE 0.00 19.44 13.84 48.75 12.72 525
2001.00 &R 5.82 29.35 17.34 40.81 6.57 0.11
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] Univariate: Contrasts (3

Factors:

B S(Simple)
P 3 A AT (None)
B = gh(None)

rChange Contrast-——————————
%Comrast Simple = Change i

Reference Category: (3) Last () First :
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f
Model Sum o df Mean Square F Sig.
Squares
Regression 11271.547 3 3757.182 5.030 . 005"
Residual 26 144.022 35 746.972
Total 37415.569 38
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& ret
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Model Sum of Squares df Mean Square F Sig.
Regression 111.761 4 27.940 19.071 .000*
Residual 186. 065 127 1.465
Total 297.826 131
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Q Add Yariables to finall.sav[DataSet1] (&)

Select a dataset from the list of open datasets or from a file to merge with the active
dataset

() An open dataset

(3) &n external SPSS data file

ENGE i EAB 6] FMinal2 sav ! Browse... I

MNon-SPSS data files must be opened in SPSS before they can be used as part of a merge.
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Model Sum of Squares df Mean Square F Sig.
Regression 15 060. 154 8 1882.519 2.526 .031°
Residual 22 355.415 30 745.181
Total 37 415.569 38
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%1 %2 %3 wd i}
11.47 19.88 29.44 0.20 2i75 1.91
| 563 15.39 31.29 0.41 5.64 3.70
| 3.20 16.18 2534 0.06 1:27 0.65
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Model Q3 P )Xot Q2 Q1
Correlations Q3 1.000 .012 .500 .500
P i) %o .012 1.000 .027 045
Q2 .500 .027 .000 .501
Q1 .500 .045 .501 1.000
Covariances Q3 . 089 .000 .044 .044
s} ] %3 4% .000 .013 .001 .002
Q2 . 044 .001 .089 .045
Q1 .044 .002 .045 .089
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f A Time Series Modeler

Variahles \ Statistics \ Plots \ OutputFiter | Save | Options

rSave
Variables:
Description sawe | Variable Name Prefix
Predicted Values Predicted
Lower Confidence Limits id] LCL
Upper Confidence Limits 0 LeL
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| For each tem you select, one variable is saved per dependent variable.

rExport Model File

File:
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95%

Unstandardized |Standardized . ) Collinearity
. . Confidence Correlations o
Coefficients | Coefficients Statistics
Model ; 55, Interval for B
Std. Lower | Upper | Zero- i
B B Partial | P Tol VIF
Exror o Bound | Bound | order artia art oeranee
1(Constant) | 11.165 | .494 22.615| .000 [10.188 [12.142
BFEOXEC | 980 | . 113 611 | 8.703| .000 | .757|1.203| .612 | .611| .610| .998 |1.002
Q1 -.102 | .298 -.029 | -.342| .733 | -.692 | .488] -.043 | -.030| -.024| .665 |1.503
02 -.045 | .298 -.013 | -.151| .880 | -.635| .545| -.003 | -.013| -.011| .666 |1.501
Q3 -.065 | .298 -.019 |-.218| .828 | -.655| .525| .004 | -.019| -.015| .667 |1.500
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Dimension: 1

TP | RS | SCSE | EREE | RS | WS S

PRI P e 1.000 .152 111 .107 .046 .029
RS .152 1.000 .380 .212 .394 .217
IR 111 .380 1.000 .209 .368 .167
TR .107 .212 .209 1. 000 .276 .122
SRS . 046 .394 .368 .276 1. 000 .125
R Wi 36 25 .029 .217 . 167 .122 .125 1.000
Dimension 1 2 3 4 5 6

Eigenvalue 2.072 .984 .913 . 834 .629 .568
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PRE1 | RES1 | DRE1 | ADJ1 | ZPR1 | ZRE1 | SRE1 | SDR1
121 1576393 071881 0.74730 1573543 0.88065 059366 060552 0.60400
122 1562900 0.27486 0.28557 1561830 0.95930 022708  0.23146 0.23060
123 1581714 044071 045766 1580020 094646 036410 037104 0.36978
124 1568996 0.31431 032627 1567800 1.02530 025967 026457 0.26360
125 1579581  -0.0B801 -0.07075 1579856 092336 -0.05619 -0.05731 -0.05708
126 15.66063  -0.44007 -0.45745 1567801 099354 036357 037088 -0.36942
127 15.84852 047605 -0.49462 1586706 098042 039330 -0.40090 -0.39957
128 1592109  -0.48379 -0.50245 1593975 1.05899 039969 040732 -0.40598
129 15.62669 043117 044877 1580009 095679 035622 036342 036217
130 1589126  0.91497 095163 1585460 102670 075692 077091 0.76968
131 1567891 118309 1.22985 1583215 1.01334 097743 099655 0.99653
132 1595125  1.04647 1.08738 1591035 1.09165 066456 0685130 0.868052
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d_10 -1.132 26 .268 -.024 19 -.068 1 L0197
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Error T Sig.

Nominal by Nominal Phi .336 .221
Cramer’s V .194 .221

Contingency Coefficient .318 .221
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