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0 中文版序言

其实最不喜欢读序言了，要么无味，要么剧透！

所以我们这篇序言里，不会给你讲从前从前……而是列出有用的网上资源（英文）：

Sketch的官方网站：

http://www.bohemiancoding.com/sketch/


Sketch试用版下载：

http://www.bohemiancoding.com/download/sketch.zip


Sketch正式版在线购买（Mac App Store）：

http://itunes.apple.com/us/app/sketch/id402476602?ls=1&mt=12


一些有用的源图，可以帮你理解Sketch画出的图是怎样的：

http://www.bohemiancoding.com/sketch/community/


软件支持服务：

http://bohemian-coding.tenderapp.com


使用技巧博客：

http://sketchtips.tumblr.com


这本手册的原文：

http://www.bohemiancoding.com/sketch/help/




图灵社区文章：


	
初识Sketch：设计师的工具箱


	
Sketch：王冠上的钻石








1 Sketch简介

欢迎打开Sketch 2手册！

本手册内容适用于菜鸟和高级用户。

如果你有关于本手册的任何问题，欢迎不吝赐教： mail@bohemiancoding.com

注意，本手册内容仍在不断更新中。



Sketch是什么？

Sketch是一款矢量做图工具，无论你是哪种类型的设计师，都能用得上。至今为止，基于矢量的做图是设计网站、图标和用户界面的最佳方式。基于矢量编辑这一基础，我们增加了基本的位图样式支持，例如模糊和颜色调节。

我们试图让Sketch成为易用而强大的工具，从而能够代替Adobe Photoshop，我们为Photoshop的用户群而设计。Sketch的用户界面和应用程序图标都是用Sketch软件本身做出来的。你可以在官方网站下载一份较早版本的应用程序图标。



为何要用Sketch？

Sketch的界面非常棒，是为想要设计图标或界面的用户而特制的；它是一个单窗口应用程序，你想要的功能永远都在手边；支持多个文件分层；使用了最佳的文字渲染和文字样式算法；画布具有无限尺寸；而且切片工具非常棒，你会爱上它。

在画布上你可以使用与分辨率无关的视图，来查看无限高的细节；或者也可以切换到像素视图，以便确切地看到每个像素点导出后的模样——如果你想要像素级的精确。



Sketch不能做的

Sketch不是一款位图编辑器。这就是说，你如果想做的是照片修正、画笔绘图，这款软件就不是你的菜。





2 界面

Sketch的界面被设计得极其简约。顶端的工具条包含了最重要的操作，右侧的检查器用于调整被选中图层的属性，而左侧的面板则列出了文档中的所有图层，当前工作的画布在中间。

2.1 工具条
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Sketch的工具条包含了你在画图过程中要使用的全部工具。在默认工具条中的第一组工具可以用来添加新的图层：你可以选择常见的形状如矩形、圆形，或者使用紧挨着它的矢量自由绘图工具。

组合和取消组合工具可以帮你组织文档。接下来的几组工具用来对图层进行编辑：旋转、变换、使用布尔操作合并图层，以及在图层列表中向上向下移动图层。

导出按钮（工具条的最后一个图标）也是切片工具，可以以一个或多个位图或矢量文件的形式导出你的作品。

不像其他的画图工具，Sketch没有一个包含常用工具的工具箱，而是将它们都放在工具条中。通过右击工具条选择“定制工具条（Customize Toolbar…
 ）”可以将其他的工具和快捷方式添加到工具条中。

2.2 图层列表

图层列表列出了当前页面（Page）中的所有图层，并为每一个图层提供了小图预览。你还可以查看图层是否锁定、隐藏或者作为蒙板。在图层列表中，你可以改变图层的排列顺序，也可以针对形状的子路径选取布尔操作。使用群组工具或者对图层重命名可以帮助你组织文档。

Sketch支持在一个文档中包含多个页面，使用图层列表顶端的弹出菜单，你可以添加、删除或者切换到其他页面。如果当前的文档包含画板（Artboard），你也可以使用同样的弹出菜单在它们之间切换。

2.3 检查器

通用检查器
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你可以使用右侧的检查器调整当前图层的设置，或者在某些情况下调整当前工具的设置。当选中一个图层的时候，你会发现选择器被划分为几个区块。

通用的图层样式在上面的区块，包括位置、不透明度、混合模式，还有几个根据图层而定的特殊选项，例如为矩形设置圆角。要想完全控制矢量对象，请查看矢量编辑
 部分。

样式属性
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每一个样式属性分在下面不同的区块里。你可以点击每一部分右上角的三角来切换它们的显示。打开后可以看到它们各自的选项。当点击颜色按钮时，你会看到当前的选择器滑动切换到一组专门的颜色选择器。然后无论你切换到其他图层，还是按下颜色选择器顶部的小后退（Back）按钮，都会回到主选择器中。

2.4 画布

Sketch的画布没有大小的限制。在你有无限大的精确度的时候你可以以一种与分辨率无关的视图查看画布，也可以切换到像素预览，你将会精确地知道每一个像素在导出时看起来的效果。

如果你喜欢在无限大的画布上定义一个固定的框架，简单地使用画板工具就可以创建一个画板。





3 图层类型

在默认工具条中的第一组工具可以用来添加新的图层：你可以选择常见的形状如矩形、圆形，或者使用紧挨着它的矢量自由绘图工具。

3.1 形状
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在你的文档中，大多数图层都将会是形状图层。Sketch提供了种类繁多的默认图形，比如圆形、矩形、星形等。你可以像编辑其他矢量图层一样直接对它们进行编辑，但其中很多形状也提供了扩展选项，可以更简单地获得想要的效果。

想要在你的文档中添加新的形状图层，只需点击工具条里的“形状（Shape
 ）”按钮并选择其中一个可用的方案。因为形状是由矢量组成的，你可以使用矢量编辑工具
 轻松把它们变成你想要的形状。

扩展选项
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Sketch里的某些默认图形具有一些有趣的扩展选项，尤其是多边形和圆角矩形。当这些图层被选中的时候，会显示出扩展选项。对多边形来说圆角和边的数量是可以调整的，对圆角矩形来说圆角是可以调整的。

要注意的是，如果改变了这些默认形状的参数，你将会丢失之前所做的编辑，例如添加的点。

3.2 铅笔
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铅笔工具允许你自由绘图。当松开鼠标之后，Sketch会试着平滑曲线、简化路径。

默认工具条中不包括铅笔工具，这就意味着你需要在工具条上右击，然后在列表中选择“定制工具条（Customize toolbar…
 ）”来添加它。铅笔工具有一个快捷键P
 。

3.3 文字

Sketch使用Mac OS原生的字体渲染，也正因为这样，文字看起来非常卓越。使用原生字体渲染的优势是，当你在做一个网站设计的时候，你可以确定它们看起来精确无误。Sketch还支持文字样式，因此你可以在多个文字图层上使用同样的字体、字号、字间距等。

添加文字

你可以点击工具条里的“文字（Text
 ）”图标添加文字。这时鼠标指针变为文字光标，你可以点击画布上的任何地方，在该处添加文字。你可以看到新添了一些文字并处于选中状态，可以马上开始打字。

你还可以点击并拖动鼠标，创建一个固定大小的文字框（Text Box），如果输入的文字超过了文字框的大小，固定（Fixed）文字框会向下方伸展，与之相对，弹性（Flexible）文字框会向左右伸展来容纳更多文字。

文字检查器
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你还会观察到，检查器已经变成一个可供选择字体、字号等选项的选择器。注意在默认情况下，字体选择列表中会显示字体预览，如果不喜欢这种方式，你可以在首选项中将其关闭。

同样你可以改变字间距，也可以改变文字的行间距。在没有对文字进行整体填充的情况下，你可以在文字检查器中改变个别文字的颜色。其他的文字设置，例如转换为大写、小写字母，可以在菜单栏的“格式（Format
 ）”下找到。

文字样式
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字体检查器的最后一项是文字的样式列表。默认这里没有预置的样式定义，如果你在这里增加了样式定义，当前的文字图层就会成为新样式的原型。稍后如果增加了新的文字图层，并且应用了同样的样式，则新图层的样式会与第一个图层的样式匹配。

依附路径

Sketch支持沿着路径对文本进行渲染，如下图所示：
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要实现这样的效果，我们先选中两个对象：一个矢量形状和一个文字图层，然后在“编辑（Edit
 ）”菜单中打开“文字依附路径（Text on Path
 ）”选项，Sketch会将文字图层中的文字依附到它下面的矢量图层的路径上。需要注意的是，只有文字图层在形状图层上面的时候才起作用，如果文字图层在形状图层的下面，请先改变图层顺序。
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要在矢量形状上定位文字的精确位置，只要沿着形状水平拖动文字就可以了。写成文字可能比较复杂，但操作起来会非常直观。

通过菜单“编辑（Edit
 ） > 转换文字为轮廓（Convert Text to Outlines
 ）”命令，可以将文字转换成矢量形状。然后就可以借助用于常规矢量形状的工具对文字进行编辑。要了解更多信息可参见形状
 章节。

3.4 组合

你可以对文档中的图层进行组合（Group），这样子它们看上去就像一个图层。你可以像一个图层一样对它进行移动或者调整大小，也可以进入组合内部，改变里面的某一个图层。

在Sketch中，组合是一个非常强大的工具。因为组合被视为图层，因此可以对它进行再次组合、移动、调整大小。当你对组合调整大小的时候，它里面的图层也将会相应地按比例缩放。如果组合中包含文字，文字中的字体也会随之缩放。

编辑组合

组合被创建后，你可以双击它来查看和编辑它的内容。你可以移动它里面的图层甚至添加更多的图层。任何时候你点击了组合之外的对象，Sketch将会跳出组合，让你可以选择文档里的其他图层。这时你再次单击组合里的某个图层，则会选中整个组合。这里的操作方式，与对形状内子路径的操作完全相同。

深度点击
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默认情况下，除非先双击某个组合，否则组合里的一个图层是不能被直接选中的。如果你按下⌘
 键，Sketch允许你直接选中嵌套在组合中的图层。

如果你只是使用某些组合来对图层列表进行分类整理，而感觉每次双击进入组合很麻烦，你可以在检查器里将一个组合标记为“允许深度点击（Click-through when selecting
 ）”，甚至还可以在首选项中设置一个参数，来定义新建群组的工作方式。

3.5 选中、移动、改变大小

通过其他做图软件，你可能已经熟悉了图层（Layer）的概念。在Sketch里则没有图层概念，或者说图层升级了，随你怎么看。

当在画布里添加一个矩形时，你就添加了一个新的图层。再添加下一个矩形，你就添加了另一个图层。因此每个对象各占一个图层，每个图层只拥有一个对象。虽然在这本手册中我们始终使用“图层”这个词，但现在你看到，它已经不同于传统意义上的字面意义了。

添加图层
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最简单添加图层的办法，就是在工具条中挑选一个标准形状。点击矩形工具，你会看到，鼠标指针变成了右上角带一个小方块的十字形光标。现在在画布上点击并拖动，插入形状。当你放开鼠标，形状就被插入到画布中，再次点击拖拽，即插入另一个形状。同时注意，你可以按下shift ⇧
 键来画出正方形。

当你认为已经添加了足够多的矩形，在画布上点击任何一个地方（不要拖动）即可退出矩形工具，或者取消选定工具条里的图标，也能达到同样效果。

选中图层

单击即可选中一个图层。你应该能看到8个小手柄，分别出现在形状的四角和四边上。如果你确定已经选中了图层但没有看见这些手柄，你可能无意中关闭了“选中时显示手柄（Selection Handles）”的选项。可以在菜单“视图 > 显示选中项（View > Show Selection
 ）”来打开它。

你可以按住键盘上的shift ⇧
 键来选择多个图层。在点击下一个图层的时候，之前选中的图层会保留。如果你按住shift ⇧
 键并且点击已经选中的图层，可以取消选中它。

在画布上的空白区域点击并拖拽，可以选中一个矩形区域所接触到的所有内容。此外，如果你按下⇧
 或者⌘
 键，它会扩大你的选中范围，或者取消任何已经选中的对象。

如果你同时还按下了alt ⌥
 键，则只有那些完全包括在矩形范围内的图层会被选中。下图为对比，左边是按下⇧
 键拖拽，右边是同时按下⇧
 和⌥
 键并拖拽。

改变大小

这8个手柄不仅用来表示选中图层，你还可以使用它们改变图层大小。抓取手柄中的任意一个然后拖拽它们来改变图层大小。如果你同时按下了shift ⇧
 键，可以在改变大小时保持宽高比——或者在已经设置了保持宽高比时，取消保持宽高比例。

如果你按下了alt ⌥
 ，图层将会基于中心放大，而不是基于对角放大。

移动

你可以通过鼠标来抓住选中图层并进行移动。为了将移动限制在某个坐标轴内，你可以在拖拽的时候按下⇧
 键。

当对图层移动或改变大小的时候，Sketch应该自动地使你的图层和临近的图层对齐。如果没有自动对齐，你可能是无意中隐藏了“图层参考线（Layer Guides）”。为了让它显示出来，在菜单中找到“视图 > 显示图层参考线（View > Show Layer Guides
 ）”。标尺、参考线和网格是相当大的话题，将用单独的章节进行说明。

如果在拖拽之前按下alt
 键，你将会拖拽出一个新的图层副本，原始图层则留在原地。

图层重叠
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当一个图层被压在另一个图层下面时，要快速选中它，你可以按下⌥
 和⌘
 键然后单击，会弹出一个漂亮的下拉菜单，显示你鼠标所在位置的所有图层列表。

即使没有事先选中某个图层，你也可以立即对它进行移动。但是，如果当前选中的图层隐藏在另一个图层下面，你拖动鼠标时就会选中上面的图层，想要避免这种情况，在点击并拖拽的时候按下A
 键。这样就不会选中新的图层，而是移动之前已经选中的图层。

3.6 蒙板

在Sketch中，蒙板（Mask）的作用是有选择地显示其他图层的某一部分。例如，在图像上放置一个圆形的蒙板，则只有在圆形里的部分图像会显示出来。
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任何形状都可以转换为蒙板。要实现这一点，选中形状，然后在菜单里选择“编辑（Edit
 ） > 做为蒙板（Use as Mask
 ）”。在蒙板以上
 的任何图层都会被裁剪到蒙板的形状内。

限制蒙板

如果你不希望蒙板以上的图像全都被剪切，限制蒙板作用范围的一种方法是：为这个蒙板和你想要裁剪的图层建立它们自己的组合。如果蒙板放在组合中，任何在组合之外的图像都不会被剪切。

有些时候不方便对图层进行组合，另一种停止蒙板的办法是按照下面的步骤：


	选择一个目前被遮住但是你不想遮住的形状

	在菜单里选择“编辑（Edit
 ） > 忽视下面的蒙板（Ignore Underlying Mask
 ）”



这个图层和之上的任意图层都将不会再被遮住。要小心的是，当你对图层重新排序的时候，某些层会忽然被遮住，某些会忽然露出來。

形状蒙板

根据以上步骤，要给一个图片添加蒙板看上去非常麻烦。我们有一个好消息：选中一个形状和画布中的一个图像，在菜单中选择“编辑（Edit
 ） > 使用选中形状做为蒙板（Mask with Selected Shape
 ）”，即可让该形状成为该图像的蒙板。Sketch将会把图像和形状两个图层放在一个新的组合内，并且将形状转化成蒙板。基本上是自动完成了上面列出的步骤。

透明度蒙板

默认情况下，蒙板的工作方式是在它的面积内显示内容，而隐藏其余部分。另一种使用蒙板的方式是给它一个渐变，使用渐变的透明度来决定什么该显示什么不显示。

要将蒙板设为第二种模式，可以选择菜单“编辑（Edit
 ） > 蒙板模式（Mask Mode
 ）> 透明度蒙板（Alpha Mask
 ）”。





4 设置样式

使用检查器面板，你可以对图层进行任意调整。

常规选项
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检查器面板的第一部分，可以针对所选中的形状，进行包括位置、混合模式、不透明度以及一些特殊选项的修改。例如：如果你已经选择了一个矩形，它将会显示出一个滑块来调节圆角半径。

边框
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可以使用实心颜色或者渐变颜色来为图层添加边框（Border
 ）或称描边（Stroke），描边的位置有外部（Outer
 ）、居中（Center
 ）或者内部（Inner
 ）可选。

想要得到虚线边框，可以使用“虚线/间隙（Dash/Gap
 ）”输入框。

想要将边框改成渐变色：


	单击“颜色（Color
 ）”按钮，检查器面板中会滑入一个新的面板。

	在这个面板的底部，你可以将颜色切换为“渐变色（Gradient）”。

	如果想使用放射性（Radial
 ）渐变而不是线性（Linear
 ）渐变，可以通过弹出菜单实现。



如果你想知道如何让编辑一个已经存在的渐变，请阅读渐变的相关章节
 。

填充
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在Sketch中，填充形状可以是实心颜色、渐变或者（图案）图像。想要将实心颜色切换到渐变色，可以按照上面边框部分的步骤来操作。想知道如何编辑一个已经存在的渐变，请阅读渐变的相关章节
 。

使用图案填充，你可以从默认图案中选择，或者将你自己的图片拖放到图像选择区中。你可以将图案设置为“平铺（Till
 ）”或者“充满（Fill
 ）”。


	平铺：图片多次重复拼接，直到整个形状区域被填满。

	充满：拉伸一个图片来填满整个形状。



你可以按下第一个填充右侧的+
 按钮来添加第二个填充，一个图层最多可以有4个不同的填充，按照从左到右的顺序依次叠加。每一个填充有它自己的混合模式，你也可以改变它们的不透明度。

注意，如果你设置了多个填充，并且最右边的是一个不透明纯色或者渐变，你将不会看到它下面的填充。

你可以在工具条中抓取拖拽，来对填充进行重新排列。

阴影和内阴影

阴影（Shadow
 ）和内阴影（Inner Shadow
 ）有着相同的设置选项，工作方式也相同。除了一个在形状内部、一个在形状外部。

要注意的一点是，在对文本图层设置内阴影时，模糊（Blur
 ）半径为0效果最佳。另外你还可以通过将阴影的偏移量（X
 、Y
 ） 设为0，并且改变模糊（Blur
 ）和伸展（Spread
 ）值来获得发光效果。

模糊
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在Sketch中，图层的模糊效果有三种方式，你可以在模糊（Blur
 ）部分的头部选择这些模式中的一个。


	高斯模糊（Gaussian Blur
 ）：均匀地对图层进行模糊；

	动感模糊（Motion Blur
 ）：在一个方向上模糊以造成移动的错觉；

	径向模糊（Zoom Blur
 ）：从某一个特定的点向外开始模糊；

	背景模糊（Background Blur
 ）：新版功能，模糊该图层后面的内容，类似毛玻璃的效果。



要知道在渲染图像时，模糊效果非常耗资源。图层面积越大，相应的内存和进程占用也越高。

虚线
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矢量图层的边框有一些高级选项，你可以修改虚线设置、以及矢量端点（Ends
 ）和接头（Joins
 ）的形状。

虚线设置可以在检查器的边框（Border
 ）部分找到，点击在它右上方显示的三角形，边框部分会扩展，显出更多的一些选项，其中底部的四个选项用来设置虚线。

例如，如果将虚线/间隙（Dash
 /Gap
 ）组合设置为4-2，就会产生4像素描边、2像素间隙、再4像素描边……的虚线。5-4-3-2组合则会产生5像素描边、4像素间隙、然后3像素描边、2像素间隙、然后从头开始。

倒影

倒影（Reflection
 ）带来的效果就好像图层立在玻璃上。你可以使用滑块来改变倒影的强度，第二个滑块用来确定原始对象和倒影之间的距离。这里要说明的是，如果滑块没有给你足够的灵活性，你还可以在它旁边的文本框中输入更大的值。

颜色调节

如果你希望对一个已经存在的图像调整颜色，可以使用颜色调节（Color Adjust
 ）工具来实现。

要注意这个效果非常耗资源，因此，如果直接改变矢量图层的图形填充等选项，也能轻松实现你要的效果，建议不要使用颜色调节。在新版Sketch中，只针对位图图层提供颜色调节选项。

4.1 颜色
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在 Sketch 中，我们将颜色选择器直接放入检查器面板内。要显示颜色选择器，选择一个形状，激活填充或者边框，然后点击它们任何一个的颜色按钮。

整个检查器面板将会滑动移出，给一个新的颜色面板让出空间。在最上面的就是颜色选择器，选择器是基于HSB（色相、饱和度、亮度）颜色模式，在大方块中，水平和垂直方向分别代表饱和度和亮度，而色相则通过它下面的滑块设置，再下面的滑块用来改变颜色的不透明度。

HSL 颜色
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在下面你可以看到颜色的 HEX 值和 RGBA 颜色值。注意，你可以通过点击R
 /G
 /B
 标签切换到HSBA颜色值。

如果你是通过点击边框或者填充中的按钮打开的颜色面板，你会看到在颜色选择器下面，还可以在颜色、渐变或者图案（仅填充）之间选择。在每一个部分，你都可以将选择保存为预设值，点击预设值列表最后的+
 按钮即可。

噪点

[image: ]


如果正在改变的是图层的填充颜色，你将会看到下面有一个选项部分，其中有一个“噪点（Noise
 ）”滑块。滑动滑块来为图层增加噪点并调整强烈程度。

想了解更多关于渐变的内容，请阅读渐变章节
 。

4.2 渐变
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Sketch中的渐变与你熟悉的其它软件有所不同，因为你可以直接在画布中编辑颜色停止点，而不是在检查器中。

要为一个形状增加渐变填充，选中它，然后点击填充（Fill
 ）按钮，检查器就会显示颜色工具。要学习如何设置颜色，请先阅读相关章节
 。在颜色面板的下面你可以在颜色、渐变或者图案填充之间选择。

点击渐变（Gradient
 ），在出现的弹出菜单中你可以选择线性（Linear
 ）、径向（Radial
 ）和角度（Angular
 ）渐变（在旧版中称为圆形Circular渐变），你可以根据对颜色顺序进行翻转（Flip
 ）。同时画布也会更新。单一的颜色填充将会变成渐变填充，并出现两个或更多的点连成的线，覆盖在图层上。线上的每一个点代表渐变的一个颜色停止点，两个点之间的空间被平滑过渡的颜色充满。
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要改变颜色停止点的颜色，在画布上单击它，在检查器中的颜色选择器会显示该停止点的颜色。在选择器中选取一个新的颜色值，你将会立即看到更新的结果。

要在两个停止点之间插入一个新的点，点击线的中间部分，你会看到另一个停止点被添加进来，可以在开始和结束点之间移动这个点，来调整渐变的平滑性。也可以移动第一个点和最后一个点来改变渐变的方向。

要删除一个颜色停止点，在画布中选中它，在键盘上按下删除（delete
 ）或者后退（backspace
 ）键，

径向渐变
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如果你一开始选择的是径向（Radial
 ）渐变，线上的第一个点将会是渐变的中心，最后一个点将决定渐变的大小。

在圆形的外缘上你还可以看到另一个点，拖拽它，可以将圆形渐变改成椭圆渐变。

角度渐变
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角度（Angular
 ）渐变的方式是沿着顺时针方向、围绕图层的中心点。你可以点击这条线的任何地方，来人意添加停止点，并且可以移除/拖拽它们，操作方式和线性渐变一样。

渐变边框

在Sketch中同样可以为边框描边设置渐变，操作和渐变填充非常相似，所不同的是首先点击“边框（Border
 ）”中的颜色按钮，然后重复以上步骤。

4.3 多重填充

在Sketch中，每个图层最多可以有4个填充，你可以轻松地将一个半透明的渐变叠加在一个单色填充上面。具体做法是，点击位于第一个颜色填充后面的+
 按钮来添加第二个填充。你可以来回拖拽它们以重新排列顺序，或者将其拖拽到面板之外来删除它。
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想要改变单个填充的颜色属性，点击相应的颜色填充按钮，然后可以修改颜色，也可以切换到渐变填充或图案填充。你可以通过点击每一个填充上面的复选框来禁用单个填充。

为一个图层添加了多个填充后，点击最后一个填充的颜色框，你会看到在颜色检查器中出现了更多的选项（Options
 ）内容。你可以为每一个连续的填充选择不同的混合模式（Blending
 ），或者单独修改某个填充的不透明度（Opacity
 ）。

4.4 预设值

如果阅读了前面关于颜色和渐变的章节，你应该已经遇到“预设值（Presets）”很多次了。颜色、渐变和图案填充，各自都有它们的预设样式，你可以随意添加、删除其中的任何一个。也可以按照你的想法拖拽它们。Sketch默认为每种效果提供了少量预设样式，但如果不喜欢，你可以全部移除它们。

样式预设值（请参见下小节说明）

Sketch同时还提供了一个途径来保存完整的样式组合，其中包括描边、填充、阴影等等。你可以在文档窗口的左下方找到它们。在画布中选择一个图层，然后点击样式预设值中的任何一个，即可用预设值中的样式来替换选中图层的样式。

就像其他的预设值列表一样，你可以重新排序样式预设值，添加更多或者删除已经存在的预设值。

复制、粘贴样式

译者说明：新版 Sketch 取消了预设值面板，然而你仍然可以将画布中现有图层的样式复制给其他图层。方法是：


	选中要复制样式的图层，注意如果选中的是一个组合，则只能复制组合的整体效果；

	选择菜单“编辑 > 复制样式（Edit
 > Copy Style
 ）”或按下alt
 +cmd
 +c
 键；

	选中要应用（粘贴）样式的图层；

	选择菜单“编辑 > 粘贴样式（Edit
 > Paste Style
 ）”或按下alt
 +cmd
 +v
 键。



这时前一个图层的样式，包括填充、边框、阴影、字体等属性等会立即应用到后一个图层上。如果要继续应用同一套样式，重复3至4步。

颜色预设值
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颜色预设值是一个特例。就像你所知道的，Sketch拥有它自己的颜色选择器，也同样有一组自己的颜色预设值。如果你在Mac OS系统的颜色选择器中有已经有一系列的颜色预设值，Sketch在每次启动的时候会导入它们。如果你不想要这些预设值，请在OS X系统的颜色选择器中移除它们。

4.5 样式链接

样式链接是保持多个图层的样式同步的一种方法，例如，如果你让多个图层共享同一个样式，更新一个图层的边框，将会同样更新其他图层的边框。
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要激活样式链接，可以点击检查器右上角的“链接（Link
 ）”按钮，你将会看到检查器稍微下滑，显示出一行样式预设值的空间。按下+
 按钮来添加一个样式链接。然后选择另一个图层，点击你刚才创建的样式链接，来将样式链接到这个图层。图层的样式将会改变，现在当你改变其中任何一个图层的样式属性时，其他图层将会随之更新。

要移除样式链接，可以右击预设值，在弹出菜单中点击“移除（Remove
 ）”。

解除链接

假设你正在三个图层上共享同一个样式，然后想要从样式链接中分离一个图层（保持其余的两个样式链接不变），选中你要修改的图层，点击样式链接预设值中的第一个图标来解除这个图层的链接。这个图层的视觉样式保持不变，但如果改变它的任何样式属性，你会注意到，其他的图层将不再随之更新。





5 矢量编辑

Sketch提供了一系列的工具，可供用来编辑矢量对象。双击一个矢量对象（例如：一个形状）来直接对矢量点进行编辑，不过你还能找到一些其他选项：布尔操作可以将几个基本形状组合成为复杂的形状。剪刀工具可用来在一个形状上切去一部分。旋转复制是围绕一个特定点来创建形状副本的最佳工具，一个典型的例子就是创建花朵的花瓣。

5.1 矢量操作

矢量是由最基本的几何元素（例如直线和曲线）定义出的形状。与位图图像不同，基于矢量的图形格式例如PDF是非常灵活的，因为它们可以被缩放到任何大小，而不损失任何精确度。矢量图形是由一个点连接另一个点的直线和曲线组合而成的。一系列互相链接的直线和曲线组成一个单一的矢量路径。

矢量绘图

Sketch有三种方法可以添加一个矢量形状：


	矢量（Vector
 ）工具：从头开始，通过添加直线和曲线点来绘制矢量图；

	铅笔（Pencil
 ）工具：像用真实的铅笔绘图一样，你绘制一条曲线，Sketch为你平滑成一个矢量图；

	形状（Shape
 ）：这种方法最简单，并且通常可以作为首选。而且为使用其他工具例如变换和布尔操作提供了一个很好的开始。



矢量工具

首先介绍矢量工具。尽管在大多数绘图任务中，矢量工具并不是最佳选择。然而，在编辑现有矢量图形（例如矩形或椭圆形）中已经存在的点时，操作方式与用矢量工具画一个新形状非常类似。
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在工具条中点击矢量（Vector
 ）工具，然后在画布的任意地方单击，来添加第一个点。点击另外的某个地方来添加第二个点。你将会看到有一条直线连接着两个点。现在在某一个地方按下鼠标，保持鼠标按下并向外拖拽，这样可以绘制一个曲线。
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在新建的点旁边有两个小圆点，称为控制点。它们的位置决定了主点之间的曲线的精确走向。稍后会详细说明。关于如何进行矢量绘制，这里就是全部内容。当然，你可能还会想要修改刚刚画出的图形。

当矢量图形画好后，你可以再次点击第一个点，来得到一个封闭的路径。如果不需要封闭路径，你也可以按下Enter
 或Esc
 键，或者在工具条上取消选择矢量（Vector
 ）工具。

矢量编辑

当我们画好新的矢量图形，或者标准的形状如椭圆和矩形后，接下来的工作是对现有形状进行编辑。想要编辑现有的矢量图形，双击它。

矢量图形上的任何点都可以通过点击来被选中，选中的点会在画布上突出。然后你可以拖拽来移动它们，或者在键盘上按下backspace
 /delete
 来删除它们。你还可以双击一个点来添加或移除它两旁的控制点，从而使连接它的线条从直线变成曲线，或者相反。

点模式
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画布顶部的迷你工具条为选中的矢量点显示一些额外的设置。


	径直：当你直接在画布上单击，将会插入一个径直点，意味着没有控制点，两端都是笔直的线；

	对称：控制点互相对称，它们彼此相对、到主点的距离相等，如果一个矢量点是非径直的，默认选项是对称；

	不对称：控制点到主点之间的距离是独立变化的，但是方向彼此相对；

	不连贯：控制点彼此之间完全相互独立；

	圆形：这个点被渲染为指定半径的圆角。这是为矩形添加添加一或两个圆角的最好方式。



高级编辑

如果你按下⇧
 键，然后在一个矢量图象的末端添加新的点之前，新的点将出现在前一个点45º角倍数的方向上，这样便于创建整齐的线条。

如果新的点是插入到原有的两个点之间，新点则会精确地出现在原有点的连线上。如果你按下⌘
 键并且在两个点之间的连线上点击，Sketch将会精确地找到连线的中点，在这里插入新的点。

多重选择

某些操作可能无法一目了然，例如你可以选择多个点并且同时移动它们。想要选择多个点，在点击它们的时候按住⇧
 键。你将看到被选中的点突出显示，而没有被选中的则是灰色的。

另一种选择多个点的方式是按下⇧
 键，然后在可见的空白区域点击并拖拽来产生一个矩形选区。如果在释放鼠标前，你一直按住⇧
 键，将会在你之前选择的基础上扩大选中点的范围，增加矩形选区内包括的点；如果没有一直按住⇧
 键，将会取消选择之前选中的点，仅仅选择新圈中的点。

5.2 布尔操作

当你需要的形状并不属于标准形状时，你就要自己创建它们。最初的冲动可能是使用Sketch中的矢量工具来绘制一个形状。然而你将会发现，许多复杂的形状可以非常容易地拆分为基础形状的组合。布尔操作正是用来完成这样的工作：组合基础形状来创建更复杂的形状。

子路径

Sketch提供了动态的布尔操作。在深入讨论细节之前，我们可以快速回顾一下矢量形状。Sketch中的大部分形状都是由一系列的点组成，可以称它为一个路径。然而根据需要，一个形状可以包含许多个子路径，形状最终的外观取决于这些子路径的组合方式。

当你在Sketch中使用布尔操作时，它会把最上面的形状作为第二个形状的子路径加入，并且进行特定的布尔运算。因为在Sketch中的布尔操作是动态的，你可以对子路径进行任意调整。例如，如果其中一个子路径是矩形，你可以随时改变它的圆角半径。

布尔运算

这里有四种不同的布尔操作，你可以根据情况进行选择：


	联合（Union
 ）：联合操作的结果是两个矢量的面积的总和组成的一个矢量；

	相减（Subtract
 ）：减去操作的结果是将顶层形状形状覆盖部分从底层形状中移除所得到的一个矢量；

	相交（Intersect
 ）：相交操作的结果是原始形状互相重叠的区域组成的一个矢量；

	差异（Difference
 ）：差异操作的结果是它们互不不重叠的区域组成的一个矢量，差异与相交是互补的。
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图层列表
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如果在你画布，有一个形状是由多个子路径组成，看看它在图层列表中是怎么呈现的。就像普通的组合一样，你将会在左边看到一个展开箭头，如果展开它，将会列出当前形状的一系列子路径。注意在右边，你可以为每一个子路径分别选择各自的布尔操作。某个子路径可以采用相减运算，而其他子路径再在其上增加。

就像图层列表是从下到上排列的，子路径的排序也是如此。你选择的布尔操作将会组合图层和位于它下面的图层。如果图层还有子路径，这些操作的结果会作用到子路径上。

5.3 变换
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变换工具可用于对已有矢量进行变形，可以将图形变得倾斜，或者产生伪3D效果。你可以使用Sketch里的变换工具同时变换一个或多个图层。

选中一个或多个图层，点击工具条里的变换（Transform
 ）按钮。抓取四个角中的一个来自由变换形状，或者抓取边线中间的点，同时移动两个角来倾斜图层。

常规变换

除了以上的倾斜变形外，对图层进行缩放、旋转等变换操作，不需要点击变换按钮。只要直接选中图层，拖动图层周围的8个小手柄（方形），即可在不同方向上缩放和拉伸图层。按住⌘
 键可以旋转图层。具体详见选中、移动、改变大小章节
 。

5.4 剪刀工具

剪刀工具用于从一个已有的矢量形状上剪掉线段。选中一个已有的形状，然后在工具条里选中剪刀（Scissors
 ，默认不显示）图标，或者使用菜单选项中的“编辑 > 路径 > 剪刀（Edit > Paths > Scissors
 ）”。

接下来你可以点击矢量形状上的一条线来剪掉它。完成后，在形状以外单击，或者按下enter
 /esc
 键来退出剪刀工具。当只剩下一条线的时候，你将会自动退出剪刀工具。

5.5 旋转副本

这是Sketch里一个特殊的工具。它默认不在工具条中，不过你可以通过右击工具条选择“自定义（Customize
 ）”来添加它。在菜单中，“编辑 > 路径 > 旋转副本（Edit > Paths > Rotate Copies
 ）”同样可以找到它。
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这个工具会针对一个图层，围绕某个特定的点对图层进行旋转复制。举一个花朵的例子：仅创建一片叶子，然后围绕中心点旋转复制出十二个副本，你将会得到一朵花。

选中一个图层，激活旋转副本工具，键入副本的数量并关闭对话框。然后在任何你想的地方放置中心点，在中心点外点击或者取消选择工具来退出。

添加的全部副本形状都会被当作原始形状的子路径。如果你想要让它们完全分开，变成单独的图层，在菜单项中找到“编辑 > 路径 > 分离（Edit > Paths > Split
 ）”来将它们转换为单独的图层。

5.6 描边宽度工具

描边宽度工具允许你给边框设置可变的宽度。选中一个矢量并且使用选择器应用一个边框。然后使用菜单项中“编辑 > 路径 > 描边宽度（Edit > Paths > Stroke Width
 ）”激活描边宽度工具。现在点击画布上的边框，来设置一个宽度点。你可以从边框上拽出这个点，来使宽度变大或变小。
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描边宽度工具同样可以通过右击工具条区域选择“自定义工具条（Customize Toolbar...
 ）”添加到你的工具条中。





6 画布

Sketch的画布（Canvas）尺寸没有限制。当需要无限精确度的时候，你可以用与分辨率无关的方式查看画布；而如果想知道每个像素导出后的精确效果，你可以打开像素预览。

如果你喜欢在无限大的画布上定义一个固定的框架，只需使用画板（Artboard
 ）工具创建一个画板即可。

6.1 画板

在Sketch中，可以通过画板（Artboard）在无限大的画布（Canvas）上设置一个固定框架，但画板并非必须，是否创建画板完全取决于你。在文档中设置了画板后，画板外面的区域将会变淡，因此你可以清楚地看见哪些元素落在画布里，哪些没有。

如果正在做一个网站设计，你可能希望考虑不同尺寸的屏幕，并且将每种屏幕尺寸转换为相应的画板。如果你在制作图标，你可能希望以几种默认的图标尺寸来作为边界，那就可以为每个图标尺寸创建一个画板。当导出的时候，你可以将每个画板导出为一个独立的文件，就像导出切片一样。

添加画板
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想要添加画板，在工具条中选择画板（Artboard
 ）按钮。然后你可以在画布中点击并拖拽出一个矩形区域，来创建第一个画板。你可以在图层列表面板中给它命名、在检查器面板中修改它的属性、或者继续点击拖拽来创建更多的画板。在工具条中还有一些可供选择的预设值。你可以选择它们来用预设的大小来创建画板，Sketch将会自动帮你精确对齐新建的画板。

要注意的是，当你在图层列表中切换画板时，坐标尺寸将会以选中的画板左上角做为起点。

画板和切片
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你可能会疑惑画板和切片（Slice）有什么区别。实际上它们的区别不大，但不是所有的画布都能当切片来用，反之亦然。根据你要使用Sketch完成的工作，它们各有各的用途。记住切片的用途是导出。

举一个网站设计的例子，你可能需要为设计的每一种屏幕尺寸创建一个画板——在向客户展示时，通过画板导出完整的图像；而在实际制作网站时，你可能又希望从完整的设计切出较小的区域（比如按钮）来在HTML中使用它们——对这些按钮，就应该使用切片工具。如果仅仅因为不想要按钮以外的区域，而为这个按钮创建画板，就不太合适了。

如果在使用Sketch工作时，你发觉不需要使用画板，当然完全没问题，画板只是一个可选功能。

模板

使用画板的一个很好的例子是我们提供的默认模板。打开菜单“文件 > 从模板新建（ File > New From Template
 ）”，如果选择“Mac应用图标模板（Mac App Icon
 ）”，你会看到我们为常用的每一种尺寸创建了一个画板。

6.2 标尺、参考线、网格

这些特性将帮助你在 Sketch 中通过网格、直线或者其他图层来精确地将图层定位到你想要的位置。

参考线
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默认在 Sketch 中，打开了自动参考线功能，你可以通过 ^ L
 键进行切换。当你改变大小或移动图层的时候， Sketch 会尝试帮助你将它与其他图层自动对齐。当两个图层对齐时，你将会看到一条红色的线出现，这表示它们精确地对齐了。

距离和大小
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按住 option/alt （⌥
 ）键的时候， Sketch 会计算当前已选择的图层和你鼠标悬停的图层之间的距离。通过一个简单的实例来说明，如图：

同样的方式，如果你改变图层大小， Sketch 将会帮你指出其它拥有同样宽度或高度的图层。

标尺
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Sketch 提供标尺，标尺默认是隐藏的。通过菜单“视图 > 显示标尺（View > Show Rulers
 ）”可以切换标尺显示。就像我们之前说过的， Sketch 拥有无限大的画布，正因为如此，标尺是不固定的，你可以抓取、拖拽标尺到任何地方，来定义你自己零值原点。

你可以双击标尺上的任何地方来手工添加参考线，只要标尺处于显示状态，参考线会一直可见。在标尺空白部分抓取并来回拖动，可以移动标尺刻度；而如果在标尺上抓取参考线来回拖动，则可以移动参考线。想要删除参考线，将它拖拽到视图之外，你将会看到它伴随着噗一声消失了。

标准网格

[image: ]


可以通过菜单“视图 > 网格（Show Grid
 ）” 切换网格显示，这里也可以看到网格设置（Grid Settings...
 ）。Sketch支持两种网格，一种正常的标准网格、一种布局网格。根据你使用Sketch要做的工作不同，你可以选用其中的一种。不同之处是显而易见的：

在基本网格中，你可以设置正方形的大小，以及粗线出现的频度。默认网格的大小是20像素，并且每十格有一条粗线。

布局网格
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使用布局网格你可以改变“页面”的总体宽度和“列”数，同样也可以设置“行”的高度，还有对空隙（Gutter）的额外设置。

Sketch 会尽可能地把布局网格放置在画板的中间，但在调整画板大小之后，居中的位置可能就不对了，在这种情况下，按下“居中（Center
 ）”按钮，可以很容易地让布局网格在画板上居中。

6.3 像素缩放

在 Sketch 中，你有两种方式可以查看作品。选用那种查看方式，取决于你所做工作的类型。这两种模式可以通过点击“视图（Vew
 ）”菜单中的“显示/隐藏像素网格（Show/Hide Pixel Grid
 ）”来切换。应当注意，在100%缩放尺寸（真实大小）下，这两种模式看起来是一样的，但视图放大的时候就可以看出区别。

如果你关心每一个独立的像素在文档中看起来是怎样的，那么这种模式适合你用。你看到的基本相当于图像导出为png格式然后在预览应用程序中放大的效果。

如果像素不那么重要，传统视图对你来说就是最好的，当放大的时候，你看到的全部图像仍然会是平滑的曲线。

强制像素预览

有时候你会发现，不能禁用像素预览，即使你想这么做。

这是因为有些图层效果（模糊和颜色调整）必须使用原始的像素数据来进行计算。这意味着， Sketch 要显示这些效果的唯一方式，就是栅格化你的矢量对象，然后套用这些滤镜。这样造成的后果就是无法进行矢量预览，因此我们强制显示像素预览。

当你试图禁用像素缩放，但无法禁用的时候， Sketch 会提示哪一个图层要求强制像素缩放。在文档较大时，这样可以节约你很多时间。
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7 导入

Sketch 支持一系列文件格式的导入。你可以直接将文件拖拽到系统 Dock 中的 Sketch 图标上，或者直接拖到一个打开的文档中。

7.1 文件格式

支持的导入格式

Sketch支持一系列文件格式的导入。你可以直接将文件拖拽到系统dock中的Sketch图标上，或者直接拖到一个打开的文档中。


	
JPG
 ：一种常用的照片格式，但是它不支持透明。

	
PNG
 ：如果你的图画包含透明像素，这种格式是个不错的选择。

	
TIFF
 ：支持透明但是文件尺寸非常大。

	
EPS
 ：矢量图像文件格式，Sketch 2.3以后支持。

	
SVG
 ：支持这种格式的主要原因是一些其他的应用软件可以导出SVG格式。



不支持的导入格式

下面列出的文件格式是平面设计中常见的，但是目前Sketch还不支持。


	
PSD
 ：Sketch只能以合并位图形式导入.psd文件。

	
PDF
 ：Sketch 2.3以后可以导入.pdf文件中的矢量和位图图像，但对文字支持有限。

	
AI
 ：Sketch只能以合并位图形式导入.ai文件。







8 导出

想要导出你的作品，可以在菜单中选择“文件 > 导出（File > Export
 ）” ，或者点击工具条上的“导出（Export
 ）”按钮。Sketch 的画布是无限大的，这也就意味着想导出图片的时候，需要先告诉 Sketch ，你感兴趣的是哪部分。

8.1 切片
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在新文档第一次在工具条中点击“导出（Export
 ）”时， Sketch 会在你的文档中创建一个新的切片，来精确地包围住你画布中的全部元素。也许你不想要其中的一些元素，可以拖动切片的任意一边来调整大小。如果愿意，你可以在根据需要，在画布区域上通过简单的点击、拖拽来添加更多切片。

命名

你可以给每个切片起一个它自己的名字，这个名字在切片存盘时会用于文件名。

一个优雅的技巧：如果在命名中包含斜杠（/
 ），在存盘时会先创建一个子文件夹。例如，如果你将切片命名为 foo/bar.png
 ，它将会首先创建一个名字为 foo
 的文件夹，然后在这个文件夹下创建一个文件名为 bar.png
 的图片。

视网膜

在检查器中还有一个 @2x
 的复选框。如果选中它， Sketch 在导出正常图片之外，还会导出一个两倍分辨率的图片，并且为文件名添加 @2x
 后缀——这是 Apple 在应用程序中提供视网膜质量图片时的命名惯例，Sketch 将这一额外的步骤变得轻而易举。

只导出某些图层

默认每个切片将会包含在它边界范围内的所有图层（Include all layers
 ），不过你可以对切片进行设置，使它只导出选中的图层，选中“只包括下列图层（Only include the following:
 ”。 在这个选项下面，你会看到要被导出的图层列表，你可以给选中所想要导出图层前面的复选框。假设你正在设计一个网站，想要导出画布上的某个按钮图片。如果它包括了透明像素，你可能不想导出按钮后面的背景，使用上面描述的方法，你可以只导出相关的图层。

裁切

每个切片的最后一个选项就是“裁切透明像素（Trim transparent pixels
 ）”。当选项打开的时候，每一个切片将会在裁切掉四周的透明像素之后导出。

例如，你在文档某处定义了一个 30x40 像素的切片，但是它的内容是一个圆形，只有 15x15 像素。你不需要改变切片大小来精确地适合这个椭圆，只要打开裁切选项， Sketch 将会在 30x40 的切片中剪去透明像素，直到剩下一个 15x15 的图片。

在前述“只导出选中图层”的设置下，裁切功能同样有效。

8.2 文件格式

支持的导出格式


	
JPG
 ：一种常用的照片格式，但是不支持透明

	
PNG
 ：如果你的图画包含透明像素，这种格式是个不错的选择

	
TIFF
 ：支持透明但是文件尺寸较大

	
PDF
 和 EPS
 ：保留矢量对象。只提供基本支持

	
SVG
 ： SVG 格式对在形状和文本的支持非常好，但不支持阴影。使用这种格式的主要原因是其他一些应用程序可以导入 SVG 文件



不支持的导出格式


	
PSD
 ： Photoshop 的文件格式是封闭的，并且不支持导出。如果你手头有 Adobe Creative Suite ，你可以将工作导出成例如 .PDF 文件，然后导入到 Illustrator，然后再导出 PSD 文件。

	
AI
 ： Illustrator 文件格式也不支持，不过 Illustrator 可以打开 Sketch 导出的 PDF 文件。



8.3 CSS属性

Sketch 拥有一个友好的小功能，来帮助网页设计师将作品从静态的 Sketch 图样转化成真实的HTML 。

在画布中选择一些元素，然后你可以选择菜单中的“编辑 > 复制CSS属性（Edit > Copy CSS Attributes
 ）”。 Sketch 将会根据选中对象的边框、填充、渐变、阴影和文本样式来创建CSS声明。

Sketch 也会将渐变转化为 CSS 渐变格式。由于渐变的语法有一点复杂，这个功能可以节约大量时间。将 Sketch 中的设计转成 CSS ，现在已经非常方便了。

8.4 打印

Sketch 最多只有很基本的打印支持。目前我们的注意力集中在产生基于屏幕的图像，不过在实际工作中你可能偶而需要进行打印。

如果选择“文件 > 打印（File > Print
 ）”菜单，你首先需要告诉 Sketch 想打印哪一个画板或者切片。如果还没有创建切片， Sketch 会提示你先创建一个切片。

目前 Sketch 还不支持 DPI （每英寸点数，打印机、扫描仪等的清晰度参数）设置，也许在未来版本里会实现，现阶段我们不予置评。





9 设置选项

在Sketch的应用程序菜单选择“偏好设置（Preferences...
 ）”或者按下Cmd
 +,
 将打开设置对话框。

9.1 通用

以下是各个选项的中文翻译：

在启动时：


	创建新文档



新建组合


	新建的组合允许深度点击



如果启用了深度点击，你就可以在画布中直接选中组合内的对象，而不需要先进入组合。如果关闭此选项，你仍然可以通过按住Cmd
 键来进行深度点击。

撤销


	将类似的操作组合在一起



一次撤销将同时撤销短时间内连续进行的类似操作。

字体渲染


	对字体进行子像素反锯齿



允许子像素反锯齿，可以精确获得在Mac上字体渲染效果。iOS设备不支持子像素反锯齿，所以要精确渲染后者效果，禁用该项。

字体检查器


	允许字体预览



启用脚本

9.2 画布

以下是各个选项的中文翻译：

视网膜


	视网膜画布



你是想看到同样尺寸、更多细节的画面，还是想看到精确像素、尺寸更小的画面呢？

缩放


	动画缩放

	放大到选中内容

	缩小时恢复之前画布位置



当缩小到实际大小时，Sketch默认会沿中心缩放。你也可以选择让它缩小到放大前的位置。

布局网格


	填充网格

	描绘边框



网格颜色


	暗、亮、辅助线



9.3 图层

以下是各个选项的中文翻译：

新形状


	绘制

	立即插入



可以按住Opt
 键切换

新建组合


	改变大小时保持比例



副本操作


	对粘贴和副本对象进行偏移

	在副本对象名称后添加“Copy”



对齐


	适应像素范围



文本图层


	粘贴时清理文本样式

	改变文本图层的字体尺寸



当对文本图层进行改变大小操作时，字体大小随之改变。

9.3.1 对粘贴和副本对象进行偏移

“对粘贴和副本对象进行偏移（Offset pasted & duplicated objects
 ）”复选框的功能是，在进行复制/粘贴（Copy/Paste）或者副本（Duplicate）操作时，所产生的新对象会有10x10像素的偏移。如果取消选中该复选框，新对象将会被粘贴到与原对象完全相同的位置。





10 脚本

激活脚本

想要在 Sketch 中激活脚本，在菜单中选择“ Sketch > 首选项（Preferences...
 ）”，选中“通用（General
 ）”选项卡，并点击“启用脚本（Enable Scripting
 ）”。一个新的叫做“插件（Plugins
 ）”的菜单项会出现在菜单条中。在这里，通过点击“自定义脚本（Custom Script...
 ）”你可以开始写你自己的脚本。

安装脚本

脚本文件应该有 .jstalk
 扩展名，并且放在 ~/library/application support/sketch/plugins
 文件夹下。如果你正在运行的 Sketch 是通过 App Store 安装的，它会处于沙盒中，相应地你的脚本需要放在 ~/Library/Containers/com.bohemiancoding.sketch/Data/Library/Application Support/sketch/Plugins
 下。

接下来，插件会显示在 Sketch 的插件菜单中。插件的名字是文件名，你甚至可以给它设一个自定义的快捷键。

语法

要了解更多关于 JSTalk 的信息和它的语法，访问 JSTalk.org
 。

前文

Sketch 会在每一个运行的脚本前面添加下面的代码片段。通过这种方式，你可以放问到常用的变量。


var doc = [[NSDocumentController sharedDocumentController] currentDocument]; 
var selection = doc.selectedLayers(); 




快捷键

你可以为插件的菜单项设置一个快捷键。方法如下：第一行应该是注释，用来解释这个脚本的用途。在第一行的某个地方，你可以在括号之间放置快捷键。例如：


// just a comment (cmd y) // (ctrl alt cmd t) 




最后一个字符是快捷键，它前面是要按下的组合键。下面的组合键都是有效的：


control ctrl alt option cmd command shift




注意，一旦你安装了一个插件，你可以通过“插件 > 自定义脚本（Plugins> Custom Script
 ）”菜单来运行任意的自定义脚本。

实例

我们认为，相对于展示头文件，通过提供实例来解释 API 的用法更好。如下：


	
将选中对象变成方形


	
创建一个对象的 5x5 阵列


	
创建一个对象的 5 个副本，附加不透明度的变化


	
用户输入示例


	
导出区域


	
缩放到一个区域




全部实例也都可以在 GitHub
 下载到。

要求用户输入

通过以下方法，脚本可以提示用户进行输入。返回值是字符串——可以很容易转换为整形或浮点型数值。两个参数是必须的：一个短标签来提示用户，以及输入区的默认值：


[doc askForUserInput:"How many times?" initialValue:10];




参见 用户输入示例
 中的实际用法

API


	
MSDocument


	
MSContentDrawView


	
MSLayer


	
MSLayerGroup


	
MSRect


	
MSStyle


	
MSPage


	
MSDocument


	
MSArtboardGroup


	
MSSliceLayer




以上的任意一个脚本都可以保存为 .jstalk 文件，放进之前提到的文件夹下，它们会工作得很好。

第三方脚本

要找到更多的 Sketch 脚本，可以看看 @bomberstudios
 建立的代码库，如下:


	
https://github.com/bomberstudios/sketch-commands




要了解 API 的重大修改，请查看 changelog
 。
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Sketch 拥有相当多的快捷键，当你使用 Sketch 完成大量工作的时候，了解快捷键很有用处。

通用快捷键


	
control+h
 ：切换选择手柄

	
control+l
 ：切换对齐参考线

	
control+g
 ：切换网格

	
Space
 ：小手工具

	
Enter
 ：编辑当前选中的图层

	
⌘+3
 ：滚动到选中的图层

	
⌘+2
 ：放大到选中的图层

	
Z
 ：缩放工具。用鼠标按下并且点击或者拖拽一个缩放区域，反转缩放用 Z + Alt
 + 点击

	
Escape
 ：退出，退出当前的工具，取消选中所有的图层，或者在检查器中后退

	
Tab/Shift-tab
 ：在当前组合中切换选中图层



插入图层


	
r
 ：插入一个矩形（Rectangle）

	
o
 ：插入一个椭圆（Oval）

	
l
 ：插入一条直线（Line）

	
u
 ：插入一个圆角矩形（Rounded）

	
t
 ：插入一个文字图层（Text）

	
v
 ：矢量图层（Vector）

	
p
 ：铅笔工具（Pencil）



移动和缩放图层


	
alt
 + 拖放：制作图层副本

	`alt + 悬停：显示和其它图层的间距

	
alt
 + 改变大小：从两端向中间缩放

	
shift
 + 改变大小：等比例缩放



这些是一些隐藏的快捷键，当然还有许多快捷键会列在菜单中。精通键盘快捷键的使用，将会帮助你极大地提升工作效率。

如果你觉得某些功能需要更好的屏幕截图来说明，请让我们知道。

隐藏的命令

Sketch 有一些隐藏的参数，适合某些高级的用途。要使用这些命令，请打开终端应用程序，输入这些命令。为使命令生效， Sketch 需要重新启动。想要禁用这些设置中的任意一个，请将 YES
 为 NO
 ，反之亦然。


defaults write com.bohemiancoding.sketch svgExportSkipAssignIdToLayerName -bool YES 




当这一项被设置为 YES 时， Sketch 在导出的SVG文件时，将不会使用图层的名字做为 ID 字段。

对于希望将 Sketch 用于某些小众功能的用户来说，我们可以像这样通过特殊设置来实现。如果你有这样的想法，请联系我们。





12 英汉术语对照

本手册用到了大量的图像处理词汇，在翻译中，我们参照了某款用户最广泛的图形软件在Mac下的最新简体中文版，尽量保证翻译一致。但译者水平有限，百密一疏，如果在阅读中见到不知所云的词汇，可以来这里看看。
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